Jump to content

Photo

Installation crashes by some languages (RC1)


  • Please log in to reply
9 replies to this topic

#1 BALLOON a.k.a. Fu-sen.

BALLOON a.k.a. Fu-sen.

    Member

  • Members
  • 123 posts

Posted 10 June 2014 - 02:27 AM

The problem that an installer crashes by some languages is not improved in RC1 either:

http://forums.bodhil...nstaller-crash/

I install it in Japanese:
Attached File  bodhi3installjpclash.jpg   164.15KB   13 downloads

I thought about one possibility. It is free space lack.
May Bodhi 3 produce an error by free space lack of the working area?
When I was going to start some application, after installer crash, Enlightenment required recovery.

The output log had only this:
Error Information:
	An exit code of 1 was returned from sudo ubiquity gtk_ui.

Output Data:
	There was no output

Error Logs:
	There was no error message




A big thank you to everyone who contributes to Bodhi Linux


#2 Jeff

Jeff

    Lead Developer

  • Developer
  • 12437 posts
  • LocationBloomington, IL

Posted 10 June 2014 - 03:20 AM

No one provided a fix for this issue with the beta. I clearly stated that unless someone else debugs this I am not getting a fix done.

For the RC2 the installer will just be English only if no one else pins down the reason for this crash.

~Jeff

#3 BALLOON a.k.a. Fu-sen.

BALLOON a.k.a. Fu-sen.

    Member

  • Members
  • 123 posts

Posted 23 June 2014 - 07:11 AM

I finally got the solution to this problem. :blink: :unsure: :o

I found log of the installation in /var/log/install/debug ,
The output of the log became like this:
locale.setlocale failed: unsupported locale setting (LANG=ja_JP.UTF-8)
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = "ja_JP.UTF-8",
	LC_ALL = (unset),
	LANG = "ja_JP.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
It was simple. There was not a locale file.

I executed the command for trial from terminology:
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get language-pack-ja
(When you perform it, please change "ja" into an objective language.)

As a result, I chose Japanese and was able to finish installation.

I think the installer to have downloaded the package.
If jeff grasps this method, it may be settled.
Or Bodhi 3 may solve this including this if size of locale files is small.

Attached Files



#4 Jeff

Jeff

    Lead Developer

  • Developer
  • 12437 posts
  • LocationBloomington, IL

Posted 23 June 2014 - 04:44 PM

Hrm, adding 50 language packs to the live image is going to double the disc size. Not sure this is a reasonable option.

~Jeff

#5 kuuko

kuuko

    Powerful E Wizard

  • Developer
  • 229 posts
  • LocationHelsinki, Finland

Posted 23 June 2014 - 04:49 PM

The thing that's making it crash seems to be the fact that the default locale doesn't exist.
account_tiny.gif

#6 BALLOON a.k.a. Fu-sen.

BALLOON a.k.a. Fu-sen.

    Member

  • Members
  • 123 posts

Posted 24 June 2014 - 01:32 AM

Hrm, adding 50 language packs to the live image is going to double the disc size. Not sure this is a reasonable option.

There was not this problem in Bodhi 2. Probably it may be settled with a small package.
I investigate the package,

#7 BALLOON a.k.a. Fu-sen.

BALLOON a.k.a. Fu-sen.

    Member

  • Members
  • 123 posts

Posted 24 June 2014 - 02:18 AM

The solution did not have to install a package.
cd /usr/share/locales
./install-language-pack ja
dpkg-reconfigure locales
I succeeded in installation in this. :D
When you perform it, please change it into a language using ja (=Japanese).

This cord may become the hint of the solution:
https://gist.github....derwear/1218856

#8 The waiter

The waiter

    Module Master

  • Developer
  • 1584 posts
  • LocationBanska Bystrica, Slovakia

Posted 01 July 2014 - 07:45 PM

If I read this forum post, I wouldn't waste such much time. Today I gave up installing Bodhi 3.0 RC1 and decided to install 2.4. As I am reading this forum, I realized there might have been something wrong with locale files. I saw something wrong in dmesg. Next time I will install slovak locale pack...

#9 Matias

Matias

    Member

  • Members
  • 5 posts

Posted 24 July 2014 - 02:41 PM

Hello everyone.

The same happened to me, I wanted to install it in Spanish, but the installation fails.

I solved installing it in English.
Once installed, select the language and other settings ....

To permanently resolve and not have to put in the image a lot of languages packs. It would be nice to have the installer minimalist look, which only has icons buttons and pictures representing the actions?

Greetings.

#10 icke68746

icke68746

    Member

  • Members
  • 28 posts
  • LocationGermany

Posted 29 July 2014 - 11:27 AM

Hi there,

I have now bodhi bodhi-3.0.0-64bit-rc1 reinstalled. If you choose to load the German installation without the live environment, the installer crashes. If you start (with an internet connection) within the live environment the installation again, the installation works (with German language).

Greetings Mike
--Original--
Hallo zusammen,

ich habe jetzt Bodhi bodhi-3.0.0-64bit-rc1 neu installiert. Wählt man die deutsche Installation ohne die Live-Umgebung zu laden, stürzt der Installer ab. Startet man (mit bestehender Internetverbindung) innerhalb der Live-Umgebung die Installation erneut, klappt die Installation (mit deutscher Sprache).

Gruß Mike

Translated with Google.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users