Jump to content


3.0 legacy RC2 - a couple of relevant issues

  • Please log in to reply
7 replies to this topic

#1 stupenDOS



  • Members
  • 5 posts

Posted 21 November 2014 - 09:22 PM

Hallo all.
I'm a newbie of Linux, I met Bodhi 2.4 short time ago and it was a nice surprise: you all guys did a really good job and I enjoy using Bodhi.

To make useful again a N450 Acer netbook, I've installed 3.0 RC1 first, but e19 is too slow.
3.0 RC2 e17, instead, runs smoothly, anyway I had to move back to 2.4 due to a couple of issues I tried to solve with no success.

#1: econnman is totally unstable. Spent lot of time trying to configure, connect, reboot, scan, launch from terminal, etc.
Each connection lasts a few seconds or a little more. No chance to use the internet.

#2: I'm sure it is up to me, but I'm unable to configure the keyboard. I didn't find keyboard settings, and during installation the option for different keyboards didn't appear (or, if it appears, it doesn't work - I don't remember for sure). It has been fun to search the position of US keys...

It was just to give a small participation in a great project.

A big thank you to everyone who contributes to Bodhi Linux

#2 Deepspeed


    Sir Creeps-a-lot

  • Developer
  • 599 posts

Posted 22 November 2014 - 06:48 AM

The problem with e19 being slow on some types of processors isn't new. That's why the legacy version will use e17 from now on.

For your keyboard settings, go to start > settings > modules, then scroll down to the keyboard module, select it, and hit apply. It should appear on the shelf. Click the module on the shelf and go to settings. Then click add and select the new keyboard type you'd like to use.

for wifi, try
sudo rfkill list all
to see if anything is blocked.

If you have softblocks, be sure you're turning wifi on in the drop-down menu of the econnman module on the shelf. It should scan automatically and show any available networks in that menu a few seconds after it's turned on, and you should just be able to click to connect. Or you could do...
sudo rfkill unblock all
Then do list all again to be sure they're unblocked.

If you have hardblocks, there's a wifi switch turned off on your pc somewhere.

If none of that helps, try pasting the results of
here for us, and we'll go from there.

#3 stupenDOS



  • Members
  • 5 posts

Posted 22 November 2014 - 11:22 AM

Thanks Deepspeed,
sorry no can do as I moved back to 2.4

Consider that my wifi now is working fine and nothing has been changed.
To be clear, with 3.0 RC2 econnman was able to scan and connect to various wifi, disconnecting within seconds or minutes. Tried also econnman-bin -a, read somewhere.
Weird failure, do you know only this case?

#4 Charles@Bodhi


    Old Faithful

  • Moderators
  • 4752 posts
  • LocationZeist, The Netherlands

Posted 22 November 2014 - 02:33 PM

Might be a driver issue that's only appearing with the 3.0 release.
Could you provide the outcome of
lspci -nnk | grep 0280

Would be useful to know what's going on, on most of my different machines wifi has worked out of the box. The one that did not had a problematic Broadcom chip that needed some work to be done.


#5 stupenDOS



  • Members
  • 5 posts

Posted 16 December 2014 - 07:22 AM

Hi Charles. Here it is.

02:00.0 Network controller [0280]: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)

#6 Sitting Fox

Sitting Fox


  • Team
  • 551 posts

Posted 16 December 2014 - 08:17 PM

Hey stupenDOS,

Something you didn't mention was how things worked on the e19 version, either because you didn't really play with it or because it didn't give you the same problem. (Not a mind reader so :lol: )

Bodhi 3 RC2 Legacy uses a much older kernel, which is found in the non-PAE version of Bodhi 2.4.0 (which I'll guess you aren't using). I wonder if that played a part at all.

Reminds me, I should post on my own legacy experience.

#7 stupenDOS



  • Members
  • 5 posts

Posted 24 December 2014 - 09:37 PM

I don't remember how econnman worked on e19. I played with e19 just for a while because it was 'unplayable'.

Actually I played shortly with e17 RC2 too because it was impossible to install anything.

#8 Sitting Fox

Sitting Fox


  • Team
  • 551 posts

Posted 25 December 2014 - 02:44 AM


Hmm, well, I guess I can't guess if it's eConnman or the older kernel, or maybe something else. Too many unknowns at work.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users