Jump to content


No Wi-Fi on ASUS X75V fixed

  • Please log in to reply
3 replies to this topic

#1 sleeeepwalker



  • Members
  • 1 posts

Posted 10 December 2014 - 10:59 AM

Hope I'm okay to share this, when I upgraded from bodhi 2.4 the wireless on my ASUS X75V no longer worked. After some searching it appears that this problem affects quite a few ASUS laptops and is not a bodhi specific problem, I found a simple solution posted in the ubuntu forums by someone who in turn found it on the fedora forums.

As root, create a file with a name like asus-wifi.conf in /etc/modprobe.d/ containing:

options asus_nb_wmi wapf=1

After reboot, wifi should be on.

A big thank you to everyone who contributes to Bodhi Linux

#2 Charles@Bodhi


    Old Faithful

  • Moderators
  • 4752 posts
  • LocationZeist, The Netherlands

Posted 10 December 2014 - 11:41 AM

Thanks for sharing and welcome to the forums. :)


#3 robot443



  • Members
  • 3 posts

Posted 16 December 2014 - 07:16 PM

I had a similar problem on a Hp Elitebook 8740w, no wi-fi in the installer and no cable internet either. The cable net was easily solved, just make sure the cable is attached to the router and PC before starting the PC/installer.

On startup after the install I could not get wi-fi at all with eConnMan, in fact pressing the wi-fi symbol button found on Elitebooks above the f-keys (inline with the power button, volume controls etc) meant that eConnMan turned my bluetooth on/off.
showed eth0 & lo, nothing else.

What I did to fix this was to do what I always do, any distro, any release: I installed wicd and removed eConnMan. I know Linux is all about choice, but can someone tell me why anything other than wicd is ever a consideration? Wicd immediately searched and found all available networks and all I had to do to "configure" my wi-fi was to type my password. Done.

I also had a mesage on boot booting system without full network configuration which I thought was related. It did not interrupt the boot process, (but google it and it looks like that is a problem for a lot of other people). So I ran
sudo dpkg-reconfigure lightdm
and that seems to have solved it. It isn't network related from what I can gather. Instead it is just the last error message you see before the real issue occurs. Also, it isn't a Bodhi thing, it's seems to be inherited from Ubuntu 14.x(04?) directly.

I hope this info helps someone else, really love this OS and want to see it continue (thanks go to Jeff and all the new people).

#4 The waiter

The waiter

    Module Master

  • Developer
  • 1834 posts
  • LocationBanska Bystrica, Slovakia

Posted 01 January 2015 - 09:44 PM

I have just written some words related to this in other topic. I had some troubles similar to yours and installing linux-image-extra-3.16 simply solved my all issues.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users