Jump to content

Photo

Wrong program for "Show In Folder"


  • Please log in to reply
15 replies to this topic

#1 DaveL60

DaveL60

    Member

  • Members
  • 196 posts
  • LocationEastern USA

Posted 21 June 2015 - 12:33 PM

I use Chrome as my primary browser, and have installed PCFileMan as my preferred file manager.  When I downloaded a file with Chrome, right-clicked on the file in the browser and picked "Show In Folder", instead of the file manager Bodhi loaded Ephoto, aimed at the download directory. Can someone point me at where to fix this behavior? I've got zero idea.  Thanks,

 

DaveL





A big thank you to everyone who contributes to Bodhi Linux


#2 ylee

ylee

    King of the Software Page

  • Moderators
  • 1577 posts
  • LocationSouth Carolina, USA

Posted 21 June 2015 - 08:34 PM

I am not really sure if you are using Chrome or chromium-browser  but regardless I think maybe the problem is xdg-open does not have a mime-type for "application/x-directory" registered by default on Bodhi3.0 or even other debian/ubuntu systems. Chrome and related browsers seem to be using xdg-open to open files in a file browser ... based on results I found googling around.

 

Anyways close Chrome and then open a terminal: and Install mimeinfo-perl on your system

sudo apt-get install libfile-mimeinfo-perl

Now use the mimeopen command to open some random folder on your system:

mimeopen -d /path/to/folder

 When mimeopen runs, it will list the options for setting the default application to open the application/x-directory mime type. Simply choose pcmanfm which hopefully is listed.

 

NOTE: I don't use chrome/chromium at all nor have I have I looked thru its source code and my testing of this was in virtual box on a default install of bodhi3.0 so no guarantees...


"No technology can ever be too arcane or complicated for the black t-shirt crowd."


#3 disadjusted

disadjusted

    Member

  • Members
  • 92 posts
  • LocationSouth West Germany

Posted 22 June 2015 - 08:10 AM

i think mimeopen needs to be run with sudo as well to change the default behaviour...



#4 ylee

ylee

    King of the Software Page

  • Moderators
  • 1577 posts
  • LocationSouth Carolina, USA

Posted 22 June 2015 - 08:52 PM

i think mimeopen needs to be run with sudo as well to change the default behaviour...

 

Sudo is not needed for a single user system as the command run as an ordinary user only changes the association for that user. Running the command as root should change the association for all users ')


"No technology can ever be too arcane or complicated for the black t-shirt crowd."


#5 obloco

obloco

    Member

  • Members
  • 2 posts

Posted 25 January 2016 - 11:15 PM

Really liking Bodhi 3.1.1 for the most part, but...

 

Having the same problem across multiple programs.

Chrome

Firefox

Uget

and others.

 

open containing folder

show in folder

 

no matter what type of file is involved, all launch Ephoto.

 

If I uninstall Ephoto, selecting 'open containing folder' launches Firefox.

 

Tried the miimeopen trick with several different directories, but I always get 'Could not determine mimetype for file' and never get asked what program should be chosen.

 

There must be somewhere one can select what applications launch in certain circumstances.

 

This worked fine in 2.4.0 ?



#6 obloco

obloco

    Member

  • Members
  • 2 posts

Posted 10 February 2016 - 12:21 AM

Found a way to fix this finally.

 

Open PCManFM

Right Click on a Folder, any Folder

select Open With...

select PCManFm as the program to use

check the box for "Set selected application as default action for this file type"

click OK.

 

Now Chrome and other applications with "open folder" options will open PCManFM and view the folder instead of launching EPhoto.



#7 Suncatcher

Suncatcher

    Member

  • Members
  • 70 posts

Posted 07 November 2016 - 07:58 AM

Open PCManFM

Right Click on a Folder, any Folder

select Open With...

select PCManFm as the program to use

check the box for "Set selected application as default action for this file type"

click OK.

 

BTW, Bodhi 4 and the same problem. How were you able to do it?

I tried this solution but PCManFM is NOT SHOWED in Applications list, only in the main menu under the name "Places". So I cannot select it in "Open with" because only Applications are listed there.

Any suggestions?



#8 Jeff

Jeff

    Lead Developer

  • Developer
  • 12493 posts
  • LocationBloomington, IL

Posted 07 November 2016 - 01:36 PM

These settings seem to do the trick:

dwNWFRa.png



#9 Suncatcher

Suncatcher

    Member

  • Members
  • 70 posts

Posted 08 November 2016 - 06:21 PM

These settings seem to do the trick:

 

No, this hasn't helped. From Midori it still opens in wrong application (in File Roller).



#10 Jeff

Jeff

    Lead Developer

  • Developer
  • 12493 posts
  • LocationBloomington, IL

Posted 08 November 2016 - 09:59 PM

No, this hasn't helped. From Midori it still opens in wrong application (in File Roller).

 

Midori is different from Chrome (which is what this thread is about). In midori there are file type options in the preferences. 



#11 Suncatcher

Suncatcher

    Member

  • Members
  • 70 posts

Posted 09 November 2016 - 07:57 AM

Well, while we see folder type is explicitiely bound to PCManFM, Midory presumably treat them as "unknown".

 

v3wvYk8.png

And we still missing PCManFM in the app list we can choose from, and unfortunately there is no way to explicitely enter command here.

 

kcoBBin.png

 

My steps?



#12 Jeff

Jeff

    Lead Developer

  • Developer
  • 12493 posts
  • LocationBloomington, IL

Posted 09 November 2016 - 02:12 PM

Create a personal launcher for PCManFM if you need one. You can also get the default one back by running the command:

 

sudo apt-get install --reinstall pcmanfm


#13 Suncatcher

Suncatcher

    Member

  • Members
  • 70 posts

Posted 14 November 2016 - 09:11 AM

 

Create a personal launcher for PCManFM if you need one. You can also get the default one back by running the command:

sudo apt-get install --reinstall pcmanfm

 

Unfortunately this didn't help. It seems file associations are stored in some file and reinstall cannot change them. But in what file?



#14 Randy

Randy

    Bodhi-Care

  • Members
  • 646 posts
  • LocationFort Wayne, IN USA

Posted 14 November 2016 - 10:23 AM

I believe that app list for midori is for downloaded files with explicit file extensions like .pdf or .docx 


Randy Fry



Linux Addict!

#15 Suncatcher

Suncatcher

    Member

  • Members
  • 70 posts

Posted 19 November 2016 - 11:37 AM

I believe that app list for midori is for downloaded files with explicit file extensions like .pdf or .docx 

 

But PDF per se opens perfectly if I double-click it. The problem persists particularly with "Show if folder" function.



#16 Suncatcher

Suncatcher

    Member

  • Members
  • 70 posts

Posted 19 November 2016 - 09:32 PM

Finally solved this by purging file-roller completely and reinstalling again. After that App prompt appeared again and I was able to select pcmanfm again.

Interesting that even TOTAL erasing of all midori configs across all filesystem haven't helped. Some bizarre stuff.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users