Jump to content

Photo

edje_cc error

e17

  • Please log in to reply
14 replies to this topic

#1 jjbenitez

jjbenitez

    Member

  • Members
  • 7 posts

Posted 25 October 2015 - 05:27 PM

Hello

I use edje_decc to decc a e17 theme, and work perfect, but if i run in terminal

edje_cc Radiance/default.edc -o myRac.edj, example, i have the next error:

fireball/fireball.edc:15 unhandled keyword spectrum

Can anybody help me ?

 





A big thank you to everyone who contributes to Bodhi Linux


#2 Duma

Duma

    Artist

  • Members
  • 2392 posts
  • LocationRivalta (TO) - Italia

Posted 25 October 2015 - 06:29 PM

what kind of edits have you done at Radiance theme? :D

 

spectrum was an old E component, so you can remove easly all the spectrum part to skip this error.

 

http://forums.bodhil...ge-2#entry24032

 

Here some talk we've made years ago about it.


Se sei italiano e interessato a Linux, clicca qui!

#3 jjbenitez

jjbenitez

    Member

  • Members
  • 7 posts

Posted 25 October 2015 - 11:15 PM

Thanks for your answer.

My real problem is a black space in windows borders, using Radiance theme, but when i try to fix that using : http://forums.bodhil...eme/#entry89592, i get the next error:

Radiance/edc/comp.edc:17 float -1.000 out of range of 0.000 to 1.000 inclusive

 

How i fix that problem ?

Sorry for my very bad english,



#4 Duma

Duma

    Artist

  • Members
  • 2392 posts
  • LocationRivalta (TO) - Italia

Posted 25 October 2015 - 11:42 PM

What black space have you noticed? Did you mean the black around rounded border?


Se sei italiano e interessato a Linux, clicca qui!

#5 jjbenitez

jjbenitez

    Member

  • Members
  • 7 posts

Posted 25 October 2015 - 11:46 PM

Yes



#6 jjbenitez

jjbenitez

    Member

  • Members
  • 7 posts

Posted 26 October 2015 - 12:44 AM

everything I do with edje_cc gives me the error:

</some/file:line> float -1.000 out of range of 0.000 to 1.000 inclusive

???



#7 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4313 posts
  • LocationZeist, The Netherlands

Posted 26 October 2015 - 10:26 AM

Looks like "-1.000" is interpreted as a negative number that is not allowed. Possibly the syntax in that lines needs some attention. Is that dash "-" needed?

 

Enjoy,

Charles


Medion S4216 Ultrabook, 4GB RAM, 1TB HDD, WIN 10 & Bodhi 2.4.0-64 & Bodhi 3.0.0-64 

Asus eeepc 901, 1GB RAM, 12 GB SSD, Bodhi 2.4.0-32 non-pae & Bodhi 3.0.0-32-Legacy


#8 Duma

Duma

    Artist

  • Members
  • 2392 posts
  • LocationRivalta (TO) - Italia

Posted 26 October 2015 - 08:20 PM

Yes

Have you considered to use a compositor? This should fix the problem.

Are you sure that you are using E17 version of Radiance and not the e19 one? Where do you have take the theme?

 

Last chanche.

Copy the rad_conf.edc file from Radiance theme, decompile MokshaRadiance and replace its rad_conf.edc file with the Radiance one.

 

With this you should have sqaured border with Radiance colors and not MokshaRadiance's ones.


Se sei italiano e interessato a Linux, clicca qui!

#9 jjbenitez

jjbenitez

    Member

  • Members
  • 7 posts

Posted 27 October 2015 - 12:02 AM

Personally, I do not like compositors.
The header of file default.edc of the theme is:
 *              <RADIANCE THEME>                      *
 *                                                                       *
 * The E17 Port of the GTK Radiance theme.   *
if the theme had square edges I was happy.
How hard is this?


#10 Jeff

Jeff

    Lead Developer

  • Developer
  • 12328 posts
  • LocationBloomington, IL

Posted 27 October 2015 - 01:23 AM

The MokshaRadiance theme has square corners by default. You can find the source here -> https://github.com/J.../MokshaRadiance



#11 jjbenitez

jjbenitez

    Member

  • Members
  • 7 posts

Posted 27 October 2015 - 03:45 AM

Well, when i try to build MokshaRadiance: Surprise !!

My friend the error:

edc/comp.edc:17 float -1.000 out of range of 0.000 to 1.000 inclusive
edje_cc: Error. PARSE STACK:
collections.group.parts.part.description.text.ellipsis
edje_cc: Error. PARAMS:
edje_cc: Error.   -1

HELP !!



#12 Jeff

Jeff

    Lead Developer

  • Developer
  • 12328 posts
  • LocationBloomington, IL

Posted 27 October 2015 - 03:47 AM

What version of E / EFL are you using?



#13 jjbenitez

jjbenitez

    Member

  • Members
  • 7 posts

Posted 27 October 2015 - 03:37 PM

E: 0.17.3-3

EFL ? How do I know which version of EFL I use?



#14 Jeff

Jeff

    Lead Developer

  • Developer
  • 12328 posts
  • LocationBloomington, IL

Posted 27 October 2015 - 05:21 PM

How did you install said EFL version? If you are using an E version that old I'm betting your EFL version is old as well and that is why it is not working with these up to date themes.



#15 Duma

Duma

    Artist

  • Members
  • 2392 posts
  • LocationRivalta (TO) - Italia

Posted 27 October 2015 - 05:46 PM

I was sure you were on bodhi with moksha, maybe I was wrong? :D
Se sei italiano e interessato a Linux, clicca qui!





Also tagged with one or more of these keywords: e17

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users