Jump to content

Photo

Can't install GRUB on GPT HDD (UEFI boot)

GPT GRUB

  • Please log in to reply
4 replies to this topic

#1 RobinHood2016

RobinHood2016

    Member

  • Members
  • 1 posts

Posted 17 December 2015 - 07:28 PM

Hello,

 

I have a GPT with Windows 10 on my HDD, and I'm trying to install Bodhi Linux on it. My problem is, I can't install GRUB, and the installation crashes. What's wrong here?





A big thank you to everyone who contributes to Bodhi Linux


#2 eric52

eric52

    Member

  • Members
  • 35 posts
  • LocationSouthbury CT

Posted 17 December 2015 - 09:06 PM

I don't believe Grub kens GPT and needs to tricked with a small partition it can recognize and work with.


Today only. Anger not. Worry not. Be grateful working karma. Be kind.


#3 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4352 posts
  • LocationZeist, The Netherlands

Posted 17 December 2015 - 10:23 PM

Bodhi and Grub can very well handle GPT disks and the UEFI type of Bios. But:

 

This has happened to me a few times and I have heard of others suffering from it. I'm still trying to debug the fenomenen.
 
You can correct this.
Most simple would be having another working Linux and running 
sudo update-grub
once booted in there. This way you could boot into your new Bodhi using the other bootloader.
 
The second way is using a live CD (64bit). I will explain how:
 
First determine the partition your new install is on, let's presume sdaX for your system and sdaY for your Efi-partition
Use sudo parted -l to get a nice listing of your HDD. In the commands replace sdaX and sdaY with your real partitions.
cd /
sudo su
mount -t ext4 /dev/sdaX /mnt
mount -t proc proc /mnt/proc
mount -t sysfs sys /mnt/sys
mount -o bind /dev /mnt/dev
mount -t vfat dev/sdaY /mnt/boot/efi


#  might be needed for going online:
cp -L /etc/resolv.conf /mnt/etc/resolv.conf


# next step will let you enter the Bodhi-Install.
chroot /mnt /bin/bash


# for working with grub do
grep -v rootfs /proc/mounts > /etc/mtab


# additional helpers and reminder
source /etc/profile
export PS1="(chroot) $PS1"  # add a reminder to your prompt
Now the extra work for the Grub installation. First get the right packages:
apt-get update
apt-get install efibootmgr grub-common grub2-common grub-efi-amd64-bin grub-efi-amd64 grub-efi grub-efi-amd64-signed secureboot-db shim shim-signed


grub-install /dev/sda
update-grub
That should be enough, now you have to clean-up all you did.
Make sure you have left no running programs in the chroot.
 
exit
umount /mnt/boot/efi
umount /mnt/{proc,sys,dev}


umount /mnt
exit
In case of error you should check if there is a program left running in the Chroot-environment or if a mountpoint within /mnt is still in use.
 
Reboot.
 
If done well you now should be able to boot to "Ubuntu" that in fact is Bodhi. That naming is something that can be changed, but let's do this first.
 
Enjoy,
Charles.

Edited by Charles@Bodhi, 21 December 2015 - 08:11 PM.
corrected grub commands

Medion S4216 Ultrabook, 4GB RAM, 1TB HDD, WIN 10 & Bodhi 4.1.0-64 

Asus eeepc 901, 1GB RAM, 12 GB SSD, Bodhi 3.0.0-32-Legacy & Bodhi 4.1.0-32 Legacy


#4 gohlip

gohlip

    Member

  • Members
  • 658 posts

Posted 17 December 2015 - 11:44 PM

Installing Bodhi in uefi is exactly the same as installing other linux OS in uefi - no problems - simple and straitforward.

Just make sure of 2 things.

o Install media is booted in uefi

o mount point of /boot/efi to the ESP (vfat) partition.

 

That's it.

 

ps: if you have existing (particularly windows) OS, just make sure you do not format the ESP (/boot/efi) partition when installing.


Life is a sexually transmitted disease with a 100% mortality rate.


#5 sef

sef

    Bodhi Builder Wizard

  • Developer
  • 237 posts
  • LocationATL

Posted 18 December 2015 - 09:31 AM

What hardware are you running? First of all you may want to google your PC and see if others have had similar problems. Seems as though some vendors have created UEFI (what most think of as BIOS) that is, how shall I say, specialized or non-conforming, making it difficult to do installs. You might also want to make sure that Secure Boot is turned off in your BIOS (ahem, UEFI firmware).

 

 

Please keep us posted on how it's going. These are exactly the issues we're trying to sort out right now.



<-sef>

Nothing is as simple as it seems at first,
or as hopeless as it seems in the middle,
or as finished as it seems in the end.






Also tagged with one or more of these keywords: GPT, GRUB

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users