Jump to content

Photo

sleep once but never again


  • Please log in to reply
5 replies to this topic

#1 syeager

syeager

    Member

  • Members
  • 75 posts

Posted 04 June 2016 - 03:01 PM

this is not limited to bodhi but many distros i try on my new computer. it will sleep once but if i wake it and try to sleep again, it will never successfully sleep (or wake).

 

On the first try, i close the lid of my hp envy 15 amd laptop, and after a second or two it goes to sleep (you hear the fan turn off and the light on the side flashes softly).  this is consistent behavior for this system in windows 8.1 (although linux sleeps much faster).  When i open the lid, the screen displays the desktop and within seconds i am functional again.

 

However, if i try to close the lid again, the fan never ceases and the light on the side stays lit constantly. i wait several seconds, even minutes but it does not change.  opening the lid does not produce the desktop but a blank, black screen.  the system does not respond to any input, including the power button which usually starts the shutdown process.  i am forced to power off with a long press of the power button.

 

any thoughts?





A big thank you to everyone who contributes to Bodhi Linux


#2 graywizardlinux

graywizardlinux

    Bodhi Supporter

  • Members
  • 734 posts

Posted 04 June 2016 - 05:35 PM

i do the suspend through the menu - it works everytime.  actually did hibernate too but had to push the on/off buton - with the suspend i wait a second or two and then close the lid when the computer screen goes off.



#3 The waiter

The waiter

    Module Master

  • Developer
  • 1459 posts
  • LocationBanska Bystrica, Slovakia

Posted 04 June 2016 - 05:38 PM

I know this behavior from my colleague's Asus. I solved it by creating script which turned off lan or wifi (sorry I cant remember) before sleep. Anyway we need more info. Which kernel version do you use? Can you post htop screenshot after second attempt to sleep if you are able to switch to the terminal console?

#4 syeager

syeager

    Member

  • Members
  • 75 posts

Posted 04 June 2016 - 09:20 PM

i will try to use the menu and see if it works more than once. this is something that worked on previous notebooks, might be something specific to my new laptop.

i cannot give you information about after second sleep attempt. the screen is blank and never recovers. i have to hard reboot (and i loose everything). if there is a log i can view, i would be happy to provide that but i need to know where it is.

 

so it wakes after using menu and i can post this.  now trying a second sleep with menu.

 

second try to sleep with menu failed the same way. blank screen. solid light. no recovery.  i do get a funny prompt on reboot stating that my boot partition was modified. i will try it again and get a picture of it to get the exact wording.

 

Warning!!! Boot script table is modified!!!

Please contact your vendor.

 

Does bodhi use uefi to boot or is it legacy boot?  Seems a lenovo system using ubuntu also has this problem on second suspend.



#5 graywizardlinux

graywizardlinux

    Bodhi Supporter

  • Members
  • 734 posts

Posted 04 June 2016 - 10:38 PM

i run bodhi on 2 thinkpads x series - my wife runs Xubuntu on an older r500.  we used a couple of other thinkpads with various distros and never had issues.  my 2 cents.



#6 aka jazz

aka jazz

    Member

  • Banned
  • 611 posts

Posted 11 June 2016 - 02:49 AM

Try it this way first. Go to Settings>All>Input>ACPI Bindings>choose Lid Closed. On the right side Pick either suspend or hibernate.

 

I suspect the reason you get that info message about a change in the boot partition is because it will boot from ram this time around, instead of the regular boot partition, which under other circumstances could be seen as a possible security issue, so it notifies you. But the notification is enough to confuse most people (it did make me wonder the first few times--I had become annoyed with it to avoid suspend if linux did it half-assed) and since I did things differently back then, running live from a stick in these 'suicide sessions-everything must go!' all the time, I had noticed that I don't get that warning unless I left the PC unattended and its power saver kicked in without my assistance.

 

Suspend means booting from swap; hibernate means booting from ram, but I might have them mixed up. Still that would explain that message. It's not something I do often; that is why I have them mixed up. I know I looked it up once before. Running live means either one shuts down the laptop, completely, after an extended eight hour session. So all things should be done by then, and anything important gets saved in the persistence area of the stick.


Screenshots of e17 at the Gallerie des shedied and here for just one only. Incidentally,why don't you try our friendly IRC channel for some help? (link up top) or watch an e-ducational clip that's 2 and a half minutes long




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users