Jump to content

Photo

Impossible to Unmount Devices(USB)without ROOT

pcmanfm

  • Please log in to reply
20 replies to this topic

#1 jvinas

jvinas

    Member

  • Members
  • 6 posts

Posted 09 October 2016 - 07:54 AM

Hello,guys 

I new here and i started to use Bodhi just a few days ago and i am with a impossible problem to solve with pcman fm and Disks Utility , maybe a permission issue . I can mount devices ( automounted ) but I cant unmount them without ROOT , I want to be able to unmount my USB as a regular user , bacause every time that i plug an USB in my  systen , i need to use the terminal with sudo to unmount my devices. Can someone help me please ? 

 

These are my Error Messages when i try to eject/unmount my USB Drive :

 

PcManfm :  Nout Authorized to Perform Operation 

 

Ubuntu Disks Utility : Impossible to Perform Operation ( udisks-error-quark , 4 )





A big thank you to everyone who contributes to Bodhi Linux


#2 Jeff

Jeff

    Lead Developer

  • Developer
  • 12501 posts
  • LocationBloomington, IL

Posted 09 October 2016 - 07:16 PM

Are you using a stock Bodhi 3.2.1 install? PCManFM has permission to unmount removable media by default on all my systems here.



#3 jvinas

jvinas

    Member

  • Members
  • 6 posts

Posted 09 October 2016 - 07:38 PM

Yes, i did several dist-upgrades. Maybe some configuration has been lost . I found that to eject my device , i need adminastrative privileges , so i need to authenticate but the authentication service is not running . I my case is polkit-gnome-authentication-agent-1. This service should be started at login . 

 

I thinking to do a new fresh install of bodhi and update nothing : packeges , programs , etc .



#4 Elw3

Elw3

  • Moderators
  • 1769 posts

Posted 10 October 2016 - 01:47 AM

 but the authentication service is not running . I my case is polkit-gnome-authentication-agent-1. This service should be started at login . 

This actually already explains why unmounting needs root access. 

Polkit IS what unmounts drives. 

Say have you changed something in the login manager? 


Bad Wolf

#5 jvinas

jvinas

    Member

  • Members
  • 6 posts

Posted 10 October 2016 - 02:45 AM

No, i changed nothing in the login manager, but my problem is solved now with a new system install . Thanks  :)

 

Waiting for Bodhi 4 :)



#6 WineCountryBoy

WineCountryBoy

    Member

  • Members
  • 1 posts
  • LocationWine Country

Posted 26 November 2016 - 07:31 AM

Similar problem here - without consciously changing anything, today USB drives mount in a new way - instead of

/media/user/My\ Book/

my external USB 3.0 drive now mounts as  

/media/My\ Book/

 

Same symptom as jvinas: PcmanFM won't let me eject it: "Not authorized to perform operation"

 

Something else - nothing was mounting automatically either until I went to check Settings:Files:Places: Mount Volumes on insert.

 

Any suggestions on how to figure out why this changed? 



#7 graywizardlinux

graywizardlinux

    Bodhi Supporter

  • Members
  • 1064 posts

Posted 26 November 2016 - 02:44 PM

i have noticed this the last few months with one of my usb drives here too - all others and my external HD seem fine.  also with my camera once or twice.  so not sure.  again nothing has been changed at all in my system.  I know so little that once i got it working for my needs and standards nothing gets changed or tweaked in the least.



#8 Randy

Randy

    Bodhi-Care

  • Members
  • 646 posts
  • LocationFort Wayne, IN USA

Posted 26 November 2016 - 02:51 PM

As Elw3 eluded too, make sure polkit is running at startup.


Randy Fry



Linux Addict!

#9 graywizardlinux

graywizardlinux

    Bodhi Supporter

  • Members
  • 1064 posts

Posted 26 November 2016 - 04:51 PM

how do i do that randy?



#10 Jeff

Jeff

    Lead Developer

  • Developer
  • 12501 posts
  • LocationBloomington, IL

Posted 26 November 2016 - 07:57 PM

Are you able to eject the media properly if you disable the automounting in places and mount the drives by clicking on them in a PCManFM window?



#11 graywizardlinux

graywizardlinux

    Bodhi Supporter

  • Members
  • 1064 posts

Posted 26 November 2016 - 08:05 PM

jeff - not sure who you are asking this of - but i have no clue what you mean or how to do it.  I do try to either eject or unmount volume by clicking said text.  menu context if that helps.  sorry.



#12 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4567 posts
  • LocationZeist, The Netherlands

Posted 26 November 2016 - 08:23 PM

On my B4-install the usb is automounted on insert by pcmanfm, even though it is not checked in places. But the pcmanfm preferences are checked for automounting on boot and insert. The usb is mounted in /media/, not in /media/$USER/. Right clicking in pcmanfm for unmounting gives permission error. Strange thing is that I could unmount it in terminal without sudo.

 

After disabling the automount in pcmanfm I could mount and unmount using the left pane without issues.

 

Enjoy,

Charles



#13 graywizardlinux

graywizardlinux

    Bodhi Supporter

  • Members
  • 1064 posts

Posted 26 November 2016 - 11:30 PM

But the pcmanfm preferences are checked for automounting on boot and insert. 

 

where do you find this or do this?  man i am lost.

 

sorry for the dumb questions. - i may just leave as is.  



#14 graywizardlinux

graywizardlinux

    Bodhi Supporter

  • Members
  • 1064 posts

Posted 27 November 2016 - 11:58 AM

is it in the preferences area?  i have some boxes checked and and some not.  I may have left them default - not sure been a year ago.



#15 Randy

Randy

    Bodhi-Care

  • Members
  • 646 posts
  • LocationFort Wayne, IN USA

Posted 27 November 2016 - 01:15 PM

In pcmanfm under the edit menu/preferences/volume management/    you should see the options Charles was talking about.


Randy Fry



Linux Addict!

#16 graywizardlinux

graywizardlinux

    Bodhi Supporter

  • Members
  • 1064 posts

Posted 27 November 2016 - 03:38 PM

that is what i thought 0- which ones to uncheck then?  I have the first three checked.  they all seem to be somewhat relevant.

 

thanks Randy and Charles.



#17 bob rashkin

bob rashkin

    Member

  • Members
  • 455 posts
  • Location26.13N, 97.63W

Posted 28 November 2016 - 02:23 PM

Just out of curiosity, what would the CLI process be to unmount a USB drive?


Bob Rashkin

#18 Jeff

Jeff

    Lead Developer

  • Developer
  • 12501 posts
  • LocationBloomington, IL

Posted 28 November 2016 - 04:11 PM

sudo umount /path/to/mount/point


#19 bob rashkin

bob rashkin

    Member

  • Members
  • 455 posts
  • Location26.13N, 97.63W

Posted 29 November 2016 - 12:41 PM

where the path to mount point is going to be /dev/sdx (x=d,e,...) or /media/....?


Bob Rashkin

#20 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4567 posts
  • LocationZeist, The Netherlands

Posted 29 November 2016 - 04:37 PM

where the path to mount point is going to be /dev/sdx (x=d,e,...) or /media/....?

 

Hardware recognition puts it in /dev/ 

Usually mountpoints are in /media/. Often there is also a directory /media/username/ The latter "should be" accessible without sudo.







Also tagged with one or more of these keywords: pcmanfm

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users