Jump to content


(SOLVED)Problem with polkit agent and authentication

  • Please log in to reply
4 replies to this topic

#1 jvinas



  • Members
  • 6 posts

Posted 09 October 2016 - 07:08 PM

Guys , 

I am having problems with polkit-gnome-authentication-agent-1 , it is not starting on login and because of this issue i am having permission issues. I cant eject my external devices for example, it requires to authenticate but i cant bacause the authentication service (polkit-gnome-authentication-agent-1)is not running. I need to run it manually all times and just works for the corrunt session when i logoof and login again the service not start by itself. How fix this ?

A big thank you to everyone who contributes to Bodhi Linux

#2 Jeff


    Lead Developer

  • Developer
  • 12650 posts
  • LocationBloomington, IL

Posted 09 October 2016 - 07:15 PM

You can add commands you want run at startup to the file ~/.e/e/applications/startup/startupcommands


Can find some more details on it here -> http://forums.bodhil...-commands-file/


Let us know if you hit any snags getting it working.

#3 jvinas



  • Members
  • 6 posts

Posted 09 October 2016 - 07:40 PM

I tried to add the command but it didnt work . It says tha Moksha was unable to start the aplicattion at login.


My file look like this : 


File Name : startupcommands  


Inside the file :  polkit-gnome-authentication-agent-1 ( Application Name )

#4 Randy



  • Members
  • 687 posts
  • LocationFort Wayne, IN USA

Posted 09 October 2016 - 09:32 PM

Try the old way. Go to menu/settings/all/apps/startup applications and scroll  the list for policy kit authentication agent, or similiar. Highlight it and click add, then apply. Hope this helps.



Randy Fry

Linux Addict!

#5 jvinas



  • Members
  • 6 posts

Posted 10 October 2016 - 12:07 AM

Guys , thanks for the help i already made a fresh new install , everything is fine now  :)

Thanks .

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users