Jump to content

Photo

forecast module/gadget


  • Please log in to reply
7 replies to this topic

#1 sket

sket

    Member

  • Members
  • 39 posts
  • LocationItaly

Posted 06 November 2016 - 12:45 PM

hello, I loaded the forecast module and put on the desktop. But the popup with the specifications open outside the desktop, and I can't see all specs.

I tried to set windows in visible display. But nothing, the popup go outside!





A big thank you to everyone who contributes to Bodhi Linux


#2 The waiter

The waiter

    Module Master

  • Developer
  • 1657 posts
  • LocationBanska Bystrica, Slovakia

Posted 06 November 2016 - 12:58 PM

Hmm, screenshot please. I am pretty sure the code is written with conditions preventing this behavior. 

Anyway what can I say is:

1. try to solve this with Moksha restart

2. move gadget to a different place on the desktop

 

Stefan



#3 sket

sket

    Member

  • Members
  • 39 posts
  • LocationItaly

Posted 06 November 2016 - 01:31 PM

I tried to move in other place and it works, the popup is visible.

I still have not finished the customizing, but I would like to put the gadget where I want.

 

30813495605_acb6e829d9_o.png

 

30777090576_d43fd7e188_o.png



#4 The waiter

The waiter

    Module Master

  • Developer
  • 1657 posts
  • LocationBanska Bystrica, Slovakia

Posted 06 November 2016 - 01:38 PM

OK, then. I must take back what I said. There are just two directions (up and down) how the popup window will be shown. Yes, it would be great to pop up also left or right according the gadget coordinations.



#5 4saken

4saken

    Member

  • Members
  • 5 posts

Posted 06 November 2016 - 08:33 PM

For both of you, maybe this will help:

 

There is a place in Settings>Settings All>Windows display>Screen limits if I remember correctly, called screen limits. One of them states: allow windows to show partly beyond screen area ( as can be seen in the screenshots you have provided), another says, Allow windows to go beyond the screen area. I mention the two, but there are three checkboxes; for the life of me, I cannot remember the first one. I am on another PC at the moment; but I believe you can find out whether this will fix the popup problem once and for all, and I do mean, once and for all, without any further fixes from the waiter, who is king of the code(but likes to mingle with us, as a waiter :)

 

The first option is keep windows inside the screen area.



#6 The waiter

The waiter

    Module Master

  • Developer
  • 1657 posts
  • LocationBanska Bystrica, Slovakia

Posted 06 November 2016 - 09:17 PM

No, this won't work. Window is means for the application window. This is not related to evas component which is that popup window...

 

PS: considering some time changing my nick :)



#7 4saken

4saken

    Member

  • Members
  • 5 posts

Posted 07 November 2016 - 12:26 AM

heh, i "popped up" those screen limits ideas because sket mentioned he had set windows to Always visible, and I remembered those other things as well. Worth a shot, but I defer to your opinion since I haven't even seen or looked at the internals or the code.

 

Changing your name might be easier lol



#8 sket

sket

    Member

  • Members
  • 39 posts
  • LocationItaly

Posted 07 November 2016 - 10:39 AM

sorry 4saken, I'm not explained good, I've setted the system in italian, so I don't know exactly how it's called in english.

anyway, what I intend and made was the screen limits and not always visible.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users