Jump to content

Photo

Clock not displaying Daylight Saving Time


Best Answer The waiter, 11 November 2016 - 02:35 PM

I use to solve it installing ntp package. It synchronized time with current timezone...

Go to the full post


  • Please log in to reply
10 replies to this topic

#1 Freece

Freece

    Member

  • Members
  • 6 posts

Posted 11 November 2016 - 09:24 AM

I have set up the time using tzdata setting up what timezone I live in. But here it is DLS now and the clock does not show it. If I enter date -ufc I get the correct time, but the clock shows one hour ahead. How would I go about solving this problem?

Sincerely,

Freece





A big thank you to everyone who contributes to Bodhi Linux


#2 bob rashkin

bob rashkin

    Member

  • Members
  • 402 posts
  • Location26.13069N,97.63676W

Posted 11 November 2016 - 02:04 PM

I think you have it backward. That is, DST has ended as of last Sunday. That your time shows "one hour ahead", as you say, implies that it did NOT "fall back" to standard. Could you have gotten the TZ wrong?


Bob Rashkin

#3 The waiter

The waiter

    Module Master

  • Developer
  • 1459 posts
  • LocationBanska Bystrica, Slovakia

Posted 11 November 2016 - 02:35 PM   Best Answer

I use to solve it installing ntp package. It synchronized time with current timezone...



#4 gohlip

gohlip

    Member

  • Members
  • 654 posts

Posted 11 November 2016 - 04:27 PM

What's output of

timedatectl

Life is a sexually transmitted disease with a 100% mortality rate.


#5 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4335 posts
  • LocationZeist, The Netherlands

Posted 11 November 2016 - 05:52 PM

tzdata is sometimes mistaken afaik. The package gets updated rather often. Can you run 

sudo apt-get update && sudo apt-get dist-upgrade
sudo dpkg-reconfigure tzdata

Make sure to enter your local capital city when reconfiguring.

 

Enjoy,

Charles


Medion S4216 Ultrabook, 4GB RAM, 1TB HDD, WIN 10 & Bodhi 4.1.0-64 

Asus eeepc 901, 1GB RAM, 12 GB SSD, Bodhi 3.0.0-32-Legacy & Bodhi 4.1.0-32 Legacy


#6 Freece

Freece

    Member

  • Members
  • 6 posts

Posted 12 November 2016 - 05:01 PM

Hello! Sorry for the delay. I am certain that the tzdata is set correctly; to Stockholm, Europe. @bob yes you are quite right, I meant the other way around.

I did your update and reconfig Charles, to no avail.

@gohlip output is following:

$ timedatectl
      Local time: lör 2016-11-12 19:00:30 CET
  Universal time: lör 2016-11-12 18:00:30 UTC
        RTC time: lör 2016-11-12 18:00:30
       Time zone: Europe/Stockholm (CET, +0100)
 Network time on: yes
NTP synchronized: no
 RTC in local TZ: no


#7 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4335 posts
  • LocationZeist, The Netherlands

Posted 12 November 2016 - 05:10 PM

Hmm, I do know that windows and linux do use different methods for the system time. Linux prefers UTC and Windows uses Local time for the internal clock. When I boot into Win10 the time is always off. When I set the correct time in Win10, Linux time is off. This might be the case for you too.

I'm not sure where you can change the internal clock in Linux, I once knew where to find that config.

 

Enjoy,

Charles.


Medion S4216 Ultrabook, 4GB RAM, 1TB HDD, WIN 10 & Bodhi 4.1.0-64 

Asus eeepc 901, 1GB RAM, 12 GB SSD, Bodhi 3.0.0-32-Legacy & Bodhi 4.1.0-32 Legacy


#8 gohlip

gohlip

    Member

  • Members
  • 654 posts

Posted 13 November 2016 - 06:22 AM

Right,

as @the_waiter says, install ntp package.

And when it gets syncronized,

"NTP synchronized: yes" will appear in timedatectl.

And being set in utc (as is done now shown by "RTC in local TZ: no") DST will automatically be done correctly. (it will not be done  in RTC but okay in UTC).

 

As for windows/Bodhi time, windows use RTC and the time when booted up after reboot from the other time will initially be wrong until ntp kicks in for each.

If you want, you can either set both to UTC (done in Bodhi now as shown by your timedatectl) or set both to RTC (always default in Windows).

But DST in RTC is not reliable see http://www.cl.cam.ac...ish/ut-rtc.html

Though setting RTC in linux is much simpler than setting windows in UTC. see https://weblogs.asp....-Book-Pro_2900_

 

Oh .... check that Bodhi's /etc/default/rcs does not have line "utc=false"

Bodhi4 now does not have this line now. Earlier Bodhi's have this and can be confusing because  tzdata works as well as timedatectl.

Now it's mainly systemd and so uses timedatectl to handle this.


Life is a sexually transmitted disease with a 100% mortality rate.


#9 Freece

Freece

    Member

  • Members
  • 6 posts

Posted 14 November 2016 - 09:03 AM

Hello again all!

@gohlip I checked the rcS file and that line was not there. I installed ntp package and it started working within seconds. I think, for simplicity, that I will just stick to that for now.

 

Thank you all for great responses.



#10 kmak

kmak

    Member

  • Members
  • 1 posts

Posted 09 March 2017 - 01:03 PM

I started encountering this problem after installing Bodhi 4.1.0. Never used to have this problem in previous versions. 

 

Thanks @the_waiter.

 

After installing ntp, my problem was fixed.

sudo apt install ntp


#11 Oblio

Oblio

    Bodhi Team

  • Team
  • 164 posts
  • LocationA desk in the Midwest

Posted 10 March 2017 - 02:10 PM

NTP to the rescue!

 

kmak - would you kindly mark this as solved?  Thank you and welcome to the forums!


Xeon E3-1220 v3 3.1GHz Quad, ASRock Rack E3C224, 2x 8GB Kingston KVR16E11/8I DDR3-1600 ECC CL11 Intel Chips (Dual Channel), EVGA GeForce GTX 570, Samsung SM863 120GB OS SSD, 2x WD RED 3TB HDDs (Raid 0), Focusrite Scarlett 2i4, Antec Earthwatts EA-750 80 Plus Platinum 750w PSU - Bodhi 4.1.0 64

AMD Phenom II X4 940 3.0GHz Quad, Gigabyte GA-MA78GPM-DS2H, 2x 2GB Kingston KHX8500D2K2 DDR2-1066 (Dual Channel), EVGA GeForce GTX 570, Intel 30GB OS SDD, Seagate ST31000340AS 1TB HDD, Seagate STBD4000400 4TB HDD, EVGA 500w Bronze Plus 80+ PSU - Bodhi Linux 3.2.1 64





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users