Jump to content

Photo

Translation issues


  • Please log in to reply
19 replies to this topic

#1 KebeK

KebeK

    Member

  • Members
  • 2 posts
  • LocationCanada

Posted 23 November 2016 - 02:45 PM

Hello everyone,
 
       I use Bodhi Linux version 3.0.1 (transladed to french) without any problems. I installed version 4.0.0 last week  and the french translation of the main menu and the submenus is incomplete. Are there any files I can edit myself? Finally I can not launch Synaptic via the menus since the translation to French. Any ideas for fixing this problem?
 
Thank you!
 
 




A big thank you to everyone who contributes to Bodhi Linux


#2 The waiter

The waiter

    Module Master

  • Developer
  • 1635 posts
  • LocationBanska Bystrica, Slovakia

Posted 23 November 2016 - 02:57 PM

Hello.
I take care of this matter. Please wait a day or two and I will provide updated po files ready for translating. Then I will be glad if you participate.

Stefan

#3 BALLOON a.k.a. Fu-sen.

BALLOON a.k.a. Fu-sen.

    Member

  • Members
  • 123 posts

Posted 29 November 2016 - 07:04 AM

Finally I can not launch Synaptic via the menus since the translation to French. Any ideas for fixing this problem?

 

I was able to reproduce the same problem in Japanese.

It seems that there is a problem with esudo. This can be started from the terminal:

sudo synaptic

This command was also started. This is obviously a locale dependent problem:

LANG=C esudo synaptic


#4 ylee

ylee

    King of the Software Page

  • Moderators
  • 1580 posts
  • LocationSouth Carolina, USA

Posted 29 November 2016 - 01:38 PM

Hello everyone,
 
       I use Bodhi Linux version 3.0.1 (transladed to french) without any problems. I installed version 4.0.0 last week  and the french translation of the main menu and the submenus is incomplete. Are there any files I can edit myself? Finally I can not launch Synaptic via the menus since the translation to French. Any ideas for fixing this problem?
 
Thank you!

 
@KebeK: OK I can't duplicate your issue with Synaptic and the main menu. Perhaps it has to do with your password. There is a known issue with esudo and certain passwords. Progress is slow but we have working on a fix.
 
So first of all, How did you 'translate' to french? And second of all are you ok with pming me the password used which fails? And lastly does changing your password help resolve this issue?
 
 

I was able to reproduce the same problem in Japanese.
It seems that there is a problem with esudo. This can be started from the terminal:

sudo synaptic
This command was also started. This is obviously a locale dependent problem:
LANG=C esudo synaptic

 
@BALLOON a.k.a. Fu-sen:  I am unsure what you mean  :huh: Do you mean that if sudo synaptic is started in a terminal then the command LANG=C esudo synaptic was also launched? Or do you mean starting synaptic from the menu or by esudo synaptic fails to launch it but LANG=C esudo synaptic succeeds in launching it? Or do you mean something else, please clarify...


"No technology can ever be too arcane or complicated for the black t-shirt crowd."


#5 BALLOON a.k.a. Fu-sen.

BALLOON a.k.a. Fu-sen.

    Member

  • Members
  • 123 posts

Posted 30 November 2016 - 07:51 AM

It is not a synaptic problem, but esudo is having problem. (It's probably a bug)

When running in an environment where esudo is not English, it is not working.



#6 KebeK

KebeK

    Member

  • Members
  • 2 posts
  • LocationCanada

Posted 30 November 2016 - 03:48 PM

 

 

So first of all, How did you 'translate' to french? And second of all are you ok with pming me the password used which fails? And lastly does changing your password help resolve this issue?


#7 BALLOON a.k.a. Fu-sen.

BALLOON a.k.a. Fu-sen.

    Member

  • Members
  • 123 posts

Posted 06 December 2016 - 03:42 AM

For esudo, I reported a bug:

https://github.com/J.../esudo/issues/5



#8 ylee

ylee

    King of the Software Page

  • Moderators
  • 1580 posts
  • LocationSouth Carolina, USA

Posted 06 December 2016 - 12:57 PM

For esudo, I reported a bug:
https://github.com/J.../esudo/issues/5


I need to know specifics here. I switched my locale to french set language to french and all worked as expected. Tell me precisely what you have did that breaks esudo. LANG=C esudo should be unnecessary so to resolve this I need details and maybe your help.

 

What is LANG currently set to on your system and what happens (terminal output) when you run the command esudo command for whatever app you wish for command. 


"No technology can ever be too arcane or complicated for the black t-shirt crowd."


#9 BALLOON a.k.a. Fu-sen.

BALLOON a.k.a. Fu-sen.

    Member

  • Members
  • 123 posts

Posted 06 December 2016 - 01:26 PM

OK. I took a capture.

balloon@BodhiLinux:~$ echo $LANG
ja_JP.UTF-8
balloon@BodhiLinux:~$ esudo leafpad

Here the authentication screen is displayed. I enter the password. (Obviously correct):

 

shot-2016-12-06_22-08-49.jpg

 

The eSudo window is closed, but Leafpad will not start after this.  :unsure:

 

I wanted to get some hint of solution, I ran "ps ax" on a different terminal:

 

shot-2016-12-06_22-13-02.jpg

 

"sudo -ES leafpad" is running. But it seems to stop there...



#10 ylee

ylee

    King of the Software Page

  • Moderators
  • 1580 posts
  • LocationSouth Carolina, USA

Posted 06 December 2016 - 01:48 PM

Wow, ok. I will look into it when I find time. Seems esudo is working in a sense, but something is preventing the app from being displayed. I will see if i can duplicate it. Thanks  B)


"No technology can ever be too arcane or complicated for the black t-shirt crowd."


#11 ylee

ylee

    King of the Software Page

  • Moderators
  • 1580 posts
  • LocationSouth Carolina, USA

Posted 06 December 2016 - 01:59 PM

Does sudo -ES leafpad have the same effect with the leafpad window being invisible? 


"No technology can ever be too arcane or complicated for the black t-shirt crowd."


#12 BALLOON a.k.a. Fu-sen.

BALLOON a.k.a. Fu-sen.

    Member

  • Members
  • 123 posts

Posted 07 December 2016 - 08:40 AM

No. "sudo -ES leafpad" itself will operate normally.

However, it looks like the same behavior as "sudo leafpad".

balloon@BodhiLinux:~$ sudo -ES leafpad
[sudo] balloon のパスワード:
                     :
(Leafpad launches)


#13 ylee

ylee

    King of the Software Page

  • Moderators
  • 1580 posts
  • LocationSouth Carolina, USA

Posted 07 December 2016 - 12:16 PM

Yes I can verify everything above. Added  language-pack-ja on Bodhi4.0 and configured locales/Moksha to  LANG = ja_JP.UTF-8. 
 
Sadly seems to be an issue with Moksha itself as esudo is working correctly. The app is launched with sudo it just doesn't display.
 
I confirmed this by installing esudo on enlightenment 21.4 with  efl 18.3, and python-efl 1.18 and LANG=ja_JP.UTF-8. On e21 esudo works correctly with LANG = ja_JP.UTF-8, and  the application IS displayed. I will continue to do a little digging around into this issue, but in all likelihood progress will be slow. I make no promises as to resolving it.

 

EDIT: turns out this was a flaw in esudo. Not sure why it worked in e21 or greater but regardless we have a hopeful fix now.


"No technology can ever be too arcane or complicated for the black t-shirt crowd."


#14 BALLOON a.k.a. Fu-sen.

BALLOON a.k.a. Fu-sen.

    Member

  • Members
  • 123 posts

Posted 08 December 2016 - 06:15 AM

I appreciate the support of ylee so far.  :)

 

Hmm...I also guess that it is not easy to find this cause.  :huh:

For example, I feel compatibility with the input method Fcitx.



#15 The waiter

The waiter

    Module Master

  • Developer
  • 1635 posts
  • LocationBanska Bystrica, Slovakia

Posted 11 December 2016 - 06:29 PM

BL 4 Leafpad process opened from run everything with root rights:

Qwzc75v.png

 

BL 3.2.1 the same situation but it is working here.

 

da63vZj.jpg

 

Yes, sth is preventing a gui from displaying. Anyway I can see some other weird stuff.

- sudo -ES --preserve-env is not correct because -E means the same as --preserve-env. (--preserve-env adds run everything and is unnecessary here)

- gksudo has 3 processes opened. I am not sure but is this OK?

- the issue is with slovak locale as well as with japanese



#16 CravateRouge

CravateRouge

    Member

  • Members
  • 1 posts

Posted 14 December 2016 - 06:25 PM

Hi,
 
I've the same problem as Kebek.
When my local is set in english I've no issue. But when I set the language to french its partially translated and all applications who need esudo can't be launched.
To set the local language I used the official wiki tutorial.


#17 ylee

ylee

    King of the Software Page

  • Moderators
  • 1580 posts
  • LocationSouth Carolina, USA

Posted 05 May 2017 - 02:11 PM

Just reporting a tentative fix for this issue is now in Bodhi's  testing repo.


"No technology can ever be too arcane or complicated for the black t-shirt crowd."


#18 BALLOON a.k.a. Fu-sen.

BALLOON a.k.a. Fu-sen.

    Member

  • Members
  • 123 posts

Posted 06 May 2017 - 03:11 AM

I contacted you from ylee and tested this fix. As a result, this resolved. Thanks ylee!

 

In addition, this problem occurred when using Ubuntu's Language Support (package: language-selector-gnome).

It seems to be caused by GNOME language pack or system language change.

If only change the language of Moksha, this problem will not be encountered.



#19 Mr.J

Mr.J

    Member

  • Members
  • 38 posts

Posted 10 May 2017 - 06:03 PM

I have had some trouble with language settings as well. As man is a lazy being I stopped to romp about it and did a fresh install without any changes to the original setup (in English). Now I am fine and I am getting some extra lessons in English.  :)  It does not matter, all the documentation is in English...

I guess the installation of a language package broke up something. 

 

The big point of this distro is its lightweight character and the splendid desktop. Stability is very important, so in my point of view the language settings might not be given priority.



#20 ylee

ylee

    King of the Software Page

  • Moderators
  • 1580 posts
  • LocationSouth Carolina, USA

Posted 10 May 2017 - 09:06 PM

...
 
The big point of this distro is its lightweight character and the splendid desktop. Stability is very important, so in my point of view the language settings might not be given priority.


I agree stability is important and in a perfect world should be given priority but the esudo locale fix mentioned above was an outstanding bug we have known about for months and months. About a week ago for some reason I was thinking about it while going to sleep and had some insight. The next day I got it working. It was nothing planned and honestly it was a distraction from what I already had planned for that day. It is all good tho because it needed fixed and hopefully is now.


"No technology can ever be too arcane or complicated for the black t-shirt crowd."





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users