Jump to content

Photo

Improvements / Fixes for Bodhi 4.1.0


  • Please log in to reply
8 replies to this topic

#1 Jeff

Jeff

    Lead Developer

  • Developer
  • 12416 posts
  • LocationBloomington, IL

Posted 12 December 2016 - 02:41 PM

Looking forward to the future - we already have a small running list of things that need to be addressed from the 4.0.0 release. Including:

 

  • UEFI Fixes
  • Theme Updates / Fixes
  • Improved Moksha Translations
  • EFL Updates

 

Are there any other issues in the default application set / configuration of Bodhi 4.0.0 that should be addressed in an upcoming 4.1.0 release? 

 

While I am not going to publish a firm timeline, my goal is to work on these improvements / get them packaged over the holidays and have a set of 4.1.0 ISO images to release some time in January. 





A big thank you to everyone who contributes to Bodhi Linux


#2 ylee

ylee

    King of the Software Page

  • Moderators
  • 1559 posts
  • LocationSouth Carolina, USA

Posted 13 December 2016 - 10:18 PM

I would like to see the remaining issues with esudo fixed. Hopefully the problem with not authenticating passwords with problematic strings or characters in them has been fixed. But we still have a remaining issue with some non english locales and apps launched by esudo not being displayed right. I have been looking into this issue with so far limited no success. Hopefully me or someone else can get to the bottom of this and do it all in time for the 4.1.0 release.

 

I will give some thought to any more issues or suggestions ....


"No technology can ever be too arcane or complicated for the black t-shirt crowd."


#3 robot774

robot774

    Member

  • Members
  • 26 posts
  • LocationOlso

Posted 15 December 2016 - 10:24 PM

Getting bluetooth to work "out of the box". I have failed at this before on Liinux, but I just now got it to work, so I'll make a post here on the forums because I have lost my wiki password and the password reset doesn't work (maybe I mentioned this before /s).  

 

There are more step than just installing blueman.   



#4 Jeff

Jeff

    Lead Developer

  • Developer
  • 12416 posts
  • LocationBloomington, IL

Posted 16 December 2016 - 01:07 AM

Blue tooth falls under one of those "this is an extra we aren't including by default on purpose" for the standard release. Adding BlueMan to the AppPack disc is probably reasonable though.



#5 nomko

nomko

    Member

  • Members
  • 122 posts
  • LocationThe Hague, The Netherlands

Posted 02 January 2017 - 08:01 AM

Is it worth waiting till January to get the latest release or will the new improvements also be implemented in the current release by means of patches/bugfixes/updates?


MSI GE70-2PE*Quad core Intel Core i7-4710HQ*Kingston 16 GB RAM*Intel 4th Gen. Integr. GPU/NVidia GeForce GTX860M*Qualcomm Atheros Killer E2200/Intel Wireless 3160*Sitecom X5-N600 Router (WLR-5100)

 

------------------------------------------------------------------------------------------------------------------------------------------------------

 

I don't need Google, my wife knows everything!


#6 Jeff

Jeff

    Lead Developer

  • Developer
  • 12416 posts
  • LocationBloomington, IL

Posted 02 January 2017 - 10:22 PM

Is it worth waiting till January to get the latest release or will the new improvements also be implemented in the current release by means of patches/bugfixes/updates?

Unless you need the UEFI fixes to get installed, everything else mentioned here is already in the stable repositories.



#7 Paraplegic Racehorse

Paraplegic Racehorse

    Member

  • Members
  • 44 posts
  • LocationSeward, AK

Posted 05 January 2017 - 12:37 AM

I'd like to see broadcomm wifi detected and installed by default. It's extremely tedious to have to do this, especially if one is in a place where there is no wire.




Stable: Lenovo G50 :: Ubuntu GNOME 16.04
Testing: Dell Inspiron Mini10 :: Bodhi Linux 4 Legacy

GitHub: ParaplegicRacehorse


#8 Bion

Bion

    Member

  • Members
  • 1 posts

Posted 26 January 2017 - 06:27 AM

First off let me say thanks for all the work you and your crew have put in to make this project a great piece of work. I tried several times to use E17 via other means with 0 success. Each attempt frustrated me because I got to likeing the desktop environment and was impressed at how beautiful and fast it was on my older equipment. Then I ran across your distro and I was hooked. My install path has been kinda crooked because I had started out on a different machine and just as I got things working and  useable I had to get a different box. Anyway, I started with Ubuntu/Unity and Ithink I hated it. What follows below is basically the log sheet I started for this occassion. 

 

Some Specs first:

-Computer-

Processor : Intel® Pentium® 4 CPU 2.66GHz
Memory : 1543MB (1191MB used)
Operating System : Ubuntu 14.04.5 LTS
-Display-
Resolution : 1440x900 pixels
OpenGL Renderer : GeForce FX 5200/PCI/SSE2
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : ICH4 - Intel 82801DB-ICH4
-Input Devices-
AT Translated Set 2 keyboard
 Logitech Optical USB Mouse
 UVC Camera (046d:080f)
-Printers (CUPS)-
HL-2170W-series : <i>Default</i>
-SCSI Disks-
ATA WDC WD2500JB-00G
HL-DT-ST DVDRAM GSA-H10L
HL-DT-ST CD-RW GCE-8520B
Now the rest:
[Bohdi notes]
These are brief notes regaurding some of the minor issues I have encountered installing Bohdi Linux/Moksha desktop alongside Xubuntu. Overall, it has worked out well. Not sure which version of Bohdi I'm using but the about Moakasha dialog says 0.2.0
 
[Update Issues]
eepdater - Gathers package info, lists available updates, I select all, then it does more processing but returns to the first screen showing available updates. So I resorted to updating using Synaptic.
 
Updateing with Synaptic was slow near the end and dpkg (I'm assuming it's dpkg?) appeared to have stalled while doing things with the "init rmf?" stuff. Since I always have the details window open so if things look stalled I will interact with it by pressing [ENTER] or [^C] to see if I get a CRLF or indicating to me that it's probably not hung. I had to do this a couple times along the way because it seemed things had stalled. Each time I tickled it with [^C] I did get a warning about killing the process or whatever, so I closed the warning dialog and the update continued churning. It finally did finish up, and Synaptic said my system is up to date, hooray, so I closed Synaptic. Moments later, I get a dialog from esudo wanting a password followed by eepdater opening with all the same updates I had just installed, listed and check marked for installation. I clicked [Apply] and let it run. It churned and did some work, then said my system was up to date.
 
I have managed to crash the desktop manager (I think). I was upgradeing via Synaptic when the windows I had open on screen, the filemanager and Synaptic, swapped focus witheach other and closed while dpkg was doing it's thing. But I'm pleased to tell you it recovered in just a few seconds with no appeareant damage.
 
[Take Away]
Updateing using Synaptic seems to work as intended.
 
[Ecomorph Issues]
Settings in Ecomorprh/Ecomp don't always change or stick even when pressing [Apply] after each alteration. Tha Open animation was changed numerous times yet it remains on Airplane (at least that's what I think it's stuck on. The window folds into a paper airplane and flies off screen). 
 
[VirtualBox]
VirtualBox which was installed and functioning under Xubuntu apears to be still working under Bohdi/Moksha
 
[Desktop Manager?]
On occasion, when the Nemo file manager is open, Mokasha (again I'm guessing) will become unresponsive. I think Nemo may have been installed when the Cinnamon DE was installed separetly. I was checking out other DE/DM's before I ran across instructions for installing Bohdi on top of/along side XFCE. I don't remember actually installing Ubuntu/Unity proper. If did, I may have gone looking for a way around it. I vaguely remember using Unity breifly and didn't care for it's performance on my old PC. Then I read about installing Cinimon was a viable work around. 
 
Back to the file manager. Because I've installed probably 4 differant DE's that as I'm sure you know, can be selected at log in. This was an exercise in curiosity. Currently there's Unity, Cinnamon, FWM Crystal, Afterstep (which came with FWM I think), XFCE and of course Bohdi/Mokasha which is my daily driver.
 
It appears that Nemo is the cause of the freeze/unresposive behavior. When it happens, clicking on any place on the screen gets me the right-click context menu offering to create a new document, folder, etc. Clicking any open application window control gets the same thing. The [CTRL-K] [CTRL-X] keystrokes are ignored. 
 
I figured out that if I move my mouse to either screen edge, the Ecomorph politley rotates the Cube out of the way as expected. Once this happens, it seems like something wakes back up and I can save my work, and restart Mokasha from the start button (love this feature), which also goes stiff when this is going on. There's an occasional hiccup with the power management but it's not consistant, and so far, managable.
 
So there ya have it. I want to thank you again, as well as those responsible for Linux on the desktop as a whole. I finally got my PC back. For years it was hostage by M$ who think it's theirs, and that everyone wants and can afford to get a new pc every other year. I started with DOS 3.1 on a laptop w a 8088, moved to WIN3.1 but that wasn't all that bitchen until I got rid of that Progman and some other stuff involving a compressed HD etc. I really appreciate your hard work. I'm on disability so all I can offer is feedback. Thanks again 


#9 Jeff

Jeff

    Lead Developer

  • Developer
  • 12416 posts
  • LocationBloomington, IL

Posted 26 January 2017 - 08:01 AM

Based on the information in your post Bion it does not sound like you are using our latest stable release.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users