Jump to content

Photo

[Archlinux]Extra modules fail to complie for Moksha

extra-modules for Archlinux

Best Answer nixfreak, 01 January 2017 - 07:38 PM

Thanks everyone I was able to compile and build Moksha, bodhi-linux , and packagekit on Archlnux and Ubuntu 16, some modules don't quite work correctly but I really don't need them anyway.

 

What I ended up doing was compiling moksha and Bodhilinux from source then having to overwrite existing ELF libs for Ubuntu 16

For Arch I grabbed the PKGBUILD from the aur and had to compile some other depends , wasn't a big deal though. I am not able to run moksha very smooth on Archlinux and installing emotion python media player is awesome and highly recommend it. I have been using ninja-ide for my IDE for python-efl bindings which works very well and haven't had a problem with it yet.

 

 

Thanks to all the developers who where involved with Moksha.

Go to the full post


  • Please log in to reply
4 replies to this topic

#1 nixfreak

nixfreak

    Member

  • Members
  • 3 posts

Posted 19 December 2016 - 02:55 PM

Hello,

 

   First let me say me say , thank you for Moksha. I was very impressed so far using it and having to exchange it for enlightenment. I have also started looking at developing with python-efl which is a lot of fun too. I am using Archlinux for my distro.

 

My question is: I am unable to load pulse-audio module but the strange part when I go into pva controls for pulseaudio I can see it working , and when I run the alsamixer tools or utilities it works also, just can't hear anything. Also I get an error when compiling the extra-modules for Moksha, the only thing that compiles correctly is the alarm module.

 

Please keep up the great work , if I can help out please let me know

 

 

 

-Nixfreak

 





A big thank you to everyone who contributes to Bodhi Linux


#2 ylee

ylee

    King of the Software Page

  • Moderators
  • 1559 posts
  • LocationSouth Carolina, USA

Posted 19 December 2016 - 03:54 PM

... Also I get an error when compiling the extra-modules for Moksha, the only thing that compiles correctly is the alarm module.

 

...

 

Be specific what errors?


"No technology can ever be too arcane or complicated for the black t-shirt crowd."


#3 The waiter

The waiter

    Module Master

  • Developer
  • 1578 posts
  • LocationBanska Bystrica, Slovakia

Posted 19 December 2016 - 04:43 PM

If you are able to compile alarm module, you should be able to compile all extra-modules. So, I assume you have installed all dev deps which are needed: 

https://github.com/J.../installdeps.sh

 

The only problem I can see in configure.ac file where can be enlightenment specific version and we need Moksha one.

 

Ylee is right. you must tell us more...



#4 nixfreak

nixfreak

    Member

  • Members
  • 3 posts

Posted 19 December 2016 - 05:28 PM

Thanks for getting back to me so quickly, right now I am at work and don't have access to that machine, I will post later with more specifics



#5 nixfreak

nixfreak

    Member

  • Members
  • 3 posts

Posted 01 January 2017 - 07:38 PM   Best Answer

Thanks everyone I was able to compile and build Moksha, bodhi-linux , and packagekit on Archlnux and Ubuntu 16, some modules don't quite work correctly but I really don't need them anyway.

 

What I ended up doing was compiling moksha and Bodhilinux from source then having to overwrite existing ELF libs for Ubuntu 16

For Arch I grabbed the PKGBUILD from the aur and had to compile some other depends , wasn't a big deal though. I am not able to run moksha very smooth on Archlinux and installing emotion python media player is awesome and highly recommend it. I have been using ninja-ide for my IDE for python-efl bindings which works very well and haven't had a problem with it yet.

 

 

Thanks to all the developers who where involved with Moksha.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users