Jump to content

Photo

Clock is 13 hours early


  • Please log in to reply
9 replies to this topic

#1 terray

terray

    terray

  • Members
  • 1 posts

Posted 02 February 2017 - 06:30 AM

How can I adjust Clock so that it matches my timezone? There is no info in Settings to allow this.





A big thank you to everyone who contributes to Bodhi Linux


#2 Jeff

Jeff

    Lead Developer

  • Developer
  • 12416 posts
  • LocationBloomington, IL

Posted 02 February 2017 - 06:45 AM

Open terminology and run the command:

 

sudo dpkg-reconfigure tzdata

 

You will be prompted to type your password (which will not appear while being typed) press enter and follow the on screen questions. Note this is an ncurses screen so you will need to navigate it with the keyboard.

Hit any issues feel free to ask.
 

Welcome to the forums mate.



#3 Oblio

Oblio

    Bodhi Team

  • Team
  • 165 posts
  • LocationA desk in the Midwest

Posted 02 February 2017 - 03:04 PM

Open terminology and run the command:

sudo dpkg-reconfigure tzdata

You will be prompted to type your password (which will not appear while being typed) press enter and follow the on screen questions. Note this is an ncurses screen so you will need to navigate it with the keyboard.

Hit any issues feel free to ask.
 

Welcome to the forums mate.

 

Jeff - I added this info to the Wiki...under the "configuring-your-new-bodhi-system"...seems to come up a fair amount on the forums.


Xeon E3-1220 v3 3.1GHz Quad, ASRock Rack E3C224, 2x 8GB Kingston KVR16E11/8I DDR3-1600 ECC CL11 Intel Chips (Dual Channel), EVGA GeForce GTX 570, Samsung SM863 120GB OS SSD, 2x WD RED 3TB HDDs (Raid 0), Focusrite Scarlett 2i4, Antec Earthwatts EA-750 80 Plus Platinum 750w PSU - Bodhi 4.1.0 64

AMD Phenom II X4 940 3.0GHz Quad, Gigabyte GA-MA78GPM-DS2H, 2x 2GB Kingston KHX8500D2K2 DDR2-1066 (Dual Channel), EVGA GeForce GTX 570, Intel 30GB OS SDD, Seagate ST31000340AS 1TB HDD, Seagate STBD4000400 4TB HDD, EVGA 500w Bronze Plus 80+ PSU - Bodhi Linux 3.2.1 64


#4 Jeff

Jeff

    Lead Developer

  • Developer
  • 12416 posts
  • LocationBloomington, IL

Posted 02 February 2017 - 03:08 PM

Good idea. Swami has a GUI for changing date / time - so hopefully I have that read for our next release.



#5 Oblio

Oblio

    Bodhi Team

  • Team
  • 165 posts
  • LocationA desk in the Midwest

Posted 20 February 2017 - 07:35 PM

Good idea. Swami has a GUI for changing date / time - so hopefully I have that read for our next release.

Hey Jeff - is this the way to go?

 

For some reason, my jump to 4.1.0 made my clock go wonky and running

sudo dpkg-reconfigure tzdata
didn't seem to fix it.  My bios clock looks ok, etc.

 

Thoughts?


Xeon E3-1220 v3 3.1GHz Quad, ASRock Rack E3C224, 2x 8GB Kingston KVR16E11/8I DDR3-1600 ECC CL11 Intel Chips (Dual Channel), EVGA GeForce GTX 570, Samsung SM863 120GB OS SSD, 2x WD RED 3TB HDDs (Raid 0), Focusrite Scarlett 2i4, Antec Earthwatts EA-750 80 Plus Platinum 750w PSU - Bodhi 4.1.0 64

AMD Phenom II X4 940 3.0GHz Quad, Gigabyte GA-MA78GPM-DS2H, 2x 2GB Kingston KHX8500D2K2 DDR2-1066 (Dual Channel), EVGA GeForce GTX 570, Intel 30GB OS SDD, Seagate ST31000340AS 1TB HDD, Seagate STBD4000400 4TB HDD, EVGA 500w Bronze Plus 80+ PSU - Bodhi Linux 3.2.1 64


#6 Jeff

Jeff

    Lead Developer

  • Developer
  • 12416 posts
  • LocationBloomington, IL

Posted 20 February 2017 - 08:55 PM

Do you have two operating systems on your computer? If so it sounds like one is set to UTC and one isn't.



#7 The waiter

The waiter

    Module Master

  • Developer
  • 1542 posts
  • LocationBanska Bystrica, Slovakia

Posted 20 February 2017 - 09:47 PM

Try

sudo apt-get install ntp



#8 Oblio

Oblio

    Bodhi Team

  • Team
  • 165 posts
  • LocationA desk in the Midwest

Posted 22 February 2017 - 02:40 PM

Do you have two operating systems on your computer? If so it sounds like one is set to UTC and one isn't.

 

I don't, and actually the drive that I'm using was crispy and fresh out of the package just for Bodhi.  I know, it's odd...and the thing was, with 4.0.0, the clock was correct.  For me, I really don't mind that much, but just found it odd.

 

Try

sudo apt-get install ntp

 

I can't remember if I tried this or not, I feel like I did, but I'll give it another shot.  [edit] This definitely worked.

 

Thank you Jeff and Stefan!


Xeon E3-1220 v3 3.1GHz Quad, ASRock Rack E3C224, 2x 8GB Kingston KVR16E11/8I DDR3-1600 ECC CL11 Intel Chips (Dual Channel), EVGA GeForce GTX 570, Samsung SM863 120GB OS SSD, 2x WD RED 3TB HDDs (Raid 0), Focusrite Scarlett 2i4, Antec Earthwatts EA-750 80 Plus Platinum 750w PSU - Bodhi 4.1.0 64

AMD Phenom II X4 940 3.0GHz Quad, Gigabyte GA-MA78GPM-DS2H, 2x 2GB Kingston KHX8500D2K2 DDR2-1066 (Dual Channel), EVGA GeForce GTX 570, Intel 30GB OS SDD, Seagate ST31000340AS 1TB HDD, Seagate STBD4000400 4TB HDD, EVGA 500w Bronze Plus 80+ PSU - Bodhi Linux 3.2.1 64


#9 Jayan Tashi

Jayan Tashi

    Member

  • Members
  • 63 posts
  • LocationSingapore

Posted 17 March 2017 - 08:25 AM

Had a similar issue as well and Swami could not even invoke. Recall it functioning in 4.0 but in 4.1.0 I rectified the matter installing GNOME appliances over Moksha. In this case I switched on the Preferences and used the Time & Date GUI and changed the location.


Son. Student. Citizen.


#10 gohlip

gohlip

    Member

  • Members
  • 662 posts

Posted 17 March 2017 - 12:04 PM

If you're using Bodhi 4.0 and higher (works for versions lower too), best to use timedatectl

 

But first check if there is the following (shouldn't be in Bodhi 4.0 and higher), if there is set 'utc=yes'

/etc/default/rcS
utc=yes

Then proceed as follows.{ First command is to check what timezone applies to your specific case. }

2nd command use what applies

$ timedatectl list-timezones
# timedatectl set-timezone America/Los_Angeles
# timedatectl set-ntp true
# timedatectl set-local-rtc false
# hwclock --systohc --utc

Do last command only when your display clock shows the correct time.

Reminder - All OS's (including windows) must  preferably be set to utc. (and preferably disable ntp in windows).


Life is a sexually transmitted disease with a 100% mortality rate.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users