Jump to content

Photo

How to set hibernate as default in battery meter settings?


  • Please log in to reply
6 replies to this topic

#1 Bok

Bok

    Member

  • Members
  • 4 posts
  • LocationPort Elizabeth. South Africa

Posted 07 March 2017 - 07:44 AM

Hi, I'm running Bodhi 3.2 and want to change the default suspend setting to hibernate in "settings, advanced, battery meter". On each new session started I have to go into these settings and change to hibernate, however, starting a new session after shutdown, Bodhi reverts back to suspend. I'm sure there must be a way to make hibernate the default but I just can't figure it out.

Any help or advice would be appreciated.





A big thank you to everyone who contributes to Bodhi Linux


#2 DOOMguy

DOOMguy

    Member

  • Members
  • 85 posts

Posted 07 March 2017 - 05:09 PM

Did you hit Apply or Apply followed by OK? Did you set the percent like 11 or 10 percent before clicking Apply? It's not something I change frequently, so we want to re-create the scenario that is taking place. How big is the SWAP? How much RAM is in your hardware?

 

Changing the value to something other than 10% (21 percent for example) will show you that the system saved your setting in between sessions.

 

EDIT: Added last line to explain the reasoning behind changing the battery's lower limit.


Edited by DOOMguy, 07 March 2017 - 10:36 PM.


#3 Bok

Bok

    Member

  • Members
  • 4 posts
  • LocationPort Elizabeth. South Africa

Posted 08 March 2017 - 06:17 AM

Hi @ DOOMguy, thanks so much for your reply. To answer your questions, I set the lower limit to 4% and then change the setting from suspend to hibernate. The system will only allow me to select either OK, or Apply. Once I select either one, the other blanks out and is unavailable.

 

Regarding your coment regarding changing the lower limit setting, I changed this from, if memory serves me, 10% to 4% and the system has saved this. Every startup, it's 4%. But the hibernate selection keeps reverting back to suspend every startup. This is what I need to change.

 

The computer is a netbook with 2GiB RAM, 3GiB SWAP, ROOT 20GiB, HOME 209GiB



#4 birdmun

birdmun

    Member

  • Members
  • 269 posts
  • LocationWabash, IN

Posted 08 March 2017 - 12:27 PM

I wonder if there is a user editable file (config file?) somewhere that you could make the adjustment to. I'll look in to this.



#5 DOOMguy

DOOMguy

    Member

  • Members
  • 85 posts

Posted 09 March 2017 - 04:45 PM

Birdmun, If I recall correctly, that question was asked a while back, when e16 was "current". Fast forward to today. It doesn't seem like the e-devs changed their minds or their direction. There are options in the enlightenment_remote command but it appears that there are none for the battery meter module.

 

So, as reported, the lower limit was indeed saved across sessions. What happened to the rest? I would report it as a bug, rather than resort to some hack.



#6 The waiter

The waiter

    Module Master

  • Developer
  • 1488 posts
  • LocationBanska Bystrica, Slovakia

Posted 09 March 2017 - 09:33 PM

Good catch Bok. You have found a bug in E/Moksha code. I spent all evening chasing the solution in Moksha source and everything looked correct in e_mod_config.c file where settings dialog is located. Then I found a bug in e_modapi_init function in e_mod_main.c file. The E developer forgot to add a line for suspend_method item thus this item was not added to module.battery config file (btw: located in ./e/e/config/bodhi).

E_CONFIG_VAL(D, T, suspend_method, INT);

 

I will commit the fix tomorow and will ask Jeff to update moksha package in repository.

Also will make a notice for E devs

 

Thanx.

 

EDIT: I hope this selection was not made this way by purpose...

EDIT2. Although now you know where the conf files are located, it is hard to change the values because of special file container.



#7 Bok

Bok

    Member

  • Members
  • 4 posts
  • LocationPort Elizabeth. South Africa

Posted 10 March 2017 - 07:39 AM

Good morning folks and thank you so much for your input and support on my problem. Looking forward to the update and fix on this bug.

I feel almost as if I've won a prize here.....my first, albeit, accidental bug discovery. I've been with Ubuntu since v9.07 and have never submitted a bug report, so my first! :)

Keep up the great work on a really fantastic operating system






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users