Jump to content

Photo

Black screen at boot - no grub


Best Answer Bertie, 17 March 2017 - 03:09 PM

Problem solved.

Enabling console (disabling graphics) mode in /etc/default/grub did it:

GRUB_TERMINAL=console

(Can just be uncommented in the file.)

I tried various things in this file but the actual culprit was the one above.

 

Thanks to all who gave advice to help get me from total disaster up to here.

Go to the full post


  • Please log in to reply
20 replies to this topic

#1 Bertie

Bertie

    Member

  • Members
  • 10 posts

Posted 15 March 2017 - 01:45 PM

Hello,

I have just installed Bodhi-4.1.0-32 (pae) via a live usb. After reboot and the initial bios messages, the screen stays black. This is where I would have expected grub to display.

 

The computer is a quite old 32-bit HP Intel with NVidia graphics (also old) and with Windows XP installed. (It belongs to my wife and she is going to kill me tonight.)

 

The disk layout is such:

sda1: 40 Gb, NTFS, Windows XP (drive C:)

sda2: 20 Gb, NTFS, Work area1 (drive D:)

sda5: 32 Gb, Ext4, Bodhi /

sda6: 56 Gb, Ext4, /home

sda7:  8 Gb, swap

 

I used the "Something else" installation option and lastly chose sda when asked where to put grub. Everything seemed to install correctly from thereon except in the end there was a message which was immediately replaced by a black screen (it is mentioned in the instructions). My only access now is via the Bodhi Live usb, when after booted, I can see that all the partitions with their respective files are still there.

 

I am not sure now if the mbr or grub is corrupted, if I should reinstall or chroot and try to fix.

 

 

 

 

 





A big thank you to everyone who contributes to Bodhi Linux


#2 gohlip

gohlip

    Member

  • Members
  • 668 posts

Posted 15 March 2017 - 04:58 PM

Boot up to bodhi livecd, at terminal, check what is the internal disk designated; it it sda or sdb?

Check using one of these

sudo parted -l
lsblk -f
sudo blkid
sudo fdisk -l

Then assuming Bodhi installed root is sda5, issue this command

sudo mount /dev/sda5 /mnt
sudo grub-install --boot-directory=/mnt/boot /dev/sda

If Bodhi root partition shows as sdb5, the command should be

sudo mount /dev/sdb5 /mnt
sudo grub-install --boot-directory=/mnt/boot /dev/sdb

Reboot without livecd.


Life is a sexually transmitted disease with a 100% mortality rate.


#3 Bertie

Bertie

    Member

  • Members
  • 10 posts

Posted 15 March 2017 - 09:31 PM

Thanks gohlip, this helped, or did it?

 

After following the directions (gohlip's post (the Bodhi root is at sda5)), same thing - rebooted to a black screen with no grub. So I switched on my own computer and came to this forum to report just that. Then I noticed that my wife's computer (the one with the problem) has since booted right up to the Bodhi login. So I logged in (no problem), tried terminology (no problem), and then power down (no problem). So I booted it again and this time waited patiently. The black screen lasted for about three minutes before grub started. Maybe it was also working previously if I have had the patience to wait that long? I rebooted, waited for grub, and could also log into Windows XP via grub. So now it seems that everything is working (no data or OS loss) but that it just takes very long for grub to start.

 

If I go to tty1, there is a message before the login prompt:

[2.904555] nouveau 0000:01:00.0: disp: conn 01:0130: func 08 lookup failed -2

I do not know if this might be a clue for I think it also shows when I boot the live usb, which seems to take a normal duration.



#4 gohlip

gohlip

    Member

  • Members
  • 668 posts

Posted 15 March 2017 - 10:18 PM

It shouldn't take that long to boot.
Try fsck the partitions. You need to do this from the lived as you need to fsck sda5 and sda6.

BTW, what's sda3 and sda4. One of them is the extended partition. What's the other?

Life is a sexually transmitted disease with a 100% mortality rate.


#5 gohlip

gohlip

    Member

  • Members
  • 668 posts

Posted 15 March 2017 - 10:20 PM

It shouldn't take that long to boot to grub.
Try fsck the partitions. You need to do this from the lived as you need to fsck sda5 and sda6.

BTW, what's sda3 and sda4. One of them is the extended partition. What's the other?

Life is a sexually transmitted disease with a 100% mortality rate.


#6 Bertie

Bertie

    Member

  • Members
  • 10 posts

Posted 16 March 2017 - 11:40 AM

Here is one sample of my disk layout:

bodhi@bodhi:~$ sudo parted -l
Model: ATA WDC WD1600JS-60M (scsi)
Disk /dev/sda: 160GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End     Size    Type      File system     Flags
 1      32.3kB  42.2GB  42.2GB  primary   ntfs            boot
 2      42.2GB  63.3GB  21.1GB  primary   ntfs
 3      63.3GB  160GB   96.8GB  extended
 5      63.3GB  95.3GB  32.0GB  logical   ext4
 6      95.3GB  151GB   56.0GB  logical   ext4
 7      151GB   160GB   8779MB  logical   linux-swap(v1)


Warning: The driver descriptor says the physical block size is 2048 bytes, but
Linux says it is 512 bytes.

It shows sda3 as the extended partition. No mention of sda4. Same with all the other disk inspection commands - no sda4. When I installed, I started off with only sda1, sda2, and unallocated space (I hope/think?). The installer decided to start at sda5.

 

Check of sda5:

bodhi@bodhi:~$ sudo fsck -r /dev/sda5
fsck from util-linux 2.27.1
e2fsck 1.42.13 (17-May-2015)
/dev/sda5: clean, 163646/1954064 files, 784263/7812255 blocks
/dev/sda5: status 0, rss 2720, real 0.091998, user 0.036000, sys 0.004000

Check of sda6:

bodhi@bodhi:~$ sudo fsck -r /dev/sda6
fsck from util-linux 2.27.1
e2fsck 1.42.13 (17-May-2015)
/dev/sda6: clean, 570/3424256 files, 267475/13671680 blocks
/dev/sda6: status 0, rss 2864, real 0.130604, user 0.048000, sys 0.004000

I have uncommented the beep in /etc/default/grub file (then sudo update-grub).

It takes about a minute after the bios messages before the beep is issued. Then about another minute before the grub menu appears. During the first minute the screen sometimes varies between piano black and matt black with some faint audible buzzing. Maybe the problem is for grub to determine the monitor resolutions? Maybe it is disk related?

 

Now that I know I have not damaged the XP partitions, I am tempted to reinstall by removing all partitions except sda1 and sda2 and see what options I have. (Put / on a primary partition and the rest on extended, for example?)



#7 DOOMguy

DOOMguy

    Member

  • Members
  • 236 posts

Posted 16 March 2017 - 12:29 PM

() See if you can match the grub configuration from the live USB so that it can display something. But the warning should tip you off. There is a forum thread where you can specify the screen resolution for grub--this will show you the screen right away regardless of graphic card (640x480).It will take some time to do the other things, whatever they are; I would pick a clean install but back up your important data before breaking the good news to your wife. XP is EOL a few years ago. Show bodhi when it's running off the stick so she can let you back in the house


Unsolicited advice for learning linux, that won't cost you anything


#8 gohlip

gohlip

    Member

  • Members
  • 668 posts

Posted 16 March 2017 - 03:17 PM

It's hard to tell, it's most likely a hard disk issue; hopefully not a failing disk.

But you have only 2 primary partitions so you cannot put a new installation in any of these unless you wipe Windows or start all over again with wiping out the drive.

 

 

You can start with new installation by wiping out the extended partition and either creating new logical partitions within it.

There is no advantage of linux using a primary partition at all. Linux can work well in logical partitions.

But I'm just puzzled about the lack of sda4 which may happen if you merge it to sda5 some time back, and that is not good because you've destroyed the first sector of the 'earlier' sda5.

 

If it is not hard drive or a partitioning problem, I don't know what else could be the issue.

If you reinstall or find out what the problem is, let us know, ya?

 

Good luck.

 

ps: a command "sudo grub-install --no-bootsector /dev/sda" will restore back the core.img which may be destroyed in the first sector, but you've done the 'full' grub-install at livecd. But still no harm trying when booted to Bodhi.


Life is a sexually transmitted disease with a 100% mortality rate.


#9 sef

sef

    Bodhi Builder Wizard

  • Developer
  • 323 posts
  • LocationATL

Posted 16 March 2017 - 04:17 PM

Welcome Bertie,

 

The message

[2.904555] nouveau 0000:01:00.0: disp: conn 01:0130: func 08 lookup failed -2

is interesting to me. You get this message about a display driver fail and also a blank screen.

Also, if you are able to go to tty1 and see a login prompt, that means that GRUB2 has booted the OS. It's just the X window system that is not displaying properly. But why GRUB2 never shows itself is a bit of a mystery to me at the moment.

 

Have you tried installing the legacy version?

 

How much RAM do you have? If less than 4Gb, then you don't need the PAE kernel which is included in the standard 32-bit release. Also, the kernel used in the legacy version is a little bit older and may have drivers that "play nicer" with your older PC.


Forum Rules (link)

---------------------------------------------------

Nothing is as simple as it seems at first, or as hopeless as it seems in the middle,

or as finished as it seems in the end.

---------------------------------------------------

"That's not how the force works..."


#10 Bertie

Bertie

    Member

  • Members
  • 10 posts

Posted 16 March 2017 - 04:37 PM

Hello,

Post #7: I have now reinstalled with /on a primary, /home and /swap on logical partitions. My disk layout is now better (no missing sdas):

Model: ATA WDC WD1600JS-60M (scsi)
Disk /dev/sda: 160GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End     Size    Type      File system     Flags
 1      32.3kB  42.2GB  42.2GB  primary   ntfs            boot
 2      42.2GB  63.3GB  21.1GB  primary   ntfs
 3      63.3GB  95.3GB  32.0GB  primary   ext4
 4      95.3GB  160GB   64.8GB  extended
 5      95.3GB  155GB   60.0GB  logical   ext4
 6      155GB   160GB   4779MB  logical   linux-swap(v1)

Unfortunately, still take over two minutes to reach grub during boot.

 

@ DOOMguy: Everything is working, I can boot into XP, just takes long. (My wife knows nothing yet.) I shall look into the other tips you mention - thanks.

 

@ gohlip: Cannot wipe and reinstall XP, it was preinstalled with a nice hologrammic sticker with serial number etc. - no CDs.

 

@ <-sef>L: Trying the legacy version is my next step - thanks. Grub2 does show itself but only afer a very long time. 2GB ram.



#11 gohlip

gohlip

    Member

  • Members
  • 668 posts

Posted 16 March 2017 - 05:34 PM

Running out of ideas, but check  your bios setup (F2 usually) that your first boot device is the hard drive, not dvd or usb or...

Then disconnect all  other external drives +usb and no dvd in tray.

And your hard drive (if sata) is connected using the primary cable, not the secondary cable; if ata (ide) drive, that jumper cables is set to 'master' not 'slave'.


Life is a sexually transmitted disease with a 100% mortality rate.


#12 DOOMguy

DOOMguy

    Member

  • Members
  • 236 posts

Posted 16 March 2017 - 08:17 PM

The only thing that I can remember from those XP days is that Windows should have a clean shutdown and not a force POWEROFF using the button, otherwise the next reboot of that OS will attempt a repair of the disk e.g. do you want Windows to try and repair the problem (recommended). Like he mentioned, XP was preinstalled, so like other laptops that came with MS stuff, there is a recovery partition that allowed MS to ship these laptops without the CD but with the hologram and the license. I don't remember all the details, but seeing that this one has nvidia, well, I'm glad that he was able to get it sorted (Congratulations B) !)

 

How to explain what happened to XP? Well you don't have to, theoretically, just say you no longer have to worry about viruses and malware (the standard excuses) and show her that the OS is on a memory stick and you can keep your work separate, but I digress.Besides, the legacy laptop can be made to look new with Moksha and Radiance and some good theme from the repos. Good laptops with discrete graphics should be kept running until the Zombie Apocalypse, or Robot uprising.


Unsolicited advice for learning linux, that won't cost you anything


#13 Bertie

Bertie

    Member

  • Members
  • 10 posts

Posted 17 March 2017 - 12:57 PM

Progress? so far:

 

Checked HD is connected to Sata0, disabled USB boot, boot from HD first.

Still the same - 2mins to grub menu.

 

Installed legacy version of Bodhi.

Still the same - 2mins to grub menu.

 

Reinstalled core.img

Still the same - 2mins to grub menu.

 

Lots of reading (information overload) regarding MBR, grub, chain loading ...

Found in the arch wiki, https://wiki.archlin...RUB&redirect=no regarding slow start of grub that low disk space may be the reason. However,  / and /boot (sda3) after a new install only uses 9% of the available space (32Gb).

Something that might be too small is the post MBR space where core.img is placed. I have only about 32kb available when 1 Mb is recommended. However, I do not think that it is possible to increase this space with XP squatting there

 

Can core.img be slimmed down?

Can grub give verbose output on each action that it does?

I do not mind if the grub menu is reduced and comes up only in console mode.

More reading to do - this will be my next attack.

 

(DOOMguy: this is not a laptop but a desktop. The heatsink on the cpu is about the size of a beer mug. I wonder if it is overclocked, or maybe even underclocked until booting is transferred to the selected OS? More reading to do.)



#14 gohlip

gohlip

    Member

  • Members
  • 668 posts

Posted 17 March 2017 - 03:07 PM

Size allocation for pbr (first sector of partition) is only 32 kb and core.img where it resides is less than that.

Where did you read it needs 1 MB? Hope you do not confuse it with bios-grub partition where it is not required in msdos partitioning, only in gpt partitioning for bios-legacy boots (and IMO, a bad setup (bios-legacy/gpt).

 

Anyway, as I said earlier, I am stumped why your boot to grub menu takes so long, noting that your boot to livecd is fast (that's why I ask you to look into first boot device).

If you find out, however long it took you, hope to hear from you. But at this point, I'm leaning to a disk issue.

 

Good luck. Take care.


Life is a sexually transmitted disease with a 100% mortality rate.


#15 Bertie

Bertie

    Member

  • Members
  • 10 posts

Posted 17 March 2017 - 03:09 PM   Best Answer

Problem solved.

Enabling console (disabling graphics) mode in /etc/default/grub did it:

GRUB_TERMINAL=console

(Can just be uncommented in the file.)

I tried various things in this file but the actual culprit was the one above.

 

Thanks to all who gave advice to help get me from total disaster up to here.



#16 gohlip

gohlip

    Member

  • Members
  • 668 posts

Posted 17 March 2017 - 03:13 PM

Bernie, can you provide your /etc/default/grub?

Default Bodhi grub should work out of the box.

Did you modify it earlier? Like putting in a grub background or using a theme set up?

 

 

 

 

Mine comes like this in installation

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

Why did yours change?

 


Life is a sexually transmitted disease with a 100% mortality rate.


#17 Bertie

Bertie

    Member

  • Members
  • 10 posts

Posted 17 March 2017 - 03:28 PM

Size allocation for pbr (first sector of partition) is only 32 kb and core.img where it resides is less than that.

Where did you read it needs 1 MB? Hope you do not confuse it with bios-grub partition where it is not required in msdos partitioning, only in gpt partitioning for bios-legacy boots (and IMO, a bad setup (bios-legacy/gpt).

 

I only said that 1Mb was recommended, not required (I read it in the arch wiki link from post#13). Also note that I now have a severe case of information overload, which will slowly decay during the next few days.

 

I tend to think that the problem is graphics related, and that grub tries to find what resolutions are available to use, and either the monitor or display driver fails to respond, resulting in a long time-out. Unfortunately I could not find a way to see which steps are performed by grub pre-menu. By removing 'quiet' from GRUB_CMDLINE_LINUX_DEFAULT it is possible to see the post-menu steps but that is too late and not applicable.

 

Thanks especially for your input, I have learned a lot from it.



#18 Bertie

Bertie

    Member

  • Members
  • 10 posts

Posted 17 March 2017 - 03:40 PM

Bernie, can you provide your /etc/default/grub?

Default Bodhi grub should work out of the box.

Did you modify it earlier? Like putting in a grub background or using a theme set up?

 

 

 

 

Mine comes like this in installation

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

Why did yours change?

You are correct, I have edited my post#15 to reflect that.

 

I have not changed anything in the file except for commenting and uncommenting. I am presently working on two computers with different Linux distributions (thus different grub files)  and took the line from the wrong grub (where I am currently logged into the Bodhi forum) as it was more convenient, without noticing the '_INPUT appendix. Thanks for alerting me.



#19 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4611 posts
  • LocationZeist, The Netherlands

Posted 17 March 2017 - 04:09 PM

Bernie, can you provide your /etc/default/grub?

Default Bodhi grub should work out of the box.

Did you modify it earlier? Like putting in a grub background or using a theme set up?

 

 

 

 

Mine comes like this in installation

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

Why did yours change?

 

Hmm, If I remember correctly Bodhibuilder (that creates the ISO) adds a grub-background to the default grub. Usually that is not problem at all as Bios starts with VGA enabled. Maybe this Bios is different causing the delay.

 

Enjoy,

Charles



#20 Bertie

Bertie

    Member

  • Members
  • 10 posts

Posted 17 March 2017 - 04:25 PM

Hmm, If I remember correctly Bodhibuilder (that creates the ISO) adds a grub-background to the default grub. Usually that is not problem at all as Bios starts with VGA enabled. Maybe this Bios is different causing the delay.

GRUB_BACKGROUND is not the problem. (I commented and uncommented it as well.)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users