Jump to content

Photo

How to change font size in filemanager


  • Please log in to reply
16 replies to this topic

#1 Twgray

Twgray

    Member

  • Members
  • 9 posts
  • LocationCrystal Beach, TX

Posted 09 April 2017 - 02:30 PM

One of the things I love about Bodhi is it's nearly infinite configurability. However, I can't seem to find how to change font size inside the filemanager. I am using a 4k monitor and the text beside the directory icons on the left side of the window, the text in the location bar and the filename text are all too small to see. I have been able to change fonts in everything on the desktop except the filemanager.

Can someone tell me how to change these?



A big thank you to everyone who contributes to Bodhi Linux


#2 Randy

Randy

    Bodhi-Care

  • Members
  • 650 posts
  • LocationFort Wayne, IN USA

Posted 09 April 2017 - 05:58 PM

The easiest way if you use the pcmanfm file manager is to install lxappearance from synaptic or from the command line with...

 sudo apt-get install lxappearance

It will show up in your menu as customize look and feel. In the very first tab is a drop down to change font size. 

 

Hope this helps.


Randy Fry



Linux Addict!

#3 The waiter

The waiter

    Module Master

  • Developer
  • 1678 posts
  • LocationBanska Bystrica, Slovakia

Posted 09 April 2017 - 06:11 PM

I tried this method some days ago waiting anybody else will bring another solution. No, lxappearance does not help. The font size will be applied to GTK menus but no icon or file names. Maybe GTK css style needs to be changed. Not my priority now, but if time permits, I can look at it...



#4 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4634 posts
  • LocationZeist, The Netherlands

Posted 09 April 2017 - 06:50 PM

In /home/user/.config/pcmanfm/ you can find a configuration file. The one existing in /default is auto-rebuild after every start but you can create a personal config file in an other dir. In the launcher for pcmanfm you have to add an option pointing to your config. See the manpage for pcmanfm.

You will need a line like: font=Ubuntu 16 (not sure though).

I'm also not sure this works for the window or only for the dektop option. Have not tested it.

 

Enjoy,

Charles



#5 graywizardlinux

graywizardlinux

    Bodhi Supporter

  • Members
  • 1077 posts

Posted 09 April 2017 - 11:06 PM

once again - you amaze me Charles.   I am stunned at all of the stuff you know in linux.



#6 Randy

Randy

    Bodhi-Care

  • Members
  • 650 posts
  • LocationFort Wayne, IN USA

Posted 10 April 2017 - 09:07 AM

@ the waiter

 

It works for me, but you need to restart pcmanfm. If it doesn't, it may be the theme that's being used.


Randy Fry



Linux Addict!

#7 The waiter

The waiter

    Module Master

  • Developer
  • 1678 posts
  • LocationBanska Bystrica, Slovakia

Posted 10 April 2017 - 09:39 AM

OK Randy. I will give it a try. Thanx

#8 The waiter

The waiter

    Module Master

  • Developer
  • 1678 posts
  • LocationBanska Bystrica, Slovakia

Posted 10 April 2017 - 09:43 AM

Ah, yes, you are right. It works indeed. When I just pressed "apply" button, it changed just menu font size. After restarting PCmanFM, filenames are changed as well. Thanx for info. One learns the whole life :)

 

PS: Thunar FM changes all settings just after "apply" button...



#9 graywizardlinux

graywizardlinux

    Bodhi Supporter

  • Members
  • 1077 posts

Posted 10 April 2017 - 11:51 AM

just curious - how do you start pcmanfm?



#10 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4634 posts
  • LocationZeist, The Netherlands

Posted 10 April 2017 - 12:29 PM

just curious - how do you start pcmanfm?

 

Just click on "Places" in the main menu. 

Or type pcmanfm in "Run Everything", the quick launcher.

 

Enjoy,

Charles.  :rolleyes:



#11 ylee

ylee

    King of the Software Page

  • Moderators
  • 1585 posts
  • LocationSouth Carolina, USA

Posted 10 April 2017 - 03:14 PM

just curious - how do you start pcmanfm?

 

If you want it back in the menu you can put it back:

sudo apt-get install --reinstall pcmanfm

"No technology can ever be too arcane or complicated for the black t-shirt crowd."


#12 graywizardlinux

graywizardlinux

    Bodhi Supporter

  • Members
  • 1077 posts

Posted 10 April 2017 - 06:34 PM

thanks!  much appreciated!!!!!

 

sorry for quick post - way too much outside garden and orchard and vineyard plus more wood to split for 2018/2019.



#13 graywizardlinux

graywizardlinux

    Bodhi Supporter

  • Members
  • 1077 posts

Posted 10 April 2017 - 06:39 PM

hmmm how do i get to places?  sorry for the dumb question but i looked and no where in any menu has places....  locations yes but places. no.



#14 The waiter

The waiter

    Module Master

  • Developer
  • 1678 posts
  • LocationBanska Bystrica, Slovakia

Posted 10 April 2017 - 08:34 PM

Just type pcmanfm in everything/quick launcher and fm will appear. For having places item in the menu, you need to load places module in case you have moksha-places installed. In case you want also the places gadget on the screen, go to gadget settings...

#15 graywizardlinux

graywizardlinux

    Bodhi Supporter

  • Members
  • 1077 posts

Posted 10 April 2017 - 08:59 PM

ok thanks Stefan - got the first part but not the 2nd part.

 

:-)))



#16 The waiter

The waiter

    Module Master

  • Developer
  • 1678 posts
  • LocationBanska Bystrica, Slovakia

Posted 12 April 2017 - 07:43 AM

As I am not sure you have places installed type in terminology:

sudo apt-get update && sudo apt-get install places-moksha

 

Then go to the module section and under the Files tab load the places module.

Now the places item should appear in the menu.

But I you want to have a places gadget on the screen with your partitions, USB and other devices (also with free/occupied capacity), you need to go to the gadget section and add places gadget on the screen.

 

PS: Proper package name is places-moksha and not moksha-places. Maybe that was the reason you did not succeed :)

 

Places gadget:

3o17BB1.png



#17 graywizardlinux

graywizardlinux

    Bodhi Supporter

  • Members
  • 1077 posts

Posted 12 April 2017 - 01:47 PM

thanks if directed to me.  let me see what i got going on.  been out in the vineyard since 6 am and more to do today.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users