Jump to content

Photo

Add a VPN connection greyed out


Best Answer Aussie, 13 April 2017 - 11:48 AM

If I remember well you should have four packages to install, not present in a default Bodhi

 

Close. It was the gnome versions I was missing.

 

To add VPN options to Edit Connections > Network Connections > Add

 

Install:

 

openvpn

network-manager

network-manager-openvpn

network-manager-openvpn-gnome

 

To also offer PPTP install:

 

pptp-linux

network-manager-pptp

network-manager-pptp-gnome

 

Now the VPN Connections option in the system tray applet is no longer greyed out. Successfully connected via PPTP by both Ethernet and WiFi.

 

The configuration options are also showing for VPN setup if I need the extra security, but at a slower speed.

 

Thanks for the nudge in the right direction with the gnome "extra".

Go to the full post


  • Please log in to reply
3 replies to this topic

#1 Aussie

Aussie

    Member

  • Members
  • 6 posts
  • LocationPerth, Australia

Posted 13 April 2017 - 08:30 AM

Okay, I have found the first problem I cannot solve myself.

 

I am trying to set up a PPTP connection. When I try to "Add a VPN connection" under "VPN Connections" from the system tray nothing opens. It is not clickable.

 

If I try to add a new connection manually, all I have is either Hardware or Virtual categories, with nothing referring to PPTP. Under Hardware, I would have to choose Ethernet or WiFi which indicates what I'm trying to do is not available.

 

I installed:

 

openvpn, network-manager, network-manager-openvpn, network-manager-pptp and pptp-linux

 

Could not find any solutions on the forum or Google, so I am fresh out of ideas. Normally with a Ubuntu based distro, you just select Add > PPTP but there is no such option on my installation.

 

In the "Choose a Connection Type" box it suggests "The correct VPN plugin may not be installed". I have no idea what plugin I may be missing.

 

So I need help on what to do next.





A big thank you to everyone who contributes to Bodhi Linux


#2 Aussie

Aussie

    Member

  • Members
  • 6 posts
  • LocationPerth, Australia

Posted 13 April 2017 - 09:40 AM

Under Hardware > DSL connection I see the type of information I need to enter.

 

Set one up, but it just disconnected and reverted to my Ethernet connection. Also obviously it doesn't work on WiFi.

 

What am I not understanding?



#3 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4558 posts
  • LocationZeist, The Netherlands

Posted 13 April 2017 - 10:29 AM

If I remember well you should have four packages to install, not present in a default Bodhi

sudo apt-get install network-manager-openvpn network-manager-openvpn-gnome network-manager-openvpnc network-manager-openvpnc-gnome 

The packages with gnome added should make vpn-connections appear in your nm-applet so you can configure them easily.

 

Enjoy,

Charles



#4 Aussie

Aussie

    Member

  • Members
  • 6 posts
  • LocationPerth, Australia

Posted 13 April 2017 - 11:48 AM   Best Answer

If I remember well you should have four packages to install, not present in a default Bodhi

 

Close. It was the gnome versions I was missing.

 

To add VPN options to Edit Connections > Network Connections > Add

 

Install:

 

openvpn

network-manager

network-manager-openvpn

network-manager-openvpn-gnome

 

To also offer PPTP install:

 

pptp-linux

network-manager-pptp

network-manager-pptp-gnome

 

Now the VPN Connections option in the system tray applet is no longer greyed out. Successfully connected via PPTP by both Ethernet and WiFi.

 

The configuration options are also showing for VPN setup if I need the extra security, but at a slower speed.

 

Thanks for the nudge in the right direction with the gnome "extra".






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users