Jump to content

Photo

acpi problems on old laptop


Best Answer sineng, 19 April 2017 - 12:18 PM

Thanks Randy for the nomodeset flag suggestion.  It didn't work.  The laptop couldn't complete booting and just hung.

 

Thanks birdmun for the links. Combed through and tried everything I could but couldn't add any other modes in xrandr.  I think the commands need to be in a script but that's beyond my ability in linux now.  Entering commands one at a time - I just couldn't get past the "gamma" error.  Was getting frustrated and gave up.  Tried to boot a live Linux Lite and had the same problem.  The laptop would just suspend every 20-30 secs and I had to press the power button to wake it up each time. It was ridiculous.  Turn acpi off stopped it but the display was stuck at 1024x768 as the only mode.  Would live with it except that the aspect ratio was not correct for the widescreen lcd.

 

Google more and more and found this and it worked! I'm happy it's solved - mostly cos apparently it's kinda a workaround setting "HandleSuspendKey" and "HandleLidSwitch" to ignore in the logind.conf file. Thanks all.

Go to the full post


  • Please log in to reply
3 replies to this topic

#1 sineng

sineng

    Member

  • Members
  • 2 posts

Posted 18 April 2017 - 05:17 PM

I'm trying to install bodhi on an old dell inspiron 710m laptop.  Booting a legacy live version from a usb stick makes the laptop go into suspend mode every few seconds.  Finally got it working with acpi=off setting in grub.  However, the screen defaults to a resolution of 1024x768.  How can I change the resolution to the native 1280x800? I really like this Bodhi linux distro but need help with this please.  I tried setting a new mode with xrandr but ran up the "failed to get the size of gamma ..." error.

 





A big thank you to everyone who contributes to Bodhi Linux


#2 birdmun

birdmun

    Member

  • Members
  • 318 posts
  • LocationWabash, IN

Posted 18 April 2017 - 06:46 PM

http://forums.bodhil...tion/?hl=xrandr

 

The above is the most recent thread I recall similar to your situation. Is there any help in it?



#3 Randy

Randy

    Bodhi-Care

  • Members
  • 630 posts
  • LocationFort Wayne, IN USA

Posted 18 April 2017 - 10:38 PM

Try to boot it once with the "nomodeset" boot parameter along with the acpi=off.


Randy Fry



Linux Addict!

#4 sineng

sineng

    Member

  • Members
  • 2 posts

Posted 19 April 2017 - 12:18 PM   Best Answer

Thanks Randy for the nomodeset flag suggestion.  It didn't work.  The laptop couldn't complete booting and just hung.

 

Thanks birdmun for the links. Combed through and tried everything I could but couldn't add any other modes in xrandr.  I think the commands need to be in a script but that's beyond my ability in linux now.  Entering commands one at a time - I just couldn't get past the "gamma" error.  Was getting frustrated and gave up.  Tried to boot a live Linux Lite and had the same problem.  The laptop would just suspend every 20-30 secs and I had to press the power button to wake it up each time. It was ridiculous.  Turn acpi off stopped it but the display was stuck at 1024x768 as the only mode.  Would live with it except that the aspect ratio was not correct for the widescreen lcd.

 

Google more and more and found this and it worked! I'm happy it's solved - mostly cos apparently it's kinda a workaround setting "HandleSuspendKey" and "HandleLidSwitch" to ignore in the logind.conf file. Thanks all.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users