Jump to content


Several issues after each try of Bodhi installation

  • Please log in to reply
5 replies to this topic

#1 Centauri39



  • Members
  • 35 posts

Posted 13 July 2017 - 09:57 AM

For several days now, I'm trying very desperately to install a Bodhi 4.2.0 64bit apppack on this system.

CPU: i6700K
RAM: 2 RAM's, each 16GB (yes, I know it is very much, but I wanted to be prepared for the future)
Mainboard: Z170A GAMING M5
Videocard: GM206 [GeForce GTX 960]
System drive: Samsung SSD 850 EVO 500GB
Storage drive: ST4000DM000-1F2168

Dual boot together with 
Win10 Pro 64bit

I even downloaded the Bodhi-ISO several times, but each time, MD5 is ok and serveral thumbdrives are ok, too.


But after the installation is done, there are the following issues:


A )

I want Firefox to be my preferred browser.

I also installed the add-on Download Manager (S3) in Firefox and therefore I need this keybord shortcut


This is also the shortcut for show desktop ( = minimize all windows).

That's why I changed the show desktop shortcut to

CTRL + Shift + ALT + D

After downloading something (by means of the above mentioned download manager add-on of Firefox), there's an option to open the target folder, but instead of this, I see the ePhoto tool, which is nonsense in that moment.

I'm not sure if this is some how caused by the ffmpegthumnailer package which I also installed to have thumbnails of video files.


B )

I've set up  the keyboard shortcut


to open Terminology, but when I do, the cursor is at the beginning of the prompt, not after it.

It doesn't only happen with the shortcu but also when I try to open the Terminal from within the main menu.

Then I have to repeat opening it a few times to get the curser after the prompt like it is meant to be.

To prevent this from happening, I had to add the line

screenfetch | lolcat

to the .bashrc after installing screenfetch (to have some system data on top of Terminology) and lolcat (to have some color in the screenfetch section).




I want to replace the default file manager PCmanFM by Caja.


So, with a reboot afterwards, I did

sudo apt-get install caja caja-share

Then, in the settings, i.e. in the default programmes, I enabled Caja.

I did this in the startup programmes and in the reboot programmes, too.

But no matter what, PCmanFM is still being used.



So what can I do to fix these issues, please?

A big thank you to everyone who contributes to Bodhi Linux

#2 DOOMguy



  • Members
  • 259 posts

Posted 14 July 2017 - 01:46 AM

Let's start with the easy ones. Terminology should be left as is; get rid of those add-ons in terminology. I would use screenfetch in urxvt or xterm. Terminology already has its own themes like nyanology or pikachu, and they handle the cursor placement already. screenfetch and lolcat will work on those other terminal emulators; I would contact their devs if they have a version ready for terminology.


There is nothing wrong with the shortcut for terminology. The .bashrc is affecting terminology though, and needs a little bit more work. Or set up conky to display the information. You are going to decide the route to take.

Unsolicited advice for learning linux, that won't cost you anything

#3 Jeff


    Lead Developer

  • Developer
  • 12604 posts
  • LocationBloomington, IL

Posted 14 July 2017 - 02:00 AM

To change the file manager the menu option opens you will need to search for "places" in the quick launcher and change the custom file manager launcher.


The terminology cursor being in the wrong spot is a terminology bug. The cursor position corrects itself as soon as you begin typing - hopefully they'll fix that next release.


As for your firefox issues - no idea off hand what firefox uses for determining what applications it uses for opening different things. For whatever reason it thinks ephoto is a file manager and not an image viewer sounds like. 

#4 Centauri39



  • Members
  • 35 posts

Posted 14 July 2017 - 08:31 AM

Meanwhile, I tried to open a folder as root and ePhoto is starting, too.

Let me add, because I wanted to have the context option...

Open as root

...I installed all packages referring to caja.


Now, using the option Open with... -> Another application, I was able to replace ePhoto by the Enlightenment file manager, and so eSudo is asking me for my password with a command, referring to the enlightenment filemanager like this:


enlightenment_filemanager 'file:///usr'

After entering the password, the wanted folder is supposed to open, but nothing happens anymore.

Why does it not open, please?


Another problem is still with the Firefox downloads.

When they are done, the target folder is supposed to open, but again eSudo is asking me for my password and the folder does not open.


Looks like the filemanagement went totally out of control, just because I wanted the context option to open something as root.


I wanted that because I don't like to enter entire commands and pathes.

What I was looking for is click that option, enter my password and... there we are.



Looks like I should reinstall Bodhi again.
I just want to have a bit more comfort than to enter each and every command or path in a terminal.

That's why I want caja instead of PCManFM.


Btw. I totally confused right now.

Usually you have PCManFM as a file manager, but then there's also the Enlightenment filemanager.

So, in the end, which one is it I'm actually supposed to use?

#5 Jeff


    Lead Developer

  • Developer
  • 12604 posts
  • LocationBloomington, IL

Posted 16 July 2017 - 01:04 AM

The "enlightenment file manager" does not exist in Moksha. We removed what E17 had when we forked because it was unfinished and there are plenty of light weight GTK file manager that are less buggy and more functional like PCManFM that we ship with by default. 


Edit: It looks like there is still a /usr/bin/enlightenment_filemanager file installed with Moksha still, but it doesn't launch anything and that is by design. If I get time I'll clean that up at some point. 

#6 DOOMguy



  • Members
  • 259 posts

Posted 17 July 2017 - 01:17 AM

Do not reinstall Bodhi --yet. Something tells me you will be repeating the steps again, without figuring out where you went wrong---and you will be back to square one. We discourage using that as a solution simply because it really isn't. Hey, I'm just the messenger. If you had to type every path or command in a terminal, then maybe it is time to fully understand how $PATH works, so that you can enjoy the benefits of terminal, and pcmanfm, etc.


Then maybe we will move away from opening everything as root. I will not even get into that.

Unsolicited advice for learning linux, that won't cost you anything

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users