Jump to content

Photo

Network problems


  • Please log in to reply
19 replies to this topic

#1 klamathh

klamathh

    Member

  • Members
  • 18 posts

Posted 31 July 2017 - 06:13 PM

Hi all,

 

started with live 4.2 and after ten minutes I had no more connection; The icon in tray reported still connected but

every site I tried was unreachable. Tried a ping to 8.8.8.8 but same problem, network unreachable and network

manager reported I was connected.

I was installing 4.2; after started new installed 4.2 had same problem, after 10 minutes "network unreachable"

and network manager connected.

 

The connection is via eth and the card is a "killer network card"

 

   *-network

                description: Ethernet interface
                product: Killer E220x Gigabit Ethernet Controller
                vendor: Qualcomm Atheros
                                
any clue ?
 
Have another little problem with system time, the time zone is correct but its 2 hours ahead tried to set correct but when I reboot
it goes ahead. Bios time is correct
 
Rgrds




A big thank you to everyone who contributes to Bodhi Linux


#2 birdmun

birdmun

    Member

  • Members
  • 390 posts
  • LocationWabash, IN

Posted 02 August 2017 - 12:36 AM

You may need to find drivers for your killer network card. The chipset may not be getting set up 100% correct and flaking out after a time. The timezone issue may be GMT vs UTC conflict. I don't know for sure I am just offering an idea on both points.



#3 klamathh

klamathh

    Member

  • Members
  • 18 posts

Posted 02 August 2017 - 07:47 PM

You may need to find drivers for your killer network card. The chipset may not be getting set up 100% correct and flaking out after a time. The timezone issue may be GMT vs UTC conflict. I don't know for sure I am just offering an idea on both points.

 

thnks birdmun

 

drivers for killer network cards does not exists, for what I know

they have been embedded in new kernel releases so there should not be problems

for older kernel on  killer network site there is a guide to patch alx module

 

http://www.killernet...view=topic&id=2

 

the problem seems to concern randomly 4.0 bodhi version too

On my desktop have both 4.0 and recently installed 4.2.

 

On 4.0 sometimes lost connection then after 10 minutes or so reconnect automatically

networkmanager report the connection up for the first 9 minutes, but browsers and ping 

respond with "network unreachable". When network manager too recognize the lost connection

in a few seconds it reconnects. 

( anyone knows if is there a way to reset network manager manually ? like service networkmanager stop & then start ? )

 

On 4.2 the problem is more serious because it happens, for what I tried, after a few minutes from boot and had no

reconnections.

 

About timezones, it's everything correct, for what I saw. Googled and found in /etc

 

lrwxrwxrwx 1 root root 31 ago  1 20:12 localtime -> /usr/share/zoneinfo/Europe/Rome

 

but clock is at every reboot 2 hours ahead and even setting it correctly at the following

reboot it's still ahead



#4 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4567 posts
  • LocationZeist, The Netherlands

Posted 02 August 2017 - 08:25 PM

About restarting the network manager: LINK. The second answer might be very handy in your case.

 

About clock setting. I would suggest to use the ntp package. 

sudo apt-get install ntp

This will use an internet timeserver to set your clock correctly. The cause most probably is dual booting with Windows 10. Default settings in Windows is never shutting down fully, but "hybernate" to allow a quicker boot. Resulting in a wrongly set internal systemclock. Linux expects that clock to have Universal Time where Windows converts it to Local Time during runtime.

 

Enjoy,

Charles



#5 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4567 posts
  • LocationZeist, The Netherlands

Posted 02 August 2017 - 08:33 PM

For your killer card please provide the outcome of:

lspci --nnk | grep 0200

This will help looking for the linux driver. Even when newer kernels are prepared for it, the driver module needs to be present on the system.

 

Enjoy,

Charles



#6 sef

sef

    Bodhi Builder Wizard

  • Developer
  • 322 posts
  • LocationATL

Posted 03 August 2017 - 10:39 AM

Can you run a live Linux Mint or Ubuntu and see if that gives you the same headache?

Have you had success with another version of linux? If so, you will probably need to install the specific kernel that that version is using.


Forum Rules (link)

---------------------------------------------------

Nothing is as simple as it seems at first, or as hopeless as it seems in the middle,

or as finished as it seems in the end.

---------------------------------------------------

"That's not how the force works..."


#7 klamathh

klamathh

    Member

  • Members
  • 18 posts

Posted 03 August 2017 - 06:58 PM

About restarting the network manager: LINK. The second answer might be very handy in your case.

 

About clock setting. I would suggest to use the ntp package. 

sudo apt-get install ntp

This will use an internet timeserver to set your clock correctly. The cause most probably is dual booting with Windows 10. Default settings in Windows is never shutting down fully, but "hybernate" to allow a quicker boot. Resulting in a wrongly set internal systemclock. Linux expects that clock to have Universal Time where Windows converts it to Local Time during runtime.

 

Enjoy,

Charles

 

great Charles, it worked



#8 klamathh

klamathh

    Member

  • Members
  • 18 posts

Posted 03 August 2017 - 06:59 PM

For your killer card please provide the outcome of:

lspci --nnk | grep 0200

This will help looking for the linux driver. Even when newer kernels are prepared for it, the driver module needs to be present on the system.

 

Enjoy,

Charles

 

this is for the 4.0 with

 

Linux bodhi64-fisso 4.4.0-36-generic #55-Ubuntu SMP Thu Aug 11 18:01:55 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
 

lspci -nnk | grep 0200

03:00.0 Ethernet controller [0200]: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller [1969:e091] (rev 13)
 
for the 4.2 it is the same
lspci -nnk | grep 0200
03:00.0 Ethernet controller [0200]: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller [1969:e091] (rev 13)


#9 klamathh

klamathh

    Member

  • Members
  • 18 posts

Posted 03 August 2017 - 07:14 PM

just now had the problem with 4.0 and restarting nm solved the problem

 

do you know what kind of tbs have I to do when network is down and nm says it's up ?



#10 klamathh

klamathh

    Member

  • Members
  • 18 posts

Posted 03 August 2017 - 07:15 PM

Can you run a live Linux Mint or Ubuntu and see if that gives you the same headache?

Have you had success with another version of linux? If so, you will probably need to install the specific kernel that that version is using.

 

don't have mint or ubuntu, have to burn and try but on 4.0 upgraded the kernel to  4.4.0-36

and in bodhi 4.2 expect a newer one.



#11 michmanbiker

michmanbiker

    Member

  • Members
  • 130 posts
  • LocationMontreal, Quebec, Canada

Posted 05 August 2017 - 02:41 PM

Just a thought. I was locked out by our home router today. Could you be experiencing a hardware issue?

 

Michel



#12 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4567 posts
  • LocationZeist, The Netherlands

Posted 05 August 2017 - 03:37 PM

I found several mentions of the same issue others had with this card. It uses the alx module for driver and there seems to be an issue with kernels from 4.0 and up. Patches are published somewhere on github, but never implemented in the official kernels, don't know why. It should be possible to rebuild this driver with the package from Atheros but that involves more investigation, unless you are familiar with compiling stuff yourself.

 

If your hardware has <4 GB RAM I would suggest trying the legacy version with a 3.16 32bit kernel that is supposed to work hasslefree. This won't work with a dual boot using UEFI for BIOS though!

 

Enjoy,

Charles



#13 klamathh

klamathh

    Member

  • Members
  • 18 posts

Posted 05 August 2017 - 09:33 PM

Just a thought. I was locked out by our home router today. Could you be experiencing a hardware issue?

 

Michel

 

no, no hw issue, moreover restarting networkmanager the card restart to work correctly



#14 klamathh

klamathh

    Member

  • Members
  • 18 posts

Posted 05 August 2017 - 09:40 PM

I found several mentions of the same issue others had with this card. It uses the alx module for driver and there seems to be an issue with kernels from 4.0 and up. Patches are published somewhere on github, but never implemented in the official kernels, don't know why. It should be possible to rebuild this driver with the package from Atheros but that involves more investigation, unless you are familiar with compiling stuff yourself.

 

If your hardware has <4 GB RAM I would suggest trying the legacy version with a 3.16 32bit kernel that is supposed to work hasslefree. This won't work with a dual boot using UEFI for BIOS though!

 

Enjoy,

Charles

 

ok

at the moment I'm using 4.0 which seems to have sporadic break, 1 a day or less

the 4.2 has more frequent

 

I'm not unfamiliar with compiling, as soon as will have a little time will look for on github for the patch

 

hi

Roberto



#15 graywizardlinux

graywizardlinux

    Bodhi Supporter

  • Members
  • 1064 posts

Posted 05 August 2017 - 09:51 PM

i had issues with the 4.0 install and since have used the 4.2 on a bunch of laptops and that is where i am with minimal hassles.  you may want to try the 4.2 and also do all updates and upgrades.



#16 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4567 posts
  • LocationZeist, The Netherlands

Posted 05 August 2017 - 10:12 PM

i had issues with the 4.0 install and since have used the 4.2 on a bunch of laptops and that is where i am with minimal hassles.  you may want to try the 4.2 and also do all updates and upgrades.

 

You have different network chips, so solutions for your hardware does not necessarily work on other hardware.



#17 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4567 posts
  • LocationZeist, The Netherlands

Posted 06 August 2017 - 12:16 PM

Hmm, I studied those patches a bit and they mainly are about adding the device to the alx driver list of aliases so it will be recognized and the module loaded at boot time. So this is probably not the solution for the connection issue.

 

I stumbled upon another topic where a user suggested a solution by changing a setting in the bios. As this is influencing I/O management that might be correct. And I know other people with other devices suffer from the same issue, so who knows.

 

Please READ HERE and judge yourself (read the footnote there about the order of steps as well). If it does not work changes can easily made undone.

 

Enjoy,

Charles



#18 klamathh

klamathh

    Member

  • Members
  • 18 posts

Posted 07 August 2017 - 02:22 PM

Hmm, I studied those patches a bit and they mainly are about adding the device to the alx driver list of aliases so it will be recognized and the module loaded at boot time. So this is probably not the solution for the connection issue.

 

I stumbled upon another topic where a user suggested a solution by changing a setting in the bios. As this is influencing I/O management that might be correct. And I know other people with other devices suffer from the same issue, so who knows.

 

Please READ HERE and judge yourself (read the footnote there about the order of steps as well). If it does not work changes can easily made undone.

 

Enjoy,

Charles

 

ok, Charles asap will try and give you feedback even if, I don't use a lot windows but from what written in the footnote it can works on linux but

in windows ? 

 

will give you feedback

 

Hi

Roberto



#19 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4567 posts
  • LocationZeist, The Netherlands

Posted 07 August 2017 - 03:02 PM

In my understanding IOMMU is present on some motherboards with high-level processors to have an option to give exclusive use of a certain device (could be any kind of device) to a virtual machine and similar use-cases. It might be hi-jacking your connection in someway without network manager knowing it. For what I gather the braking connection is not a device specific issue, it could happen to Broadcom, Realtek, Intel or whatever. Might be some design flaw that affects linux systems. I don't have hardware with this myself, so all I know is from reading.

 

Enjoy,

Charles



#20 klamathh

klamathh

    Member

  • Members
  • 18 posts

Posted 25 August 2017 - 03:14 PM

In my understanding IOMMU is present on some motherboards with high-level processors to have an option to give exclusive use of a certain device (could be any kind of device) to a virtual machine and similar use-cases. It might be hi-jacking your connection in someway without network manager knowing it. For what I gather the braking connection is not a device specific issue, it could happen to Broadcom, Realtek, Intel or whatever. Might be some design flaw that affects linux systems. I don't have hardware with this myself, so all I know is from reading.

 

Enjoy,

Charles

 

Hi Charles, sorry for the delay, went on holiday.

Since came back, some days ago, had no problems at all with network card

if will have trouble again will find time to try the advice and will report the results

 

Hi

Roberto






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users