Jump to content

Photo

Cheese and my webcam.

webcam

  • Please log in to reply
10 replies to this topic

#1 Xewess

Xewess

    Member

  • Members
  • 4 posts

Posted 01 August 2017 - 03:04 PM

Hi, I bought a Logitech webcam (c170) but I can't use Cheese.

When I type 'Cheese' in Terminology, these errors are shown:

 

(cheese:3624): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:121:0: Expected a valid selector
 
(cheese:3624): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:351:23: Not using units is deprecated. Assuming 'px'.
 
(cheese:3624): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:121:0: Expected a valid selector
 
(cheese:3624): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:351:23: Not using units is deprecated. Assuming 'px'.
libv4l2: error got 4 consecutive frame decode errors, last error: v4l-convert: libjpeg error: End Of Image
 
(cheese:3624): cheese-WARNING **: Failed to allocate a buffer: gstv4l2src.c(884): gst_v4l2src_create (): /GstCameraBin:camerabin/GstWrapperCameraBinSrc:camera_source/GstBin:bin18/GstV4l2Src:v4l2src1
 
I tried another apps like guvcview, camorama and fswebcam but none of them works either.
Although I can record my webcam with VLC and I can take pictures in facebook.
 
By the way if I uninstall Cheese, it still appears in the menu and I don't know how to remove it from there. 
 
Sorry for my bad English. :(
 
Edited: some solutions.
I  ran 'sudo cheese' and changed the size resolution: 640 x 480.
Now I can record videos and take pictures, but the audio quality is very poor, it has too much noise,  is there any way to fix it? 




A big thank you to everyone who contributes to Bodhi Linux


#2 birdmun

birdmun

    Member

  • Members
  • 416 posts
  • LocationWabash, IN

Posted 02 August 2017 - 12:55 AM

Your English reads better than mine many days. :D I wonder if maybe you need to add yourself to a group so you don't need to run sudo cheese. A quick search did not turn up any ideas on fixing the audio. Maybe the hardware is just poor?



#3 Xewess

Xewess

    Member

  • Members
  • 4 posts

Posted 04 August 2017 - 04:20 PM

I don't how to add myself to a group, I'm a new Linux user.  :lol: Although my laptop is old, I don't not think it's a hardware problem cause when I record with VLC the audio quality is good.



#4 birdmun

birdmun

    Member

  • Members
  • 416 posts
  • LocationWabash, IN

Posted 04 August 2017 - 06:58 PM

I don't feel comfortable enough to make suggestions for how you should proceed. I hope someone will step in and offer good, useful advice.



#5 Randy

Randy

    Bodhi-Care

  • Members
  • 649 posts
  • LocationFort Wayne, IN USA

Posted 05 August 2017 - 09:29 AM

a quick search came up with this,,,

 

https://askubuntu.co...tu-13-04#346546

 

 

What are the specs of your machine?


Randy Fry



Linux Addict!

#6 birdmun

birdmun

    Member

  • Members
  • 416 posts
  • LocationWabash, IN

Posted 05 August 2017 - 10:19 AM

The bit of searching I did with respect to his model and ubuntu suggested that his 640x480 switch was required to get things working. I just don't understand why he has to run cheese as root. The searching I did mentioned being added to the proper group and there was some more cli wizardry suggested, but, the links I had followed were Arch related and I don't want to suggest attempting to translate anything to a linux newb, no offence intended. I have spent 10 to 12 years with linux on and off for the first 5 or 6 and pretty solid for the last 5 or 6. If I "blow something up", I don't feel so uncomfortable about attempting to fix it or reinstalling.



#7 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4617 posts
  • LocationZeist, The Netherlands

Posted 05 August 2017 - 12:33 PM

Hmm, maybe you need setting alsamixer to use the correct input device for sound.

 

Enjoy,

Charles



#8 DOOMguy

DOOMguy

    Member

  • Members
  • 236 posts

Posted 05 August 2017 - 01:36 PM

there is a danger in running things as root, to elaborate further what birdmun says. It tends to bulldoze over some problems and exposes a different set of problems. Try running cheese as a regular user, and we can proceed from there. The alsamixer that Charles mentioned also helps. The good thing is that your camera does work; it just needs a little more tweaking. It would be wise to get out of the "sudo this" mentality early on for a newbie. 


Unsolicited advice for learning linux, that won't cost you anything


#9 Xewess

Xewess

    Member

  • Members
  • 4 posts

Posted 06 August 2017 - 04:08 AM

I usually don't use 'sudo', although I'm a newbie I know I shouldn't do that. I just did it because it was the only way to make Cheese record, If I run cheese as a regular user it doesn't record anything. :-/

 

And these are the specs of my machine:

  • Intel Celeron processor 560 (2.13 GHz)
  • 1GB RAM
  • 111GB HDD
  • Mobile Intel Graphics Media Accelerator X3100


#10 birdmun

birdmun

    Member

  • Members
  • 416 posts
  • LocationWabash, IN

Posted 07 August 2017 - 02:11 AM

I wonder if you can run cheese, as a regular user, in some kind of debug/more verbose mode, so that you can get info about what is keeping you from recording video. LIke, Permission denied writing to such and such location. I still think you may need to add yourself to something like the video or webcam group. If you search for ubuntu add user to group CLI that you may possibly fix your recording issue.



#11 Xewess

Xewess

    Member

  • Members
  • 4 posts

Posted 10 August 2017 - 07:41 AM

Well, I already added myself to the video and audio groups  but I still can't record with Cheese. I think I'd better use VLC. You Know, this is the only hardware problem that I have and it's not  so big, I think  I'd better leave it at that.

Thanks anyway.  :) 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users