Jump to content

Photo

No WiFi Connection in Bodhi Live

wifi internet network nm-applet dell wireless adapter

  • Please log in to reply
3 replies to this topic

#1 andbeyond

andbeyond

    Member

  • Members
  • 1 posts

Posted 02 August 2017 - 05:21 PM

Aloha! I am trying to switch an old Dell Inspiron mini 10 from Windows 7 to Bodhi. I am at the "Bodhi live" stage of things, and I am unable to connect to the internet. The network manager does not recognize/show any wifi connections even though the computer still connects through Windows (where I am working right now). I have spent a couple days trying to resolve the issue with what is already on the web, but I have not been successful. Thus, I am making a new post with the hope of getting new ideas/support that will help me - and maybe others, too! - understand the problem and resolve it.
 
Some info that might be relevant:
(1) I don't have a USB or a disk drive, so when I ran UNetbootin, I chose "hard drive" instead of "USB". To boot Bodhi live: I start the computer, the system automatically goes to BIOS, and I select "UNetbootin" instead of "Windows".
 
(2) I would like to have a better understanding of computer hardware, Linux commands, and their relationship, but I know enough to have started probing into which network adapters Bodhi "sees." When I run the command 
sudo lshw -class network
in Terminology, I don't see anything in the output about "Dell Wireless 1937 WLAN Mini-Card" or "Microsoft virtual WiFi Miniport Adapter", which are listed in Windows' System Information under Network Adapters. Based on this Ubuntu help page, I ran
lspci -vvnn | grep -A 9 Network

from which I gathered that I have a Broadcom BCM4313 chip...or maybe 4312 (I know, should've written it down! I can switch to Bodhi and run it again after I finish this post). But definitely a number for which the page suggests bcmwl-kernel-source. However, when I ran

sudo apt-get install bcmwl-kernel-source

at the suggestion of an earlier page, I was asked to insert a disk, which I can't do.

 

(3)Speaking of problems with requests from Bodhi, I am sometimes asked for a password. Neither leaving it blank nor using my Windows password has worked. 

 

(4) Other system information:

Processor: Intel® Atom™ CPU N270   @ 1.60GHz, 1600 Mhz, 1 Core(s), 2 Logical Processor(s)

BIOS Version/Date: Dell Inc. A06, 2009-07-29
Network adapters: Dell Wireless 1397 WLAN Mini-Card
Microsoft Virtual WiFi Miniport Adapter
Realtek PCIe FE Family Controller

 

Any ideas on where the problem lies and what I can do? Your help is appreciated!

 

P.S. I have done my best to do my own homework and observe forum etiquette, but I am open to feedback if I have committed any faux pas.





A big thank you to everyone who contributes to Bodhi Linux


#2 Jeff

Jeff

    Lead Developer

  • Developer
  • 12430 posts
  • LocationBloomington, IL

Posted 02 August 2017 - 10:52 PM

It has been awhile since I've used a broadcom chip - but I am unsure off hand if the live CD will have enough space to install the kernel drivers to use on the live distro.

Maybe someone who has used one more recently can confirm. 

Welcome to the boards.



#3 sef

sef

    Bodhi Builder Wizard

  • Developer
  • 306 posts
  • LocationATL

Posted 03 August 2017 - 10:49 AM

Speaking of problems with requests from Bodhi, I am sometimes asked for a password. Neither leaving it blank nor using my Windows password has worked

 

 

username is bodhi -- there is no password

 

This is something I am looking into regarding the live ISO. Seems that there is a 10 minute screensaver timeout as indicated by doing "xset q" and looking in the screensaver section at 'timeout: 600'. You can fix it in the live ISO by issuing the command "xset s 0", then it won't kick out to the lightdm login prompt. But each time you boot again to the live ISO you will have to run that command to disable the timeout.


Nothing is as simple as it seems at first, or as hopeless as it seems in the middle, or as finished as it seems in the end.

 

"That's not how the force works..."

 

Forum Rules


#4 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4511 posts
  • LocationZeist, The Netherlands

Posted 03 August 2017 - 12:44 PM

Hmm, the package that you need is on your HDD. The question how to point your live session to the right spot and make it believe that is a CD with a local repository. That involves mounting the stuff that Unetbootin copied to hdd at /cdrom. I suppose you let Unetbootin use a separate partition on your hdd, so the command would be something like

sudo mount -t iso9660 /dev/sdaX /cdrom

where X has to be replaced with the correct partition number.

Partition layout can be found by the command lsblk

If this is not showing enough info use the command sudo parted -l #(lowercase L)

 

Since this is a live-CD you can not destroy anything as it is a read-only filesystem, nothing gets truly changed and on a reboot you start afresh.

 

Hope this helps a bit.

 

Enjoy,

Charles







Also tagged with one or more of these keywords: wifi, internet, network, nm-applet, dell, wireless, adapter

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users