Jump to content

Photo

Terminology CPU anomaly when running "nmon" app

terminology nmon cpu

  • Please log in to reply
7 replies to this topic

#1 oqbqbodpdpo

oqbqbodpdpo

    Member

  • Members
  • 24 posts
  • LocationColumbus, OH

Posted 04 August 2017 - 05:20 AM

I recently installed Bodhi 4.2.0 Legacy on an old Toshiba Satellite A10 laptop (2.20Ghz Pentium 4-M CPU, 768MB RAM) and have noticed strangely high CPU use by the nmon app itself (20–30%) when it's running under terminology. I installed xfce4-terminal for comparison and under it nmon runs 'lightly' (0.5–1.0%) as expected.

 

terminology:

shot-2017-08-0400-29-20.png

 

xfce4-terminal:

shot-2017-08-0400-34-52.png





A big thank you to everyone who contributes to Bodhi Linux


#2 The waiter

The waiter

    Module Master

  • Developer
  • 1573 posts
  • LocationBanska Bystrica, Slovakia

Posted 04 August 2017 - 07:00 AM

Hello

 

Is the same situation with htop command?



#3 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4511 posts
  • LocationZeist, The Netherlands

Posted 04 August 2017 - 11:24 AM

Can't duplicate that high cpu-usage on a Virt Machine with only 1 core assigned from the CPU (Intel i3) and 1GB RAM, it's just 0.5%.

 

Can you run nmon in debug mode and see if the log shows something?

 

Enjoy,

Charles



#4 oqbqbodpdpo

oqbqbodpdpo

    Member

  • Members
  • 24 posts
  • LocationColumbus, OH

Posted 04 August 2017 - 06:07 PM

htop runs fine for me under terminology (and xfce4-terminal, both). Uses slightly more CPU than nmon does (with my routine "n,m,c,d,t" options running), but such is usual in my experience.

How do I run nmon in debug mode? And when doing so where will the data be logged?



#5 oqbqbodpdpo

oqbqbodpdpo

    Member

  • Members
  • 24 posts
  • LocationColumbus, OH

Posted 07 August 2017 - 05:41 PM

I've now installed the 32 bit Legacy version of Bodhi on an old IBM M50 as well. It has the same high CPU usage anomaly by terminology when running nmon.  I upgraded the kernel to 4.10.0 so as to make Bodhi aware of the hyperthreading in the Pentium 4 CPU (w/ default non-pae kernel htop and nmon were only showing a single core in CPU meters; now show both threads). Thought such might by chance address the anomaly as well, but no terminology is still running high CPU when running nmon, even with new kernel. 

 

The anomaly seems to only manifest when the terminology tab running nmon is the one brought into focus. If I start nmon in one terminology tab and then switch to a second terminology tab and check from htop the terminology CPU use drops off. Same if I check CPU use from a different virtual desktop/workspace than the one with terminology focused on running nmon. 

Curiously, when I tried placing a small xfce4-terminal window over a maximized terminology window with nmon running in the terminology window and htop running in the xfce4-terminal window on top of it the CPU anomaly went away when the xfce4-terminal window running htop had focus ... even though terminology was actively displaying nmon output visibly in the background. When focus was brought back to the terminology window CPU use rose again.

 

Charles, did you test specifically the Legacy version in a 32 bit VM? As I've now reproduced the anomaly on two different 32 bit Pentium 4 machines (well, a P 4 and a P 4-M, one with hyperthreading and one without) I'm wondering if your test may not have been effectively emulating 'apples-to-apples'.



#6 oqbqbodpdpo

oqbqbodpdpo

    Member

  • Members
  • 24 posts
  • LocationColumbus, OH

Posted 07 August 2017 - 07:55 PM

I hopped on Enlightenment's IRC channel and got directed to 'phab' where I posted an inquiry which led to discovering that turning off cursor animation makes the CPU spike behavior go away.

phab thread:
https://phab.enlightenment.org/T5854

 

handy URL:

http://issues.terminolo.gy/ 



#7 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4511 posts
  • LocationZeist, The Netherlands

Posted 07 August 2017 - 08:41 PM

Thanks for sharing this notes about the cursor. My animations were turned off all the time. And I did test on a VM Legacy 4.2..0 with only 1 core.

 

Enjoy,

Charles



#8 oqbqbodpdpo

oqbqbodpdpo

    Member

  • Members
  • 24 posts
  • LocationColumbus, OH

Posted 08 August 2017 - 05:24 PM

You're welcome.
Boris (@billiob; Terminology dev) over at Phab has since put forth the suggestion that the CPU spike with blinking enabled may relate to forced display redraws without having compositing enabled. However I'm still seeing the same behavior on an Xfce distro (MX-15, Debian Jessie base) with Xfce's native compositing enabled. Perhaps someone who has already added/enabled compositing onto Bodhi might check and see if it makes a difference with a more recent (than Debian Jessie's) Terminology running under Moksha.

Tnx 4 offering your time-&-attention,
Kevin







Also tagged with one or more of these keywords: terminology, nmon, cpu

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users