Jump to content

Photo

Printer Support


Best Answer Charles@Bodhi, 11 August 2017 - 09:51 AM

OK, getting rid of the menu entry.

Menu > QuickLauncher > Type imagem and select the app represented with a logo. > Hit TAB and choose Edit Application Entry > Options tab > uncheck "Show in Menu". You will have to do this for all instances of imagemagick with a logo, the other mentions are not .desktop files.

 

Making Ephoto default for the usual formats.

Menu > Settings > tab Apps > Default applications.

In the dialog left pane scroll ~3/4 down where you should see a list of file extensions starting with image/. Select the items (one by one) with at least gif,jpeg,png and then choose Ephoto in the right pane as assigned application and hit apply. Do so for every image format you want but make sure Ephoto can handle that format.

 

This should do the trick.

 

Enjoy,

Charles

Go to the full post


  • Please log in to reply
8 replies to this topic

#1 auro

auro

    Member

  • Members
  • 9 posts

Posted 10 August 2017 - 06:46 PM

Hi,

I got Printer Support package from the AppCenter and I'm quite happy with it, got my Canon MG6350 printing. Although, I would like to know what packages are included in that?

There is a new item on my menu, namely ImageMagick (display Q16) showing twice in the menu. The annoying thing is that my photos open in it be default, instead of as previously with EPhoto.

Do I need this for the printing? Can I remove ImageMagick and if so, how?
If I type imagemagick in the terminal it says that it's not installed, although we already know it is...

Thanks!

EDIT: So, I figured out that this package is needed for printing. But, why is it showing twice in the menu? How do I remove one of these two entries? Also, can I do something so my photos open in EPhoto per default as before?



A big thank you to everyone who contributes to Bodhi Linux


#2 DOOMguy

DOOMguy

    Member

  • Members
  • 166 posts

Posted 10 August 2017 - 07:23 PM

When you launch synaptic look for the package that you installed; you can select that package  which should have an entry under "installed version" and click the Properties button, and you can then go to the tab labeled Installed files. You might even see two entries with ImageMagick--one of them could be ImageMagick (display), for the print preview option; the other is for the actual print function ImageMagick (Print). There are some menu entries that are too long and end up getting truncated, so one would get the impression that there is a repeat.


Unsolicited advice for learning linux, that won't cost you anything


#3 auro

auro

    Member

  • Members
  • 9 posts

Posted 10 August 2017 - 07:31 PM

Great, Thanks!
I'll look into that.
Can I do something so that my photos open in EPhoto per default? Right now I have to choose "Open with", otherwise they open with imagemagick.

#4 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4522 posts
  • LocationZeist, The Netherlands

Posted 10 August 2017 - 07:39 PM

Try this in terminal:

sudo apt-get install --reinstall ephoto

That should restore the mime settings for ephoto that were "hijacked" by imagemagick.

 

Enjoy,

Charles



#5 auro

auro

    Member

  • Members
  • 9 posts

Posted 11 August 2017 - 07:30 AM

@DOOMguy

Cheers, it's clear for me now why there are two entries of imagemagick in the menu. Thanks! :)

But, should they be there at all? Imagemagick does not have a GUI by default, it's a CLI application, so why showing-up in the menu? Is there a configuration file that can be edited, so that it does not show in the menu, but keeping it installed?

 

@Charles

Thanks!

sudo apt-get install --reinstall ephoto

didn't help, so I tryed

sudo apt-get remove ephoto
sudo apt-get install ephoto

but to no avail :unsure:

My photos still open with imagemagick per default. The annoying thing with this is that imagemagick opens them in full resolution, i.e the maximum resolution of the photo itself and that's much larger than my screen. Is there a "always open files of this type using this application, unless stated otherwise" or something that can override how photos are open?

 

Thank you to you both!



#6 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4522 posts
  • LocationZeist, The Netherlands

Posted 11 August 2017 - 09:51 AM   Best Answer

OK, getting rid of the menu entry.

Menu > QuickLauncher > Type imagem and select the app represented with a logo. > Hit TAB and choose Edit Application Entry > Options tab > uncheck "Show in Menu". You will have to do this for all instances of imagemagick with a logo, the other mentions are not .desktop files.

 

Making Ephoto default for the usual formats.

Menu > Settings > tab Apps > Default applications.

In the dialog left pane scroll ~3/4 down where you should see a list of file extensions starting with image/. Select the items (one by one) with at least gif,jpeg,png and then choose Ephoto in the right pane as assigned application and hit apply. Do so for every image format you want but make sure Ephoto can handle that format.

 

This should do the trick.

 

Enjoy,

Charles



#7 birdmun

birdmun

    Member

  • Members
  • 350 posts
  • LocationWabash, IN

Posted 11 August 2017 - 10:36 AM

Another option I have found that works for me is open pcmanfm, find a file of whatever type I want to adjust, right click, select properties, and in that window you will see Open with:. Just choose the program you want that file type to open with.



#8 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4522 posts
  • LocationZeist, The Netherlands

Posted 11 August 2017 - 10:47 AM

Another option I have found that works for me is open pcmanfm, find a file of whatever type I want to adjust, right click, select properties, and in that window you will see Open with:. Just choose the program you want that file type to open with.

 

Yep, but don't forget to use the checkbox at the bottom about making it default.



#9 auro

auro

    Member

  • Members
  • 9 posts

Posted 11 August 2017 - 02:38 PM

Thanks Charles!

Those steps did it  :) !

 

Thanks to all of you for the input.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users