Jump to content

Photo

Stop Ibar flicker


Best Answer Charles@Bodhi, 19 August 2017 - 09:43 AM

Confusion maybe.

 

Engage is a module that acts as a "floating shelf" or "gadget container". Default parts of it are iBar and Tasks, you can also add some other gadgets.

In a standard shelf or as desktop gadget or in Engage you can access the ibar settings by right clicking on an icon in the ibar.

The iBar instance in Engage is more configurable ( e.g. zooming) compared to the default because Engage has more fancy options.

 

Enjoy,

Charles

Go to the full post


  • Please log in to reply
18 replies to this topic

#1 michmanbiker

michmanbiker

    Member

  • Members
  • 130 posts
  • LocationMontreal, Quebec, Canada

Posted 17 August 2017 - 08:02 PM

I am sure it is written somewhere, but Bodhis menu options are so many, I get lost! 

 

Is there a way to stop Ibar app icons to stop flickering when I mouse over them. It is just too distracting and makes me click on the wrong app sometimes.

 

Thanks,

 

Michel





A big thank you to everyone who contributes to Bodhi Linux


#2 The waiter

The waiter

    Module Master

  • Developer
  • 1657 posts
  • LocationBanska Bystrica, Slovakia

Posted 17 August 2017 - 08:22 PM

Yes, it, is. As I wrote before, you need to install bodhi-theme-moksha-detour theme and use it, or just assign iBar from this theme to your current theme in the theme advanced settings...

 

e-5995f9f4e817f8.45544468.jpg



#3 michmanbiker

michmanbiker

    Member

  • Members
  • 130 posts
  • LocationMontreal, Quebec, Canada

Posted 17 August 2017 - 08:28 PM

I don't really get it. I can stop the flicker in that specific theme only?

 

Thanks,

 

Michel



#4 The waiter

The waiter

    Module Master

  • Developer
  • 1657 posts
  • LocationBanska Bystrica, Slovakia

Posted 17 August 2017 - 08:31 PM

The simplest way I can suggest. It is a theme matter. But as I said, use the detour lBar theme and bind it with your current theme. The harder way is to decompile theme, find the script lines which are related to this effect, disable the effect, compile it back to edj file and copy to the proper locations. Feel free to try :)

 

BTW: I like that effect. It helps me know I am above right icon.



#5 DOOMguy

DOOMguy

    Member

  • Members
  • 236 posts

Posted 17 August 2017 - 09:48 PM

Try this, when you right click on that bar, and it shows 'Configure Bar' and you get to pick some of its settings: try checking or unchecking Show mouseover animation and see if it eliminates or reduces the effect. I have to let you know that my detourious screenshot posted on another thread shows some other special effects and they're being displayed by an AMD Radeon graphics card.


Unsolicited advice for learning linux, that won't cost you anything


#6 michmanbiker

michmanbiker

    Member

  • Members
  • 130 posts
  • LocationMontreal, Quebec, Canada

Posted 17 August 2017 - 11:12 PM

Removed the application name showing. Things a re abit less cluttered now, but no options for removing the flicker. No problem really. Thanks for all.



#7 DOOMguy

DOOMguy

    Member

  • Members
  • 236 posts

Posted 18 August 2017 - 01:16 AM

Do you still have Bodhi on a USB stick or disc that you can run on a friend's netbook or laptop, I was wondering whether the symptoms do not appear on different hardware. And there is no option to "remove flicker" but having mouseover animations checked or unchecked might have more to do with it. In any case, it could be a mere annoyance; you're welcome, but still welcome to try this last one out too.


Unsolicited advice for learning linux, that won't cost you anything


#8 michmanbiker

michmanbiker

    Member

  • Members
  • 130 posts
  • LocationMontreal, Quebec, Canada

Posted 18 August 2017 - 02:16 AM

Do you still have Bodhi on a USB stick or disc that you can run on a friend's netbook or laptop, I was wondering whether the symptoms do not appear on different hardware. And there is no option to "remove flicker" but having mouseover animations checked or unchecked might have more to do with it. In any case, it could be a mere annoyance; you're welcome, but still welcome to try this last one out too.

Where can I check / uncheck mouseover animation?



#9 JollyRoger

JollyRoger

    Member

  • Team
  • 196 posts
  • LocationHigh Wycombe, UK

Posted 18 August 2017 - 03:21 PM

michmanbiker

 

I think what may not be clear to you is that you can combine elements from other themes with your main theme. This is what the Waiter was suggesting you do in an earlier post. You have to first install those other themes, then from the Main menu choose Settings then Theme. At the Theme Selector dialog box click Advanced, where you can select elements from other themes (such as Modules/iBar) to incorporate into your theme.

 

What Waiter is saying is that this element from the detour theme will stop the mouse effects you mention. I can't comment on this as I haven't tried it.



#10 DOOMguy

DOOMguy

    Member

  • Members
  • 236 posts

Posted 18 August 2017 - 04:14 PM

Michel, how to get there is in post # 5, but JollyRoger is referring to the waiter's post preceding mine, post # 4. And yes, you can mix and match pieces from different themes, so that you are not limited to one theme only. My overall theme, right down to the clock gadget, is detourious but going to the Advanced Theme setting I could assign Black Nostrum to do my borders because the filament-thin borders in detourious mean that I cannot Window shade Left.

 

The next screenshot illustrates the result.


Unsolicited advice for learning linux, that won't cost you anything


#11 The waiter

The waiter

    Module Master

  • Developer
  • 1657 posts
  • LocationBanska Bystrica, Slovakia

Posted 18 August 2017 - 04:18 PM

DOOMguy, please tell how you get to the Show mouseover animation setting. Hmm, I had to missed sth, but seriously not able to see it. Post the screenshot for users here, please...



#12 DOOMguy

DOOMguy

    Member

  • Members
  • 236 posts

Posted 18 August 2017 - 06:11 PM

here is the image. Times like these I wish more of us here were on IRC, but that is a topic for another time


Unsolicited advice for learning linux, that won't cost you anything


#13 The waiter

The waiter

    Module Master

  • Developer
  • 1657 posts
  • LocationBanska Bystrica, Slovakia

Posted 18 August 2017 - 06:25 PM

Oh, we are talking about lBar and you about Engage module. 



#14 michmanbiker

michmanbiker

    Member

  • Members
  • 130 posts
  • LocationMontreal, Quebec, Canada

Posted 18 August 2017 - 09:11 PM

michmanbiker

 

I think what may not be clear to you is that you can combine elements from other themes with your main theme. This is what the Waiter was suggesting you do in an earlier post. You have to first install those other themes, then from the Main menu choose Settings then Theme. At the Theme Selector dialog box click Advanced, where you can select elements from other themes (such as Modules/iBar) to incorporate into your theme.

 

What Waiter is saying is that this element from the detour theme will stop the mouse effects you mention. I can't comment on this as I haven't tried it.

Hello Jolly I got the general idea, just don't want to change how my theme looks right now. All is well. It still flickers, but I removed the app names from appearing and it makes it OK. Thanks



#15 michmanbiker

michmanbiker

    Member

  • Members
  • 130 posts
  • LocationMontreal, Quebec, Canada

Posted 18 August 2017 - 09:11 PM

Oh, we are talking about lBar and you about Engage module. 

Now I'm really confused  :(



#16 DOOMguy

DOOMguy

    Member

  • Members
  • 236 posts

Posted 18 August 2017 - 09:24 PM

well, so am I; right click says, Configure bar. *shrug*


Unsolicited advice for learning linux, that won't cost you anything


#17 birdmun

birdmun

    Member

  • Members
  • 413 posts
  • LocationWabash, IN

Posted 19 August 2017 - 05:17 AM

15 seconds of your life will show you what The waiter was suggesting.

 

DOOMguy, your settings panel specifies Engage settings rather than iBar Settings.



#18 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4616 posts
  • LocationZeist, The Netherlands

Posted 19 August 2017 - 09:43 AM   Best Answer

Confusion maybe.

 

Engage is a module that acts as a "floating shelf" or "gadget container". Default parts of it are iBar and Tasks, you can also add some other gadgets.

In a standard shelf or as desktop gadget or in Engage you can access the ibar settings by right clicking on an icon in the ibar.

The iBar instance in Engage is more configurable ( e.g. zooming) compared to the default because Engage has more fancy options.

 

Enjoy,

Charles



#19 The waiter

The waiter

    Module Master

  • Developer
  • 1657 posts
  • LocationBanska Bystrica, Slovakia

Posted 19 August 2017 - 07:26 PM

Sometimes it is hard to assume the user experiencie and fit the right answer. Now I hope everything is clear...
Video tutorial was about turning off the icon label but I was talking about combining two themes as was already said.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users