Jump to content

Photo

Time setting in Enlightenment

time enlightenemnt gui settings

  • Please log in to reply
25 replies to this topic

#1 Suncatcher

Suncatcher

    Member

  • Members
  • 70 posts

Posted 22 August 2017 - 07:51 AM

Hi there,

where can I set time/timezone in GUI? Is it possible in Enlightenment or I should use only

 

 

 dpkg-reconfigure tzdata

 





A big thank you to everyone who contributes to Bodhi Linux


#2 The waiter

The waiter

    Module Master

  • Developer
  • 1657 posts
  • LocationBanska Bystrica, Slovakia

Posted 22 August 2017 - 08:55 AM

NO, there is no GUI for timezone...

 

There are some goals in Jeff's project called Swami control. Not sure if this feature was included.



#3 Randy

Randy

    Bodhi-Care

  • Members
  • 649 posts
  • LocationFort Wayne, IN USA

Posted 22 August 2017 - 09:07 AM

You can try ntp.  Look for it in synaptic or install in terminal with... 

 

sudo apt-get install ntp

 

 

 

then install gnome-system-tools...

 

sudo apt-get install gnome-system-tools  --no-install-recommends

 

 

Look for "Time and Date" in main menu/preferences


Randy Fry



Linux Addict!

#4 The waiter

The waiter

    Module Master

  • Developer
  • 1657 posts
  • LocationBanska Bystrica, Slovakia

Posted 22 August 2017 - 09:37 AM

I meant, there is no default E GUI within Moksha desktop...

 

Randy, thx for more info...

 

Stefan



#5 Jeff

Jeff

    Lead Developer

  • Developer
  • 12524 posts
  • LocationBloomington, IL

Posted 22 August 2017 - 01:16 PM

The swami control panel is installed by default in the latest Bodhi release and provides a GUI for changing the date and time settings.

If you installed an older Bodhi release you can add the Swami Control panel with the commands:

 

sudo apt-get update
sudo apt-get install swami-control


#6 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4616 posts
  • LocationZeist, The Netherlands

Posted 22 August 2017 - 02:38 PM

FYI in the menu swami-control is called "System Settings" under Applications > System Tools

 

Enjoy,

Charles



#7 Suncatcher

Suncatcher

    Member

  • Members
  • 70 posts

Posted 22 August 2017 - 03:04 PM

FYI in the menu swami-control is called "System Settings" under Applications > System Tools

 

Enjoy,

Charles

 

Okay, I installed those Swami, but I get this

 

shot-2017-08-22_02-57-57.jpg



#8 Suncatcher

Suncatcher

    Member

  • Members
  • 70 posts

Posted 22 August 2017 - 03:05 PM

How can I check what is wrong?



#9 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4616 posts
  • LocationZeist, The Netherlands

Posted 22 August 2017 - 03:32 PM

In terminal type

swami

and post the outcome, might give a clue.

 

Did you perform all updates? If so what method did you use? For best result you should use the following in terminal:

sudo apt-get update
sudo apt-get dist-upgrade

Enjoy,

Charles



#10 Suncatcher

Suncatcher

    Member

  • Members
  • 70 posts

Posted 22 August 2017 - 04:57 PM

Here is the outcome:

root@bodhi-v:/home/suncatcher# swami
No protocol specified
No protocol specified
No protocol specified
No protocol specified
Traceback (most recent call last):
  File "/usr/bin/swami", line 177, in <module>
    app = MainWin(launchArg)
  File "/usr/bin/swami", line 36, in __init__
    autodel=True, size=(600, 400))
  File "efl/elementary/window.pxi", line 1516, in efl.elementary.__init__.StandardWindow.__init__ (efl/elementary/__init__.c:378144)
  File "efl/elementary/object.pxi", line 111, in efl.elementary.__init__.Object._set_obj (efl/elementary/__init__.c:250435)
  File "efl/evas/efl.evas_object.pxi", line 198, in efl.evas.Object._set_obj (efl/evas/efl.evas.c:54834)
  File "efl/eo/efl.eo.pyx", line 254, in efl.eo.Eo._set_obj (efl/eo/efl.eo.c:3484)
AssertionError: Cannot set a NULL object 


#11 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4616 posts
  • LocationZeist, The Netherlands

Posted 22 August 2017 - 05:58 PM

We had errors like that a while ago, thought that was fixed in an update. It does not happen on my fresh 4.2.0 install. Have a look here.

You can go to Elementary Config using the menu under Applications > Preferences. In post#15 I wrote what I did and that worked for me.

 

What version did you have to install your system and how did you update that?

 

Enjoy,

Charles



#12 Jeff

Jeff

    Lead Developer

  • Developer
  • 12524 posts
  • LocationBloomington, IL

Posted 22 August 2017 - 06:58 PM

Can you please try running Swami as your normal user? It looks from your terminal that you are trying to launch it as root. 



#13 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4616 posts
  • LocationZeist, The Netherlands

Posted 22 August 2017 - 07:09 PM

Can you please try running Swami as your normal user? It looks from your terminal that you are trying to launch it as root. 

 

missed that.



#14 Suncatcher

Suncatcher

    Member

  • Members
  • 70 posts

Posted 23 August 2017 - 08:28 AM

Can you please try running Swami as your normal user? It looks from your terminal that you are trying to launch it as root. 

 

Just another error

suncatcher@bodhi-v:~$ swami

Traceback (most recent call last):
  File "/usr/bin/swami", line 177, in <module>
    app = MainWin(launchArg)
  File "/usr/bin/swami", line 74, in __init__
    self.loadModules()
  File "/usr/bin/swami", line 130, in loadModules
    self.modules[imported] = imported.SwamiModule(self)
  File "/usr/lib/python2.7/dist-packages/swami_startupapps/swami_startupapps.py", line 94, in __init__
    with open(d) as desktopFile:
IOError: [Errno 2] No such file or directory: '/usr/share/applications/gdebi.desktop'


#15 Suncatcher

Suncatcher

    Member

  • Members
  • 70 posts

Posted 23 August 2017 - 08:29 AM

Just FYI, gdebi is installed on my system:

root@bodhi-v:/home/suncatcher# apt-get install gdebi-core
Reading package lists... Done
Building dependency tree
Reading state information... Done
gdebi-core is already the newest version (0.9.5.7ubuntu1).
gdebi-core set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 14 not upgraded

If swami requires not gdebi but gdebi's shortcut (gdebi.desktop) then it's dumbest app, I've ever seen.



#16 Suncatcher

Suncatcher

    Member

  • Members
  • 70 posts

Posted 23 August 2017 - 08:45 AM

Did you perform all updates? If so what method did you use? For best result you should use the following in terminal:

sudo apt-get update
sudo apt
-get dist-upgrade

 

 

Didn't help.



#17 Jeff

Jeff

    Lead Developer

  • Developer
  • 12524 posts
  • LocationBloomington, IL

Posted 23 August 2017 - 12:28 PM

One of Swami's modules is managing startup applications. It doesn't have any dependence on gdebi - it is simply trying to add all of your .desktop files to a list so it can offer them as startup applications.

 

Does the file /usr/share/applications/gdebi.desktop exist? If it exists is it a normal file or is it a symlink for some reason? Can you please post the output of the command:
 

ls /usr/share/applications

Swami is a newer tool and we've tested it for a variety of use cases - but obviously whatever state your current system is in right now was not one of them. Wonder what is different - I can't reproduce any launch errors with Swami on any of my 4 physical systems or my half a dozen virtual machines. 



#18 Suncatcher

Suncatcher

    Member

  • Members
  • 70 posts

Posted 23 August 2017 - 02:14 PM

Gdebi is marked in red.

 

EXJrasD.png



#19 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4616 posts
  • LocationZeist, The Netherlands

Posted 23 August 2017 - 03:40 PM

It's marked in red because it is a (faulty) symlink like Jeff was talking about. That symlink should point to an existing file but in your case that file is missing though it has been there it seems , seeing gdebi-old in your output.

sudo apt-get install --reinstall gdebi-bodhi-launcher

Should fix this.

Any reason why you are logged in as root? Quite dangerous IMHO.

 

Enjoy,

Charles



#20 Suncatcher

Suncatcher

    Member

  • Members
  • 70 posts

Posted 24 August 2017 - 09:01 AM

Thanks, that helped. Swami is really cool.

 

Any reason why you are logged in as root? Quite dangerous IMHO.

 

I am not logged as root. Where do you see this on screen? Root permissions on .desktop files are confusing you?  I dunno why they root-owned, maybe because I install apps as root?  :)

 

P.S. What concerns this error, some type of exception handling should be built in Swami for such cases, in order that some dummy shortcut not to break app start.







Also tagged with one or more of these keywords: time, enlightenemnt, gui, settings

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users