Jump to content

Photo

Cannot save security settings on new Wi-Fi connection


Best Answer gogolink, 05 September 2017 - 02:11 AM

I figured it out.  What a silly mistake on my part!

 

There was a checkbox to the left of the statement "No CA certificate is required" that wasn't rendered as a box -- and so I didn't see it, and didn't check it.  Once I checked it, the save button was no longer grayed out.

 

Thanks for all the input!

Go to the full post


  • Please log in to reply
6 replies to this topic

#1 gogolink

gogolink

    Member

  • Members
  • 78 posts

Posted 02 September 2017 - 12:38 PM

Hi, I'm running Bodhi 4.2 on an Acer c720 Chromebook (very happily, btw), and I'm trying to set up a new network connection.

 

I was able to add a new WiFi connection, but when I'm editing the security settings, the "Save" button is greyed out.

 

The settings I need (and put in) are

 

 

Security: WPA & WPA2 Enterprise
∘ Authentication: Protected EAP (PEAP)
∘ CA certificate: No CA certificate is required
∘ PEAP versions: Automatic
∘ Inner authentications: MSCHAPv2
∘ Username: kgogolin
∘ Password: •••••••••

 

(I'd post a screenshot, but don't understand how to.)

 

I can enter the settings into the nm-applet connection editor, but I can't save them.  I tried running the nm-applet in gksudo as well.

 

Any ideas?

 





A big thank you to everyone who contributes to Bodhi Linux


#2 birdmun

birdmun

    Member

  • Members
  • 413 posts
  • LocationWabash, IN

Posted 02 September 2017 - 02:29 PM

Just for giggles, add 8.8.8.8 to the dns in the ipv4 tab and see if that helps. I have seen the issue before, but, don't recall if/how I fixed it.

 

BTW 8.8.8.8 is one of Goggle's domain name servers. There are many other options from different sources, if Goggle is "EVIL" to you. :)



#3 Jeff

Jeff

    Lead Developer

  • Developer
  • 12524 posts
  • LocationBloomington, IL

Posted 03 September 2017 - 02:22 PM

If running as root doesn't solve the issue this is likely a nm-applet bug. 



#4 DOOMguy

DOOMguy

    Member

  • Members
  • 236 posts

Posted 03 September 2017 - 06:37 PM

I had noticed that the SAVE is grayed out when there is invalid or insufficient information in the window e.g. there was no password entered when the security that was specified insists or requires one. In that case, entering a password will then let me save it, but entering one that is too short leaves it grayed out. I think it was in nm-applet or network connection setup, but without the screenshot I can't say for sure


Unsolicited advice for learning linux, that won't cost you anything


#5 Randy

Randy

    Bodhi-Care

  • Members
  • 649 posts
  • LocationFort Wayne, IN USA

Posted 04 September 2017 - 01:35 AM

Have you run any updates yet? I had similar issues and they cleared up after some updates.


Randy Fry



Linux Addict!

#6 gogolink

gogolink

    Member

  • Members
  • 78 posts

Posted 05 September 2017 - 02:11 AM   Best Answer

I figured it out.  What a silly mistake on my part!

 

There was a checkbox to the left of the statement "No CA certificate is required" that wasn't rendered as a box -- and so I didn't see it, and didn't check it.  Once I checked it, the save button was no longer grayed out.

 

Thanks for all the input!



#7 DOOMguy

DOOMguy

    Member

  • Members
  • 236 posts

Posted 05 September 2017 - 11:54 AM

Excellent! You knew where to look :lol:  Glad you figured it out; we would never have guessed it


Unsolicited advice for learning linux, that won't cost you anything





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users