Jump to content

Photo

nm-applet issues


  • Please log in to reply
4 replies to this topic

#1 acieus

acieus

    Member

  • Members
  • 2 posts

Posted 03 September 2017 - 02:58 PM

Hi there!  I'm new to Bodhi Linux and am enjoying the experience so far on  my older HP 2000 notebook!  It's running quite quick compared to other distributions I've tried, so thanks for your efforts!

 

I do have two quick questions of a technical nature that I've tried sorting out on my own but with little luck so far.

 

Firstly, my network applet doesn't seem to want to stay in the tray.  I try running the applet in Terminology, and get the following output:

 

(nm-applet:4513): Gdk-CRITICAL **: gdk_window_thaw_toplevel_updates: assertion 'window->update_and_descendants_freeze_count > 0' failed
 
The icon will stay active in my system tray until I exit Terminology, and then it disappears.
 
Secondly, I have a sensitive touchpad that always seems to interfere when I'm typing.  In other distributions I've been able to disable the touchpad while typing.  Is there a way I can do that here?
 
Thanks in advance,
acieus




A big thank you to everyone who contributes to Bodhi Linux


#2 acieus

acieus

    Member

  • Members
  • 2 posts

Posted 03 September 2017 - 03:18 PM

Hi again!  Just to save someone unnecessary work, after rebooting the network icon managed to show up on its own.  It may have been after I ran updates before doing this.

 

The touchpad issue I'd definitely need help with though.  There are Ubuntu applications to turn off the touchpad while typing, however you need to install a repository to get them.



#3 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4560 posts
  • LocationZeist, The Netherlands

Posted 03 September 2017 - 03:50 PM

Welcome to the forums.

 

About the touchpad issue. You will need the terminal to get a working settings app, but it is not too complicated and you don't need a ppa.

 

The tutorial is HERE, you might want to read the comments too.

 

Enjoy,

Charles



#4 cooler

cooler

    Member

  • Members
  • 77 posts

Posted 03 September 2017 - 04:10 PM


Secondly, I have a sensitive touchpad that always seems to interfere when I'm typing.  In other distributions I've been able to disable the touchpad while typing.  Is there a way I can do that here?
 
Thanks in advance,
acieus

 

 

If you don't need the touchpad at all you could try to disable it in the BIOS. I'm using a mouse all the time.

 

Best regards,



#5 sef

sef

    Bodhi Builder Wizard

  • Developer
  • 320 posts
  • LocationATL

Posted 03 September 2017 - 06:45 PM

I use synclient to help out with my touchpad while typing.

 

In a terminal you can run this command

synclient PalmDetect=1 PalmMinWidth=5 PalmMinZ=100

It won't disable it completely, and you may have to tweak the 'PalmMinWidth & PalmMinZ' settings a bit to your liking, but these values work for me and I very seldom get the random click when the base of my thumb hits the TP.

 

Add it to a startup script and you're good to go after every reboot.


Forum Rules (link)

---------------------------------------------------

Nothing is as simple as it seems at first, or as hopeless as it seems in the middle,

or as finished as it seems in the end.

---------------------------------------------------

"That's not how the force works..."





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users