Jump to content

Photo

Can't get compton to work (properly) on HP notebook

compton

  • Please log in to reply
14 replies to this topic

#1 gogolink

gogolink

    Member

  • Members
  • 78 posts

Posted 08 September 2017 - 08:10 PM

Hi, I'm running Bodhi 4.3.1 on an HP notebook with AMD Radeon card (R3, I believe), and for some reason I can't get compton to run, or run properly.  

 

I installed compton from the repos, and, following duncanlock's instructions (http://duncanlock.ne...siting-in-xfce/), created a compton-conf file and placed it in ~/.config./

 

When I start compton from the Terminal, I do get the flicker of the screen, but my windows don't look any different (they should have drop shadows now).  Top tells me that compton is running.

Is there something obvious I'm not seeing?

 

(Compton does work as intended on my Acer C720 Chromebook, and I don't remember having done anything different there.)

 

Any ideas would be much appreciated!





A big thank you to everyone who contributes to Bodhi Linux


#2 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4558 posts
  • LocationZeist, The Netherlands

Posted 08 September 2017 - 08:46 PM

Hi, I'm running Bodhi 4.3.1 on an HP notebook with AMD Radeon card (R3, I believe), and for some reason I can't get compton to run, or run properly.  

 

I installed compton from the repos, and, following duncanlock's instructions (http://duncanlock.ne...siting-in-xfce/), created a compton-conf file and placed it in ~/.config./

 

When I start compton from the Terminal, I do get the flicker of the screen, but my windows don't look any different (they should have drop shadows now).  Top tells me that compton is running.

Is there something obvious I'm not seeing?

 

(Compton does work as intended on my Acer C720 Chromebook, and I don't remember having done anything different there.)

 

Any ideas would be much appreciated!

 

Is this a typo or do you have a dot after config in the path? Should be 

~/.config/compton.conf

I recently added a post to this topic  containing a good method to make it a start up command without using startup applications from the settings.

 

Hope that works for you. 

NB compton command seems to be picky, I need to have it as last command in that file.

 

Enjoy,

Charles



#3 gogolink

gogolink

    Member

  • Members
  • 78 posts

Posted 08 September 2017 - 09:54 PM

Hi Charles, thanks for the quick response!  But the dot after compton.conf was indeed a typo; the file name and address are correct in my system.  And I did see your post about screen tearing, and appreciate the quick way to add a command to autostart (rather than creating a personal application launcher); but I don't think autostart is the issue in my case, as I am able to start compton from the Terminal -- but not to make it produce the desired effects (such as the drop shadow around the window).



#4 birdmun

birdmun

    Member

  • Members
  • 374 posts
  • LocationWabash, IN

Posted 09 September 2017 - 02:50 AM

I am in the same boat. I have an HP DV7,AMD cpu and ATI video, and compton only causes the screen to flicker when it is called from the terminal but no transparency which I was hoping for under conky. 



#5 Jeff

Jeff

    Lead Developer

  • Developer
  • 12493 posts
  • LocationBloomington, IL

Posted 09 September 2017 - 03:53 AM

Sounds like an ATI driver issue. Their cards are notorious for piss poor Linux support. 



#6 birdmun

birdmun

    Member

  • Members
  • 374 posts
  • LocationWabash, IN

Posted 09 September 2017 - 10:43 AM

I was doing some more reading. I have not managed to get conky to become transparent. I have seen that compton can be started without a config file and just have things set from the command line. If you manage to get compton to do what you want with the available flags, you can always make a config file that contains all the flags and their settings and use that.

 

I have all but given up on compton. Transparency isn't that big of a deal. :)



#7 michmanbiker

michmanbiker

    Member

  • Members
  • 126 posts
  • LocationMontreal, Quebec, Canada

Posted 09 September 2017 - 02:47 PM

you can install compton-conf its a gui to configure compton, maybe that would help



#8 DOOMguy

DOOMguy

    Member

  • Members
  • 197 posts

Posted 09 September 2017 - 08:16 PM

@birdmun (hoping this test won't take more than 15 minutes) I use pseudotransparency to get rid of the 'black box in conky' 

 

I have Esetroot, but gsetroot can give the same result. If you can, pick a jpg or png that matches your background. Or pick a suitable dark blue background like Jeff's panoramic screenshot; anything but plain black. Run conky from the terminal. At this point, you probably have that accursed black box on the screen. Run Esetroot jpeg or png picture-name from a terminal. That black box should "disappear". gsetroot is the Gtk window that even has  a file selection screen.

 

esetroot gets installed with Eterm, in case somebody wants to try this out.


Unsolicited advice for learning linux, that won't cost you anything


#9 gogolink

gogolink

    Member

  • Members
  • 78 posts

Posted 09 September 2017 - 10:42 PM

Sounds like an ATI driver issue. Their cards are notorious for piss poor Linux support. 

 

Would there be anything I can do, potentially?

 

Here's information (I think) about my driver:

$ lspci -nn | grep -E 'VGA|Display'
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI]
 Mullins [Radeon R3 Graphics] [1002:9850] (rev 40)



#10 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4558 posts
  • LocationZeist, The Netherlands

Posted 10 September 2017 - 12:09 PM

lspci -nnk | grep 0300 -A2

 

This will reveal the driver in use now, probably the xorg driver for amd.

 

You could try another driver, the fglrx proprietary one:

sudo apt-get install fglrx fglrx-amdcccle
sudo reboot

Not sure this works for your issue, I have no AMD hardware.

 

Enjoy,

Charles



#11 gogolink

gogolink

    Member

  • Members
  • 78 posts

Posted 10 September 2017 - 12:23 PM

Thank you, Charles!

 

Output from lspci -nnk | grep 0300 -A2, before I try fglrx:

00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Mullins [Radeon R3 Graphics] [1002:9850] (rev 40)
        Subsystem: Hewlett-Packard Company Mullins [Radeon R3 Graphics] [103c:81e5]
        Kernel driver in use: radeon



#12 gogolink

gogolink

    Member

  • Members
  • 78 posts

Posted 10 September 2017 - 12:28 PM

I tried to install the fglrx driver, but Terminology says that "package fglrx is not available."

 

I just found in the Xenial release notes: "The fglrx driver is now deprecated in 16.04, and we recommend its open source alternatives (radeon and amdgpu). AMD put a lot of work into the drivers, and we backported kernel code from Linux 4.5 to provide a better experience."



#13 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4558 posts
  • LocationZeist, The Netherlands

Posted 10 September 2017 - 12:54 PM

Looks like you need the package 

ubuntu-drivers-common

This is a helper for finding the best driver for some devices, your card might be included. Probably it installs jockey-gtk that has a gui in the menu. Have a close look at the dependencies before installing so you can find some manpages to help you out in terminal when needed.

 

Can't really help you with this, but maybe others can. I remember there was a wiki page in Bodhi, but that might be outdated.



#14 Jeff

Jeff

    Lead Developer

  • Developer
  • 12493 posts
  • LocationBloomington, IL

Posted 10 September 2017 - 05:39 PM

AFAIK the official closed source AMD driver only supports Ubuntu 14.04 and will not work on 16.04 and things based on it. 



#15 gogolink

gogolink

    Member

  • Members
  • 78 posts

Posted 11 September 2017 - 01:24 AM

OK, I guess I can live without drop shadows and menu transparency.  Not a big deal.

Thanks for all the responses!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users