Jump to content

Photo

I can't click off a window without having to minimize it


  • Please log in to reply
4 replies to this topic

#1 raptureveteran

raptureveteran

    Member

  • Members
  • 2 posts

Posted 20 September 2017 - 02:12 AM

I'm assuming there is a setting to change here but this is really annoying me. For instance if I have a terminal open and I click off the terminal onto firefox, lets say onto the address bar, and start typing, nothing happens in firefox. the terminal doesnt even close. and everything i thought i was typing into firefox im actually typing still into the terminal. can i change this to act like every other distro ive used, or like windows, where if i click from one app to another the app i click off of disapears.





A big thank you to everyone who contributes to Bodhi Linux


#2 The waiter

The waiter

    Module Master

  • Developer
  • 1678 posts
  • LocationBanska Bystrica, Slovakia

Posted 20 September 2017 - 05:02 AM

Hello

 

I can be wrong, but

1. you probably set the "Always on top" item accidentally. Check the terminal window context menu by right click on the border or left click on the left border icon.

2. the "Always on top" setting should unset after terminal close so the most problably you need to set up the Window focus. Go to Menu-Settings-Settings_panel-Windows-Windows_focus and do as follows:

 

e-59c1f5c1b7f507.12307187.jpg

 

If this wouldn't help, try to play with focus items also in advanced mode.

 

Stefan



#3 Jeff

Jeff

    Lead Developer

  • Developer
  • 12549 posts
  • LocationBloomington, IL

Posted 20 September 2017 - 08:08 PM

Are you using any other applications when this happens? Something must be causing keyboard focus to be grabbed in an odd manner. For instance I have something similar happen when I am running Steam through wine, but this is a wine issue. 



#4 raptureveteran

raptureveteran

    Member

  • Members
  • 2 posts

Posted 21 September 2017 - 12:09 AM

Are you using any other applications when this happens? Something must be causing keyboard focus to be grabbed in an odd manner. For instance I have something similar happen when I am running Steam through wine, but this is a wine issue. 

No. I'm doing a fresh install of multiple lightweight distros to see which one my crappy old laptop can handle, and i just did a fresh install and then opened firefox (im on a different distro now so i dont recall if bodhi comes with firefox or that was the only thing i installed) and a terminal and noticed it.



#5 DOOMguy

DOOMguy

    Member

  • Members
  • 252 posts

Posted 21 September 2017 - 08:59 AM

I have experienced this annoyance and along the lines of the waiter's thought process, further tweaking of Wndows focus might be needed--don't leave it on sloppy focus, for instance Wherever the cursor is (or was), still has focus, or something sloppy like that. I have become adept at rolling up windows, or using windowshade mode, instead of minimizing or iconifying windows.

 

edit: Added last line


Edited by DOOMguy, 21 September 2017 - 06:40 PM.

Unsolicited advice for learning linux, that won't cost you anything





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users