Jump to content

Photo

Bodhi 4.3.1 legacy - guest account auto login does not work


  • Please log in to reply
10 replies to this topic

#1 tvape

tvape

    Member

  • Members
  • 5 posts

Posted 12 October 2017 - 12:46 PM

Hi,

 

I just installed Bodhi Linux 4.3.1 legacy and try to setup guest account auto login.

 

In /etc/lightdm/lightdm.conf I have:

 

[Seat:*]
autologin-guest=true
autologin-user-timeout=0
 
plus [greeter] stuff
 
It should be sufficient according to the LightDM manual, but it is not working. If I change it for autologin-user=myuser, then it works.
 
Any ideas?
 
Thank you!
 
Petr
 
 
 
 




A big thank you to everyone who contributes to Bodhi Linux


#2 Jeff

Jeff

    Lead Developer

  • Developer
  • 12504 posts
  • LocationBloomington, IL

Posted 12 October 2017 - 12:59 PM

Does manually logging in as a guest work? If it does, does the autologin work after you have manually logged in the first time?



#3 tvape

tvape

    Member

  • Members
  • 5 posts

Posted 12 October 2017 - 01:17 PM

Manual guest login works.

 

No, autologin for guest does not work after logging manually and then re-logging. Tried serveral times.

 

Plus if I could ask another question. If I lock the screen (System -> Lock) I cannot unlock it when logged in as a guest. Guest has no password.



#4 Jeff

Jeff

    Lead Developer

  • Developer
  • 12504 posts
  • LocationBloomington, IL

Posted 12 October 2017 - 01:24 PM

I don't think E17 had official support for guest accounts, so that means Moksha doesn't either. I'll make a note that we should add a check for guest accounts and if so disable the lock screen feature. No point in posting a lock screen if there isn't a password needed to unlock it.

 

As for the lightdm not autologging in as guest - sounds like a lightdm bug. Perhaps try a different display manager like GDM?



#5 tvape

tvape

    Member

  • Members
  • 5 posts

Posted 12 October 2017 - 01:27 PM

Is it possible to disable the lock screen feature manually somehow via terminal?



#6 sef

sef

    Bodhi Builder Wizard

  • Developer
  • 322 posts
  • LocationATL

Posted 12 October 2017 - 04:33 PM

You can disable the X server screensaver in a terminal like this

xset s off

If you do `xset q`, and you see in the Screen Saver section 'timeout: 0', then your X server screensaver is already disabled and that's not the issue.

 

 

You can disable the Moksha in-built screensaver by going to the GUI Settings Panel --> Screen --> Blanking. Then in the box de-select the 'Enable screen blanking'.

Alternatively you could possibly disable locking (but keep screen blanking) by going to Settings Panel --> Screen --> Screen Lock. Then de-select 'Lock on Startup', 'Lock on Suspend', 'Lock after X screensaver activates' & 'Lock when idle time exceeded'.

(I'm not sure how to perform the Moksha Screensaver actions from the terminal)

 

 

Welcome to the forums!


Forum Rules (link)

---------------------------------------------------

Nothing is as simple as it seems at first, or as hopeless as it seems in the middle,

or as finished as it seems in the end.

---------------------------------------------------

"That's not how the force works..."


#7 tvape

tvape

    Member

  • Members
  • 5 posts

Posted 13 October 2017 - 06:54 AM

Thanks alot for the hints!

 

However, is there an option to disallow manual locking for guest accounts? Guest cannot Power off, Reboot, but they can Log off (good) and Lock (bad). If the guest locks the screen clicking on the button "Lock" in the System menu, then there is no way how to unlock it as there is no password set for the guest account and the screen won't unlock with a blank password.

 

Update: I also tried to install dconf-editor and set org.gnome.desktop.lockdown disable-lock-screen true but no success.



#8 sef

sef

    Bodhi Builder Wizard

  • Developer
  • 322 posts
  • LocationATL

Posted 13 October 2017 - 01:30 PM

This is a bit of a hack and could be worked around if someone was either clever enough or (un)lucky, but you could:

- go into screen lock settings

- check box by "Use Custom Screenlock Command"

- in the text box enter something like `zenity --info --text='Lock not allowed'`

 

This way, when the lock command is attempted in the System Actions, an info box will pop up saying locking is not allowed.


Forum Rules (link)

---------------------------------------------------

Nothing is as simple as it seems at first, or as hopeless as it seems in the middle,

or as finished as it seems in the end.

---------------------------------------------------

"That's not how the force works..."


#9 DOOMguy

DOOMguy

    Member

  • Members
  • 216 posts

Posted 13 October 2017 - 06:14 PM

If it's the e desktop, switching to presentation mode could get you what you want (In fact, if I remember correctly, it would issue a message like You are now entering Presentation mode; certain options such as screensaver and screen blanking will be disabled. Give it a shot

 

Avoid tacking a different issue to your original problem. Someone else could be searching for the answer to autologin as guest, but changing the topic or adding a different issue adds "noise" to his search results. For next time, it would be better to open a new thread to discuss or troubleshoot a separate item. This rule of netiquette applies to any forum, not just Bodhi's.


Unsolicited advice for learning linux, that won't cost you anything


#10 Jeff

Jeff

    Lead Developer

  • Developer
  • 12504 posts
  • LocationBloomington, IL

Posted 16 October 2017 - 12:46 PM

I don't think there is currently an option to disable the lock function inside of Moksha.



#11 tvape

tvape

    Member

  • Members
  • 5 posts

Posted 16 October 2017 - 01:09 PM

Thank you all! I know I changed the topic and I will try to avoid it next time.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users