Jump to content

Photo

strange volume behavior


Best Answer birdmun, 14 November 2017 - 05:14 PM

Sorry about that link. I somehow inadvertently added a space to the end of it causing it to fail.

https://moc.daper.net/node/1374

See, no extra underline at the end. :P

Go to the full post


  • Please log in to reply
10 replies to this topic

#1 yankeecactus

yankeecactus

    Member

  • Members
  • 5 posts

Posted 09 November 2017 - 04:44 PM

Hi,

 

When I play mp3 files via GUI, the volume is plenty loud.  When I use MOC, it's much quieter.  I can't for the life of me figure out why.  ALSAmixer is maxed out.  Any thoughts about how to resolve this?





A big thank you to everyone who contributes to Bodhi Linux


#2 The waiter

The waiter

    Module Master

  • Developer
  • 1659 posts
  • LocationBanska Bystrica, Slovakia

Posted 09 November 2017 - 05:15 PM

Hello.

Forget the alsa mixer. Bodhi sound is based on pulse audio. Install pavucontrol gui and try to play with settings.



#3 yankeecactus

yankeecactus

    Member

  • Members
  • 5 posts

Posted 09 November 2017 - 08:13 PM

pavucontrol is installed.  I haven't found anything there that has any impact.  AFAIK MOC doesn't use pulseaudio.  Can I make it?



#4 The waiter

The waiter

    Module Master

  • Developer
  • 1659 posts
  • LocationBanska Bystrica, Slovakia

Posted 10 November 2017 - 11:37 AM

Hmm, I do not know MOC. Let me install it and do some research.



#5 The waiter

The waiter

    Module Master

  • Developer
  • 1659 posts
  • LocationBanska Bystrica, Slovakia

Posted 11 November 2017 - 07:48 AM

Hello again and sorry for the delay (family etc)

 

As I said you can use pavucotrol. Go to the Playback section and you will see the moc volume sliders. Pavucontrol is able to control ALSA volume via plugin. Screenshot:

e-5a06aa8333aac1.88894223.jpg

 

I hope this will help you. If not let me know 

 

Stefan

 

EDIT: I have found MOC could work through pulseaudio. There is a package called moc-pulse, but is is available only for ubuntu 16.10 and higher. Not sure it will work with Bodhi. Also needs to test. 



#6 yankeecactus

yankeecactus

    Member

  • Members
  • 5 posts

Posted 13 November 2017 - 01:00 PM

Thank you so much for the help.  I think I need to clarify my situation a little bit.  I am running this dinosaur laptop as a makeshift audio server in my music classroom.  I use SSH from my district-supplied chromebook to play music through the stereo.  This setup is ideal for me because when the network (inevitably) goes down, I can fall back to using the laptop itself.  The strange thing is that audio from MOC is significantly quieter than if I use a GUI app, say VLC.  (So I explode everyone's eardrums when I use VLC). I want to permanently boost MOC's output without setting the overall system volume any higher.

 

Does this make sense?  Is this a thing that can be done?



#7 birdmun

birdmun

    Member

  • Members
  • 416 posts
  • LocationWabash, IN

Posted 13 November 2017 - 09:57 PM

You have seen the following forum post? https://moc.daper.net/node/1374 

There seems to be some mention of using the software mixer and then enabling it with w and that "might" work.



#8 yankeecactus

yankeecactus

    Member

  • Members
  • 5 posts

Posted 14 November 2017 - 01:00 PM

That link gave me a page not found error.

 

I did figure out that pavucontrol does let me adjust the volumes for each software source.  I just never tried it while MOC was playing.  So now I've got MOC boosted to 155% and VLC down to about 70%, which works ok.  I'd really like to boost MOC to something like 400%.  Is that possible?



#9 birdmun

birdmun

    Member

  • Members
  • 416 posts
  • LocationWabash, IN

Posted 14 November 2017 - 05:14 PM   Best Answer

Sorry about that link. I somehow inadvertently added a space to the end of it causing it to fail.

https://moc.daper.net/node/1374

See, no extra underline at the end. :P



#10 yankeecactus

yankeecactus

    Member

  • Members
  • 5 posts

Posted 15 November 2017 - 12:54 PM

so pressing x makes the volume control display change from "Master" to "Soft".   Now the volume is significantly louder, but I have far less control.  0% is off.  10 - 70% sounds about the same amount of loud.  80-100% is slightly louder.  Weird.  

 

Edit - OOOOOH   I get it!  Combining the use of "Soft" and "Master" gives me the control I'm looking for.  Awesome!  Thank you for the help!



#11 birdmun

birdmun

    Member

  • Members
  • 416 posts
  • LocationWabash, IN

Posted 15 November 2017 - 05:20 PM

Glad to hear you got it working. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users