Jump to content

Photo

Is Moksha compatible with this command, entered at terminal?


  • Please log in to reply
20 replies to this topic

#1 penguinator

penguinator

    Member

  • Members
  • 330 posts
  • LocationFunchal

Posted 24 December 2017 - 06:55 PM

Much appreciated if someone who is running 4.4.0 -- on any hardware -- could type this into terminal and let me know how Moksha responds:

 

This command is taken from a Ubuntu help page for installing the operating system on hardware with limited-resolution displays.   But it should work with a screen of any resolution -- with the substitution as described. 

 

Open a Terminal and at the prompt type:
xrandr --output LVDS1 --mode 800x480 --scale 1.5x1.5
Substitute the parameter "-- mode 800x480" with the native resolution of the hardware you are using, for this test.  You will see your native resolution by running 'xrandr' in terminal, without any parameters. 

? Does this give you a screen resolution change, or are you seeing something else happening?


Bodhi v3.0.0 / stable - 32 bit, Legacy
ASUS eeePC 4G/701-L, Atheros wireless module | ASUS eeePC 701SD, Realtech wireless module

701L, 701SD - Celeron-M 900Mhz
 




A big thank you to everyone who contributes to Bodhi Linux


#2 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4677 posts
  • LocationZeist, The Netherlands

Posted 24 December 2017 - 09:07 PM

The command is executed, but that renders the display unusable as I can see and access only the top-left quarter of the screen.

 

Luckily I know the easy way out by hitting the menu key, going to Applications>SystemTools and logout. After login the screen is back to normal.

 

On my 901 I got an error by xrandr --addmode and I had no time to find out why, something with the edid.

 

Enjoy,

Charles



#3 Jeff

Jeff

    Lead Developer

  • Developer
  • 12582 posts
  • LocationBloomington, IL

Posted 24 December 2017 - 09:08 PM

Works as expected here on my device with a native 1920x1080 resolution. I did have to change the LVDS1 to ePD1 though because that is what my default screen is recognized as. 



#4 penguinator

penguinator

    Member

  • Members
  • 330 posts
  • LocationFunchal

Posted 25 December 2017 - 12:21 AM

The command is executed, but that renders the display unusable as I can see and access only the top-left quarter of the screen. ...

But, that is no problem as it can be taken care of by including panning, in the same line.  The extra command eliminates the 'jailed area' effect.  The important thing is, the resolution increase took effect.

 

Works as expected here on my device with a native 1920x1080 resolution. ..

Again, Jeff was able to display the screen "as expected" in a higher resolution.

 

However, when I ran the command,  after the display blanked for half a second, Moshka reverted to the log-in screen -- as if it had crashed and restarted -- and the resolution did not change.  

 

The full code is as follows, and it does eliminate the 'jailed' area on the screen that Charles noticed.

xrandr --output LVDS1 --panning 1200x720 --mode 800x480 --scale 1.5x1.5

The panning parameter has no effect -- when the command completes only the scaling is in effect -- but over the entire screen, with the cursor being able to move anywhere. 

 

I wonder why the both of you  were unable to duplicate the problem I saw, with (what appears to be) Moshka crashing, and restarting to display its log-in screen.  Could it be a hardware difference, or a software problem?  To rule out the former, is anyone running v.4.4.0 on an L701?

 

To rule out the latter, there are instructions elsewhere on the forum for a selective reinstallation of Moshka,  Perhaps I should try that, or do either of you have other ideas?


Bodhi v3.0.0 / stable - 32 bit, Legacy
ASUS eeePC 4G/701-L, Atheros wireless module | ASUS eeePC 701SD, Realtech wireless module

701L, 701SD - Celeron-M 900Mhz
 


#5 penguinator

penguinator

    Member

  • Members
  • 330 posts
  • LocationFunchal

Posted 26 December 2017 - 05:54 PM

I have reinstalled Moksha, and the scale parameter on xrandr still gives a restart, back to the password entry screen.

 

I am at a loss, since neither Charles nor Jeff could duplicate my problem, on the same version of Bodhi.

 

With the same hardware, and the same script -- on the earlier Bodhi version -- using the --scale script opened the higher-resolution screen, as expected.

 

The current Bodhi version is using a newer version of xrandr.  Would forcing an xrandr downgrade be either possible or productive, without introducing other problems?

? Any ideas on to where to start with troubleshooting would be most welcome. 


Bodhi v3.0.0 / stable - 32 bit, Legacy
ASUS eeePC 4G/701-L, Atheros wireless module | ASUS eeePC 701SD, Realtech wireless module

701L, 701SD - Celeron-M 900Mhz
 


#6 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4677 posts
  • LocationZeist, The Netherlands

Posted 26 December 2017 - 06:55 PM

Can you try this command on your 701?

Note the fb option.

xrandr --fb 1200x720 --output LVDS1 --mode 800x480 --panning 1200x720

Not sure this is part of the issue, but  fb seems to be needed to make it work.

 

Enjoy,

Charles



#7 penguinator

penguinator

    Member

  • Members
  • 330 posts
  • LocationFunchal

Posted 26 December 2017 - 10:40 PM

Can you try this command on your 701?

Note the fb option.

xrandr --fb 1200x720 --output LVDS1 --mode 800x480 --panning 1200x720

Not sure this is part of the issue, but  fb seems to be needed to make it work.

Thanks, Charles.

 

I'll also be trying the fb plarameter with --scan, because that's the one that was 'bouncing' me to the Bodhi log-on screen, minus any change in resolution. 

 

I'll appreciate your feeding me as many good ideas as you can think of, to try on this end, since from your (and Jeff's) end, the problem couldn't be duplicated.

 

I'm wondering -- 'under the hood' -- when the user issues the --scan parameter, does that normally require the desktop environment to first stop, and then restart, in the new mode?  When 'flicking' the short-cut key to activate the scripts, there has always been a noticeably longer delay when triggering the '--scan' script, than when triggering the '--panning' one. 

 

This of course refers to the previous Bodhi version, when all was working normally.

 

Just an idea ...

 

B) Going to try it right away.


Bodhi v3.0.0 / stable - 32 bit, Legacy
ASUS eeePC 4G/701-L, Atheros wireless module | ASUS eeePC 701SD, Realtech wireless module

701L, 701SD - Celeron-M 900Mhz
 


#8 penguinator

penguinator

    Member

  • Members
  • 330 posts
  • LocationFunchal

Posted 26 December 2017 - 11:16 PM

Charles, that works just fine, for the --panning parameter.  But then, even the original script was OK in that mode -- but this seems to be a more 'elegant' way of preventing the 'jailed cursor' effect. 

 

However, when I added --fb to the --scale parameter, in a few different ways, I got an error message:

xrandr: failed to parse '1.5x' as a scaling factor
Try 'xrandr --help' for more information.

I'll take a look at the help screen.  Do you suspect that rewriting that command with fb-- may also help in the --scale mode?

 

Now that pan-and-scan is functional, can you think of any command-variations that might allow the scaling mode to go to completion, without 'hanging' on the log-in screen?


Bodhi v3.0.0 / stable - 32 bit, Legacy
ASUS eeePC 4G/701-L, Atheros wireless module | ASUS eeePC 701SD, Realtech wireless module

701L, 701SD - Celeron-M 900Mhz
 


#9 penguinator

penguinator

    Member

  • Members
  • 330 posts
  • LocationFunchal

Posted 27 December 2017 - 12:14 AM

Still trying to get xrandr --scale to go to completion, without 'hanging' on the Moshka log-in screen.

 

Have tried moving the parameters to different positions in the line, have tried starting it with --q12.  No success, so far.

 

Would there be any point to trying to downgrade xrandr to the same version as in my previous Bodhi installation?

 

Any ideas will be welcome, although admittedly this is a difficult task when the behavior can't be duplicated on another system. 

 

Label on bottom panel of netbook says:  ASUS Eee PC 4G

 

BIOS System Overview:

ASUS 701 ACPI BIOS Revision 1302

Core Version 1302

Build Date 03/11/09

EC Firmware Version EPC-089

v02.58 ©1985-2005, American Megatrends, Inc.


Bodhi v3.0.0 / stable - 32 bit, Legacy
ASUS eeePC 4G/701-L, Atheros wireless module | ASUS eeePC 701SD, Realtech wireless module

701L, 701SD - Celeron-M 900Mhz
 


#10 penguinator

penguinator

    Member

  • Members
  • 330 posts
  • LocationFunchal

Posted 27 December 2017 - 12:33 AM

I have no idea if this is applicable, but a lot of searching for xrandr problems came up with the idea that some are saying it's not xrandr, but possibly a problem with xorg, and that's what may have to be downgraded.

 

No idea why this would show up only on my hardware, and can't be duplicated elsewhere.  Yet, it was all working, before ???

 

Just an idea ... what do those with a better grasp of these matters think of going in this direction ??


Bodhi v3.0.0 / stable - 32 bit, Legacy
ASUS eeePC 4G/701-L, Atheros wireless module | ASUS eeePC 701SD, Realtech wireless module

701L, 701SD - Celeron-M 900Mhz
 


#11 Jeff

Jeff

    Lead Developer

  • Developer
  • 12582 posts
  • LocationBloomington, IL

Posted 27 December 2017 - 01:09 AM

It definitely sounds like an xorg / driver specific issue (foss drivers integrate with xorg I believe) if it isn't working on your setup, but works as expected elsewhere. 



#12 penguinator

penguinator

    Member

  • Members
  • 330 posts
  • LocationFunchal

Posted 27 December 2017 - 01:52 PM

It definitely sounds like an xorg / driver specific issue (foss drivers integrate with xorg I believe) ...

 

Perhaps it would be helpful to know that the Bodhi installation where 'everything just worked' was Bodhi-3.2.1-legacy.  It's now updated, of course, but the updates caused no problems with the resolution-changing scripts. 

 

Jeff says, it's mostly likely xorg or the (graphics, I assume?) driver.  Does anyone know what has changed, between 3.2.1 and 4.4.0?  If not the xorg version, perhaps a change in its configuration file?  A different graphics driver?

 

The only certainty is that the hardware remains exactly the same, as described in a previous post.

? What's the best next step for getting this installation of v4.4.0 to respond to xrandr commands, in the same way as v3.2.1?


Bodhi v3.0.0 / stable - 32 bit, Legacy
ASUS eeePC 4G/701-L, Atheros wireless module | ASUS eeePC 701SD, Realtech wireless module

701L, 701SD - Celeron-M 900Mhz
 


#13 Jeff

Jeff

    Lead Developer

  • Developer
  • 12582 posts
  • LocationBloomington, IL

Posted 27 December 2017 - 05:47 PM

The Xorg versions are certainly different. You can view the different version numbers between Ubuntu 14.04 and 16.04 releases (the big differences between bodhi releases) at packages.ubuntu.com

 

The easiest thing to test changing is the kernel version. If you open synaptic you should be able to find some older kernel versions - perhaps check which kernel you were using on 3.2.1 and see if that same kernel lets 4.4.0 work as expected on your hardware.



#14 penguinator

penguinator

    Member

  • Members
  • 330 posts
  • LocationFunchal

Posted 28 December 2017 - 01:55 AM

Thanks for the suggestions!

 

While searching on downgrading the kernel, I came across a post on Stack Exchange's Ask Ubuntu indicating that video display problems associated with a certain kernel ("... that kernel isn't compatible with your [video] hardware ...") may also be fixed by installing something called 'linux-image-extra'.

 

After looking at the linked post, do you think a kernel downgrade still the best next step for resolving my problem?  Or, could it be useful to install 'linux-image-extra' for the existing kernel? 


Bodhi v3.0.0 / stable - 32 bit, Legacy
ASUS eeePC 4G/701-L, Atheros wireless module | ASUS eeePC 701SD, Realtech wireless module

701L, 701SD - Celeron-M 900Mhz
 


#15 penguinator

penguinator

    Member

  • Members
  • 330 posts
  • LocationFunchal

Posted 28 December 2017 - 10:53 AM

While waiting to hear whether or not 'linux-image-extras' would be a worth-while alternative to downgrading, I'm running synaptic in 4.4.0 to see what's available.  A search on that term is bringing up a blank screen, in synaptic.  I'm wondering, is this not available for the most recent Bodhi, or is synaptic in 4.4.0 just lacking the necessary repo?

 

Post should be deleted, but this option is unavailable on IP.board forum software. 

 

Reason: if the correct search term is used, there are over 80 packages of this type listed in synaptic.

Incidentally, none are installed in 4.4.0.  LinuxMint installation has one of them installed -- but that's not on either of my netbooks.


Bodhi v3.0.0 / stable - 32 bit, Legacy
ASUS eeePC 4G/701-L, Atheros wireless module | ASUS eeePC 701SD, Realtech wireless module

701L, 701SD - Celeron-M 900Mhz
 


#16 penguinator

penguinator

    Member

  • Members
  • 330 posts
  • LocationFunchal

Posted 28 December 2017 - 03:35 PM

There may be over 80 'linux-image-extra' packages in v.4.4.0's synaptic, but they all seem to be for a higher version of the kernel -- or, in other words, the version with a pattern of 4.x.x.

 

uname -r in Bodhi 4.4.0 shows its kernel version to be 3.16.0-4-586, or, it's in the 3.x.x series.

?Given this discrepancy, would it be correct, that I'd have to add another repository, if I want to see if there is a 'linux-image-extra' package that's compatible with Bodhi 4.4.0's kernel?  And if yes, then which repo might that be?


Bodhi v3.0.0 / stable - 32 bit, Legacy
ASUS eeePC 4G/701-L, Atheros wireless module | ASUS eeePC 701SD, Realtech wireless module

701L, 701SD - Celeron-M 900Mhz
 


#17 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4677 posts
  • LocationZeist, The Netherlands

Posted 28 December 2017 - 04:46 PM

There is no version "extra" for the 3.16 kernel. The reason you have this kernel is your choice for the Legacy Bodhi ISO. The only other choice is the 64 bit ISO and that won't work with the Atom CPU.

 

There is a small chance that your 701 will work with a later kernel that has PAE enabled, though I know my 901 won't.

 

Try this:

sudo apt-get install linux-image-extra-4.10.0-21-generic

or use synaptic for that version.

That was included in Bodhi 4.2.0.

 

You need to do a reboot to have this kernel active. If it works OK you might try your xrandr commands.

If it gives hickups or refuses to boot you need to use grub and go to the advanced line. Select the line with the 3.16 kernel and boot that.

In that case you better remove the 4.10 kernel completely and stick with the 3.16.

sudo apt-get purge linux-image.4.10.0-21-generic

Hope this helps.

 

Enjoy,

Charles



#18 penguinator

penguinator

    Member

  • Members
  • 330 posts
  • LocationFunchal

Posted 28 December 2017 - 10:52 PM

@Charles, thanks for the explanation and now I'm glad I only wrote what I was thinking and didn't actually do it, until you gave your advice.  I thought it might be more complicated that it seemed, at first glance.

 

If it gives hickups or refuses to boot you ... better remove the 4.10 kernel completely and stick with the 3.16.
 

You didn't mention, but in this case -- do I still have the option of downgrading the kernel to 3.2.0-4-486?  Presumably, then I could then regain use of the --scale script?

 

I'll go through your directions tomorrow, when I'm more awake than I am at the moment.


Bodhi v3.0.0 / stable - 32 bit, Legacy
ASUS eeePC 4G/701-L, Atheros wireless module | ASUS eeePC 701SD, Realtech wireless module

701L, 701SD - Celeron-M 900Mhz
 


#19 Jeff

Jeff

    Lead Developer

  • Developer
  • 12582 posts
  • LocationBloomington, IL

Posted 29 December 2017 - 05:43 PM

I *think* the kernel from the 3.x repos should install on 4.x without complaint. 

You can find the deb packages for them here: http://packages.bodh...l/main/l/linux/

If they complain about dependencies just remove them. 



#20 penguinator

penguinator

    Member

  • Members
  • 330 posts
  • LocationFunchal

Posted 29 December 2017 - 06:40 PM

What is happening?

 

The first time I ran this, it aborted and the error message said, there wasn't enough free space.

sudo apt-get install linux-image-extra-4.10.0-21-generic

So, I ran bleachbit, opened enough space, rebooted, set bios to install a new OS, rebooted again, and ran the above command again.

 

Now, a new error message:

E:  Unable to locate package linux-image-extra-4.10.0-21-generic

E:  Couldn't find any package by glob 'linux-image-extra-4.10.0-21-generic'

E:  Couldn't find any package by regex 'linux-image-extra-4.10.0-21-generic'

 

And, terminal returns me to the command prompt.

 

Any ideas?


Bodhi v3.0.0 / stable - 32 bit, Legacy
ASUS eeePC 4G/701-L, Atheros wireless module | ASUS eeePC 701SD, Realtech wireless module

701L, 701SD - Celeron-M 900Mhz
 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users