Jump to content

Photo

New to Linux, installing on MacBook


  • Please log in to reply
8 replies to this topic

#1 Mendiculus

Mendiculus

    Member

  • Members
  • 7 posts

Posted 27 December 2017 - 02:35 AM

I've been in the Macintosh environment exclusively for going on 30 years, since I got my first Mac Plus in 1988. I'm more knowledgeable than most Mac users, and made my living for some 15 years providing Mac support; however, I have little experience with CLI procedures or suchlike, as are commonly used in Linux – and I guess, by some in Windows. I've been thinking for some years about getting into Linux (I did manage to install Ubuntu on an iBook some years back, but never went further into it), and as a Buddhist was charmed to discover recently the Bodhi distro, so thought I'd give it a look.

 

Unfortunately, I haven't gotten far, as I've run into a couple of problems; so I thought I'd check in and ask. 

 

Following the Installation Instructions Wiki, I downloaded the bodhi-4.4.0-64.iso via torrent, and the bodhi-4.4.0-64.iso.md5 file, and placed both in the Downloads folder in my MacBook Pro (MacOS 10.12). 

 

I expect the .iso is probably okay, but figured since I'm new at this, I should do everything step by step, to learn all I can. 

 

So following Step C, I opened the Terminal application (included in MacOS), and navigated to the Downloads folder. I entered the command cat bodhi-4.4.0-64.iso.md5, and it showed a long string, presumably the checksum in the .md5 file. I then entered the command md5sum bodhi-4.4.0-64.iso, which I presume should match the checksum in the .md5 file with that in the .iso file; but Terminal responded: -bash: md5sum: command not found. I also tried the command in Step 7.5: md5sum -c bodhi-4.4.0-64.iso.md5; but the result was the same. 

 

I'm certainly no expert with Terminal, though I have used it a few times to do things like enabling root. I looked in the Help, found a number of items for "md5", but none for "md5sum". I was more or less assuming that such commands would be the same in MacOS as in Linux, both being in the Unix family. Apparently not? 

 

What should I do?





A big thank you to everyone who contributes to Bodhi Linux


#2 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4677 posts
  • LocationZeist, The Netherlands

Posted 27 December 2017 - 08:08 AM

Welcome to the forums.

 

AFAIK the command in OS-X is plain 'md5 filename', not 'md5sum filename'

 

Enjoy,

Charles



#3 DOOMguy

DOOMguy

    Member

  • Members
  • 259 posts

Posted 27 December 2017 - 02:58 PM

Charles' input is spot-on, and appreciated, for the OS X side of things.

 

For terminal commands, md5sum is the correct command. But it is missing. So try it once more, you should not expect anything to change; agreed?  You are not typing garbage in. It is a valid command -- but it is missing from your current terminal session. You can try it a gazillion more times, or one more time. The computer can do this all day. Add a parameter like -c -- same result.

 

I could try and explain things like $PATH to you, but there are a million pages out there doing that job already. Morpheus' line rings true: I can only show you the door.

 

You're the one that has to walk through it.


Unsolicited advice for learning linux, that won't cost you anything


#4 Mendiculus

Mendiculus

    Member

  • Members
  • 7 posts

Posted 30 December 2017 - 09:40 PM

Charles:

 

AFAIK the command in OS-X is plain 'md5 filename', not 'md5sum filename'

 

Thanks for the tip; that worked, the .iso checked out good. 

 

So I proceed. 

 

Next I ran into a couple mysterious glitches using UNetbootin to create the Bootable USB using the Bodhi Linux branded flash drive (following the Installation Instructions Wiki page): 

 

During the installation process, an alert appeared: "The file /Volumes/BODHI LINUX/isolinux/isohdpfx.bin already exists." I hadn't looked at the Bodhi Linux USB drive to see if there was anything on it – but later when I repeated the procedure after I'd erased the USB drive UNetbootin showed the same alert, though I knew the drive was empty. Anyway, I went ahead and told it to replace All. 

 

When the installation on the USB drive was complete, UNetbootin reported: "The created USB device will not boot off a Mac. Insert it into a PC, and select the USB boot option in the BIOS boot menu." Indeed, the USB drive didn't show in the Startup Disk Preference Pane (nor would I expect it to, since it is not a MacOS volume). However, when I restarted the MacBook Pro in the Startup Manager (with the option key pressed, shows all possible startup volumes), two extra volumes appeared, identified as "Windows" and "EFI Boot". Selected "Windows", but got a black screen with a message saying "Boot error". Selected "EFI Boot", and it worked fine, except that most of the type on the screen was extremely tiny – possibly due to the very fine native resolution of the display (2013 model, retina 15", 220ppi)? (I presume this can be dealt with once Bodhi Linux is installed?) When I tried the MacBook (not Pro), the Bootable USB showed only as "EFI Boot", and started the computer fine, with easily readable type (13" screen, 1200x800). 

 

Meanwhile, I had a lot of trouble with the Bodhi Linux USB drive, which I couldn't get to make a reliable connection in either of the MacBook Pro's USB ports. Turns out its USB connector plug, which extends out of the housing when the handle is pushed, is about a millimeter shorter than any other USB plug I have, so when inserted it barely makes a connection, and disconnects (unmounts) easily (as in right in the middle of an operation) if touched or bumped. Is this particular one faulty, or are they all like this? 

 

(I also tried another utility named Etcher to make a Bootable USB, having heard about it from this article by another Mac user who said he couldn't get UNetbootin to work. Etcher worked, but with some even more weird glitches, so I went back to UNetbootin.)

 

So I continued with the MacBook (2008 Aluminum Unibody model), which is where I want to install Bodhi anyway. The HD in the MacBook has several partitions, each with a different version of MacOS installed. I erased one partition I didn't need, formatting it in FAT32. (MacOS Disk Utility also offers ExFAT format, and explains: "MS-DOS (FAT): Use for Windows volumes that are 32 GB or less. ExFAT: Use for Windows volumes that are over 32 GB." Should I then use ExFAT instead for a 50 GB volume?)

 

Once the MacBook was running from the Bootable USB, I clicked the little leaf at the lower left, to Install Bodhi Linux. Selected English. Did not check "Download updates" and "Install third-party software"; get to those later. 

 

Next is "Installation type". Not sure what "Install Bodhi alongside them" does; when I selected it, the next screen showed two panels, under the legend "Allocate drive space by dragging the divider below:"

 

On the left with an icon of a file folder it said: 

 

Files (8.7 GB) 

/dev/sda4 (fat32)

27.9 GB

 

While on the right was an Ubuntu icon (?) and: 

 

Bodhi

/dev/sda5 (ext4)

22.1 GB

 

Then below: "8 smaller partitions are hidden. use [sic] the advanced partitioning tool for more control" I clicked on that, and it took me to the same screen that shows when "Something else" is selected in the Installation type screen, displaying a list of the present partitions. The partition I intended to use is at /sda4, 50 GB, formatted as FAT32; apparently the "Files" panel above refers to that, though it says it's now only 27.9 GB. /sda5 is presently another 50 GB partition with MacOS installed; I certainly don't want to delete/erase/replace it. 

 

Anyway, in this "Installation type" window with the list of partitions presently on the disk, at the bottom under "Device for boot loader installation" I saw a dropdown menu with a duplicate of the list of partitions, so I selected /dev/sda4, the 50 GB FAT32 volume I'd created. Then selected "Install Now", and an alert appeared:

 

"No root file system. No root file system is defined. Please correct this from the partitioning menu." I don't see a "partitioning menu", but there is a button that says "New Partition Table…"; however it is inactive. It becomes active if I select "/dev/sda" at the top of the partition list, which I understand to be selecting the entire disk. And indeed, I am warned that continuing with "New Partition Table…" will repartition and erase the entire disk (losing several hundred GB of data), which I certainly don't want to do. 

 

The Installation Instructions Wiki page simply assumes that "Erase disk and install Bodhi" is the user's choice, says nothing about the "Something else" option. The instructions appear not to have been updated since Bodhi 3.0.0; anyway I didn't see the first screen pictured at all. 

 

I also came across a PDF titled "Step-by-Step Guide to Bodhi Linux 4" by Roger Carter (I don't remember where I got it, thought it was on the Bodhi Linux site, but don't find it there now), but it makes the same assumption. 

 

I did an Internet search for "bodhi linux installation" and found a couple other sets of instructions, but again, both assumed I was ready to erase the computer's disk to install BL. Which I'm not. I just want to put it on the empty partition I prepared for it.

 

Suggestions?



#5 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4677 posts
  • LocationZeist, The Netherlands

Posted 31 December 2017 - 02:42 PM

OK, the Installer option "Something Else" needs some more explanation.
 
First off, this is in general meant for more experienced people, but reading your background I think you can do it.
 
When clicking the option a new slide appears that has an overview of all harddisks and their partitions. You will have options to modify, delete and add partitions. You may even decide to replace the Partition Table which means wiping the whole disk, something you don't want. So consider this a warning and be cautious.
A bit more about he filesystems. 
Apple has HFS * and most Linux OS use ext*. Installing Bodhi your best choice is ext4. 
How many partitions and for what purpose. 
Usually you will have two partitions, one for the system as a whole, including the users data, and a dedicated partition for SWAP. Why swap? It's a place on disk that offers fast access to RAM, in case it is loaded to the max. Further more it can be used when the machine is set to hybernation to store all what it needs on reboot. Personally I like to have a Swap parttion the size of my RAM, some want twice that size. Swap does not need to be formatted, it uses RAW data. You can however create much more partitions for several purposes, but I'm not that much in favor of that. The installer offers a list of options. The one you MUST have is a partition marked with a slash ' / ' that stands for the root of the system. Swap is chosen by telling it to use as ' linux swap '.
In your case I would delete the 50 GB partition you had created as FAT 32. The space is now seen as unallocated and free. Select that and choose "new" to make a partition with a size of ~45 GB and format it as ext4 and use it as / . Next create a partition in the remaining free space and assign that to Swap. Now you have the partitions the installer needs. 
Next you should notice a segment that is titled ' Device for bootloader installation '. Usually that is preset with /dev/sda. Leave it like that and don't choose a partition, the installer will find the right spot.
Once you have done all this you can click on ' Install Now '. An informational popup will appear about the actions that you need to confirm, or go back to the previous slide to make corrections or cancel.
About the bootloader.
We use Grub2 as bootloader application. Depending on the hardware and the Partition Table it will use either the MBR in the root of the harddrive or the dedicated bootpartition. For (U)EFI machines that would be the ESP where it would write an entry for ' ubuntu ', the distro we are based on. At boottime you should be greeted with a screen that gives you options into what OS you want to boot. At installation Grub will search the harddisk for bootable partitions and determine what OS's are present. AFAIK Mac would be recognized and shown on that first screen. Anyway, Bodhi will be shown on top and will autoboot after 5? seconds unless you arrow down to another line. It then waits for you to hit Enter. 
 
Hope this helps you enough for now.
 
Enjoy,
Charles


#6 Mendiculus

Mendiculus

    Member

  • Members
  • 7 posts

Posted 31 December 2017 - 11:27 PM

Charles:

 

Thanks for the details. Clearly a lot to learn. I know I did figure out a lot of this when I managed to install Ubuntu on an iBook (with a PowerPC CPU, which was more complicated in some ways than installing on a more recent Mac). But that was ten years ago, so I've pretty much forgotten what I learned then. I also have an IBM ThinkPad X31 a friend gave me back then to try with Linux, so I'll be working with that too. I had to quit working with computers almost entirely for most of the last decade due to ill health; I found myself unable to think hard enough to deal with the complexity ("cognitive impairment" they call it). Lately I seem to be recovering, and seem to be drawn back into the computer world. So far I don't feel swamped, but I need to pace myself, and it'll take a while, step by step. Thanks for your help – one of the things I like about the Open Source world is the community feeling – and I'll post again when I've made some progress. 



#7 graywizardlinux

graywizardlinux

    Bodhi Supporter

  • Members
  • 1090 posts

Posted 01 January 2018 - 01:44 AM

bodhi should install nicely with a few tweaks on the x31.  i run x201 and x220.   wnat anew asus badly but just too many major emergencies keep setting me back.

 

Good luck!



#8 cooler

cooler

    Member

  • Members
  • 83 posts

Posted 01 January 2018 - 09:42 AM

Welcome to Bodhi Linux.

You could try the installation straightforward on your X31- an excellent laptop (I've owned one or two of them) - but you need the legacy version of Bodhi. Once you've seen what's all about you could try to upgrade your Mac.

As a slight coincidence I've also started using Linux because of a Thinkpad X (I don't remember if it was a X22 or X31). At that time Ubuntu just changed their kernel and the non-PAE machines were no longer supported and that's how I found out about Bodhi from some post in a forum.

Good luck!



#9 Oblio

Oblio

    Bodhi Team

  • Team
  • 240 posts

Posted 01 January 2018 - 04:10 PM

As cooler stated, that X31 system may be something to play around with/practice...break, fix, learn.  Then, once you are a Bodhi ninja, you can start playing with advanced partitioning as Charles mentioned.

 

It's always awesome to have a "production" system and then one to play and learn on.  You are in a great position!

 

Cheers!


Xeon E3-1220 v3 3.1GHz Quad, ASRock Rack E3C224, 2x 8GB Kingston KVR16E11/8I DDR3-1600 ECC CL11 Intel Chips (Dual Channel), EVGA GeForce GTX 570, Samsung SM863 120GB OS SSD, 2x WD RED 3TB HDDs (Raid 0), Focusrite Scarlett 2i4, Antec Earthwatts EA-750 80 Plus Platinum 750w PSU - Bodhi 4.4.0 64

AMD Phenom II X4 940 3.0GHz Quad, Gigabyte GA-MA78GPM-DS2H, 2x 2GB Kingston KHX8500D2K2 DDR2-1066 (Dual Channel), EVGA GeForce GTX 570, Intel 40GB OS SDD, Seagate ST31000340AS 1TB HDD, Seagate STBD4000400 4TB HDD, EVGA 500w Bronze Plus 80+ PSU - Bodhi Linux 3.2.1 64





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users