Jump to content

Photo

Symphytum 2.2


Best Answer The waiter, 02 January 2018 - 09:28 PM

OK, it looks, the QT5 version installed from repository does not match. Symphytum requires QT 5.9 and we have QT 5.5.1. Now there are two choices

1. upgrade QT (if possible. Needs to do some Google research). 

2. downgrade Symphytum (maybe to ver. 2.0)

 

Anyway, Symphytum is aimed for Ubuntu 17.04 and Bodhi Linux is based on Ubuntu 16.04. It explain some installing issues

Go to the full post


  • Please log in to reply
8 replies to this topic

#1 vvkozmenko

vvkozmenko

    Member

  • Members
  • 119 posts

Posted 02 January 2018 - 12:45 AM

Hello, all,

 

I've installed Symphytum database application (version 2.2) and it autocloses at launch.

 

I've had a similar problem with the Exterminator today, and The Waiter suggested to install a python package which solved the problem.

 

How can I find what package I am missing to run the Symphytum 2.2?

 

Thank you in advance.

 

Val





A big thank you to everyone who contributes to Bodhi Linux


#2 The waiter

The waiter

    Module Master

  • Developer
  • 1715 posts
  • LocationBanska Bystrica, Slovakia

Posted 02 January 2018 - 05:29 AM

As I told you, run app from terminal and post the outcome here...

#3 vvkozmenko

vvkozmenko

    Member

  • Members
  • 119 posts

Posted 02 January 2018 - 04:30 PM

Hi, Stefan,

 

After running the Symphytum from the terminal, I've got this report

 

irtual-Platform:~$ symphytum
symphytum: /usr/lib/x86_64-linux-gnu/libQt5PrintSupport.so.5: version `Qt_5' not found (required by symphytum)
symphytum: /usr/lib/x86_64-linux-gnu/libQt5Network.so.5: version `Qt_5' not found (required by symphytum)
symphytum: /usr/lib/x86_64-linux-gnu/libQt5Sql.so.5: version `Qt_5' not found (required by symphytum)
symphytum: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.7' not found (required by symphytum)
symphytum: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5' not found (required by symphytum)
symphytum: /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5: version `Qt_5' not found (required by symphytum)
symphytum: /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5: version `Qt_5' not found (required by symphytum)
bodhi64@bodhi64-Parallels-Virtual-Platform:~$
 
 
Basically, the Symphytum 2.2.0 requires TQt_5 and I am nost sure what exactly it is  and how to get it.
 
Thank you,
 
Val


#4 The waiter

The waiter

    Module Master

  • Developer
  • 1715 posts
  • LocationBanska Bystrica, Slovakia

Posted 02 January 2018 - 04:55 PM

OK

 

Let's see how to help. When I have this type of issue and some dependencies are missing, I do this:

 

Look at your first line 

symphytum: /usr/lib/x86_64-linux-gnu/libQt5PrintSupport.so.5: version `Qt_5' not found (required by symphytum)

 

So, we are looking for libQt5PrintSupport. Now type this command in terminal

apt-cache search libQt5PrintSupport

 

Apt-cache search will look up this package (libqt5printsupport5 - Qt 5 print support module) and then we need to install it.

sudo apt-get install libqt5printsupport5

 

After installing, run the app from terminal again what happens. If there are still deps missing, repeat the searching and installing as I showed you until app works fine, OK?

 

Stefan



#5 vvkozmenko

vvkozmenko

    Member

  • Members
  • 119 posts

Posted 02 January 2018 - 05:16 PM

Hi, Stefan,

 

Thank you for showing me the method. I will try it tonight.

 

Val



#6 vvkozmenko

vvkozmenko

    Member

  • Members
  • 119 posts

Posted 02 January 2018 - 07:39 PM

Hi, Stefan,

I've done as you recommended. The output was - this package has been ready installed. Apparently, the sudo apt-get install libqt5printsupport5 installed the same version.

Thank you for your help, Stefan. I am learning every day.

Val

#7 The waiter

The waiter

    Module Master

  • Developer
  • 1715 posts
  • LocationBanska Bystrica, Slovakia

Posted 02 January 2018 - 08:56 PM

How did you install Symphytum? I can try to install and look closer...

 

EDIT: OK, I found it. Let me have some time



#8 The waiter

The waiter

    Module Master

  • Developer
  • 1715 posts
  • LocationBanska Bystrica, Slovakia

Posted 02 January 2018 - 09:28 PM   Best Answer

OK, it looks, the QT5 version installed from repository does not match. Symphytum requires QT 5.9 and we have QT 5.5.1. Now there are two choices

1. upgrade QT (if possible. Needs to do some Google research). 

2. downgrade Symphytum (maybe to ver. 2.0)

 

Anyway, Symphytum is aimed for Ubuntu 17.04 and Bodhi Linux is based on Ubuntu 16.04. It explain some installing issues



#9 vvkozmenko

vvkozmenko

    Member

  • Members
  • 119 posts

Posted 03 January 2018 - 01:53 AM

Hi, Stefan,

No worries, I am using 2.1. Works well.

Thank you for your help.

Val




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users