Jump to content

Photo

Startup applications not, or sometimes not, starting up


Best Answer gogolink, 06 February 2018 - 03:29 AM

Thank you, Jeff and Charles, editing the startupcommands file as you suggested did the trick!

 

I've got Compton, Dropbox, Synclient TouchPadOff, and nm-applet running at startup, editing the file ~/.e/e/applications/startup/startupcommands with epad.  The file now looks like this:

sh -c 'compton -b &' | \
~/.dropbox-dist/dropboxd | \
synclient TouchPadOff=1 | \
nm-applet

I had less luck with the Moksha gui.  I don't know whether that's the reason, but something might have happened to my .desktop files at ~/.local/share/applications: when I double-click, for instance, the file Touchpad_Off.desktop (a personal application launcher that I created a while ago), I get an "untrusted application launcher" error.  The file doesn't appear to be executable.  I guess that's why adding or removing Touchpad_Off, or Compton, or Dropbox, via the Startup Applications gui didn't do anything for me.

 

But I'm totally happy using epad on the startupcommands file instead.

Thank you so much for your help!

Go to the full post


  • Please log in to reply
6 replies to this topic

#1 gogolink

gogolink

    Member

  • Members
  • 82 posts

Posted 03 February 2018 - 01:06 PM

Hi guys, I'm running Bodhi 4.4.0 with Moksha 0.2.1, on an Acer C720 Chromebook.

 

I've never been able to get Compton to autostart.  I've looked at various forum posts, including this one: http://forums.bodhil...ers/?hl=startup;

 

My entry for startupapplications at ~/.e/e/applications/startup reads:

 

sh -c 'compton -b &' | \

 

I had tried before to create a custom launcher for Compton and use the Moksha gui to get it to autostart; don't know whether the two methods interfered with one another, but in any case the autostart never worked.

 

I was living with that.

 

Recently, however, I noticed that sometimes Dropbox didn't start.  Sometimes it did, though it would take quite a while (over a minute, perhaps two or sometimes three) for the icon to appear in the panel.  But sometimes that icon never appeared (and I don't think the daemon started, either), and I needed to reboot.

 

I was living with that, too.

 

But now I also notice that the application launcher I created to turn the touchpad off (synclient TouchPadOff=1) doesn't seem to start up automatically any more (or at least not reliably); it used to.

 

Any advice for what I can do to diagnose the problem(s) and get my applications I to start automatically?

Thanks in advance!





A big thank you to everyone who contributes to Bodhi Linux


#2 Jeff

Jeff

    Lead Developer

  • Developer
  • 12599 posts
  • LocationBloomington, IL

Posted 04 February 2018 - 01:27 PM

Can you remove the | \ at the end of your startup applications file? That should only be present if there are multiple lines / commands. It is used as a separator between lines. 

 

As for your other applications not auto starting - can you post the output if your ~/.e/e/applications/startup/.order file?



#3 gogolink

gogolink

    Member

  • Members
  • 82 posts

Posted 05 February 2018 - 01:26 AM

Hi Jeff,

 

Here's my .order:

 

nm-applet.desktop
elaptopcheck.desktop
Touchpad_Off.desktop
DropBox.desktop

 

Also of interest, I guess: nm applet seems to not have started, or rather, doesn't show up in the Shelf.  I am on the Internet, but am missing my usual icon.

And the file startupcommands in /home/gogo/.e/e/applications/startup is empty: 0 bytes, doesn't open with epad.

 

I've removed the | \ at the end of my startupapplications file, but compton still does not start automatically.



#4 Jeff

Jeff

    Lead Developer

  • Developer
  • 12599 posts
  • LocationBloomington, IL

Posted 05 February 2018 - 04:33 AM

Err, if your startupcommands file is empty / unreadable that is probably the issue. How are you opening / editing the contents of it?



#5 gogolink

gogolink

    Member

  • Members
  • 82 posts

Posted 05 February 2018 - 06:22 PM

Err, if your startupcommands file is empty / unreadable that is probably the issue. How are you opening / editing the contents of it?

 

I'm not (editing the contents of it).  For Dropbox and Touchpad Off, I had used the Moksha gui tool.  For Compton, I used startupapplications, rather than startupcommands -- probably I created the file following advise I took from some post somewhere, but I did so many different things when I tried to get Compton to autostart, that I don't remember.

 

Now, if Moksha uses a the startupcommands file, and mine is unreadable / empty: can I just delete the existing one and create a new one with epad?  

 

And if so, what should it look like?

 

Thank you so much for your help, and please excuse my ignorance!



#6 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4701 posts
  • LocationZeist, The Netherlands

Posted 05 February 2018 - 08:17 PM

There is a GUI option, like this: (Example for compton)

Menu > Applications > SystemTools > SystemSettings 

In the dialog click on Startup Applications

At the bottom click on Startup Commands

Click in the Add Startup Command box and type your command: compton -b (no need for syntax stuff, the GUI tool will do that for you)

Next hit Add Command and the command will move to the upper box.

Now hit Apply.

Done

Logout and login again to test.

 

Else you should start epad first, open the file startupcommands, write your command and hit save.

Using this method will make it necessary to use the correct syntax when you have more commands to execute.

 

NB. Navigating to the empty file and open it from there with epad will not work because if a file is empty nothing will be shown, not even an empty window. But epad will be running. Do a thing like that a few times and your RAM will be eaten up because it will start a new epad instance every time. 

 

Enjoy,

Charles



#7 gogolink

gogolink

    Member

  • Members
  • 82 posts

Posted 06 February 2018 - 03:29 AM   Best Answer

Thank you, Jeff and Charles, editing the startupcommands file as you suggested did the trick!

 

I've got Compton, Dropbox, Synclient TouchPadOff, and nm-applet running at startup, editing the file ~/.e/e/applications/startup/startupcommands with epad.  The file now looks like this:

sh -c 'compton -b &' | \
~/.dropbox-dist/dropboxd | \
synclient TouchPadOff=1 | \
nm-applet

I had less luck with the Moksha gui.  I don't know whether that's the reason, but something might have happened to my .desktop files at ~/.local/share/applications: when I double-click, for instance, the file Touchpad_Off.desktop (a personal application launcher that I created a while ago), I get an "untrusted application launcher" error.  The file doesn't appear to be executable.  I guess that's why adding or removing Touchpad_Off, or Compton, or Dropbox, via the Startup Applications gui didn't do anything for me.

 

But I'm totally happy using epad on the startupcommands file instead.

Thank you so much for your help!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users