Jump to content

Photo

can't update grub

grub

Best Answer TechnoJunky, 08 February 2018 - 03:51 PM

I found the problem.  It was an error in my copy and paste when editing the grub file.  I've modified it and now update-grub works.

Go to the full post


  • Please log in to reply
6 replies to this topic

#1 TechnoJunky

TechnoJunky

    Member

  • Members
  • 5 posts
  • LocationChicago

Posted 07 February 2018 - 09:36 PM

I just installed Bodhi.  One of the steps that I take when installing/reinstalling Linux is to modify grub.  I've edited /etc/default/grub but when I run 'sudo update-grub2', it errors with "/usr/sbin/grub-mkconfig: 12: /etc/default/grub: to: not found".  Any idea why?





A big thank you to everyone who contributes to Bodhi Linux


#2 gohlip

gohlip

    Member

  • Members
  • 680 posts

Posted 08 February 2018 - 05:24 AM

Command is 'sudo update-grub', not 'sudo update-grub2',


Life is a sexually transmitted disease with a 100% mortality rate.


#3 TechnoJunky

TechnoJunky

    Member

  • Members
  • 5 posts
  • LocationChicago

Posted 08 February 2018 - 12:55 PM

it gives the same error



#4 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4708 posts
  • LocationZeist, The Netherlands

Posted 08 February 2018 - 02:13 PM

/usr/sbin/grub-mkconfig is the script that is executed when you issue the command update-grub (or update-grub2).

 

The error suggests that the file '/etc/default/grub' does not exist.

 

Can you check the results for 

ls -l /etc/default/ | grep grub

And post the outcome here.

What did you use to edit the file? Did you save it right?

 

Enjoy,

Charles



#5 TechnoJunky

TechnoJunky

    Member

  • Members
  • 5 posts
  • LocationChicago

Posted 08 February 2018 - 03:37 PM

I get the following output when running the suggested command:

-rw-r--r-- 1 root root 1275 Feb  7 13:26 grub
-rw-r--r-- 1 root root 1343 Dec  5 14:24 grub.bodhi
-rw-r--r-- 1 root root 1237 Jan 26  2017 grub.ucf-dist
-rw-r--r-- 1 root root 1343 Feb  7 12:56 grub.ucf-old
 

I used epad, and yes I saved it right, the change is still present in the file.  FYI, I disable IPv6 due to a limitation with my VPN provider, and also force the menu to show during boot.

I normally use Kate with KDE, but since I'm trying Bodhi, I didn't install Kate or other KDE packages.



#6 TechnoJunky

TechnoJunky

    Member

  • Members
  • 5 posts
  • LocationChicago

Posted 08 February 2018 - 03:51 PM   Best Answer

I found the problem.  It was an error in my copy and paste when editing the grub file.  I've modified it and now update-grub works.


  • Kev likes this

#7 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4708 posts
  • LocationZeist, The Netherlands

Posted 08 February 2018 - 04:31 PM

Glad you got it sorted.

 

Enjoy,

Charles







Also tagged with one or more of these keywords: grub

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users