Bodhi Linux Forums: Wireless issues with HP Laptop - Bodhi Linux Forums

Jump to content

  • 2 Pages +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

Wireless issues with HP Laptop

#1 User is offline   DaveL60 

  • Member
  • Group: Members
  • Posts: 93
  • Joined: 17-July 11
  • LocationEastern USA

Posted 17 July 2011 - 03:09 PM

I have an HP Pavilion dv4-1123us laptop, on which I've been experimenting with various flavors of Linux. I've just install Bodhi 1.1.0 and am fairly impressed so far: it's fast, very attractive, and the minimal installation with easy software additions works great.

I am encountering a couple of problems that I haven't been able to solve:

1) There seems to be some oddities with the keyboard. In particular, the "end" key doesn't consistently work right in some places, such as editing the address or search fields in Midori. Sometimes "end" works and some times it doesn't. And while ctrl-left/right moves by words editing this post, shift-ctrl-left/right doesn't move the cursor and so doesn't select by words.

2) I've had wireless working on this laptop under Ubuntu and Mint, but am not succeeding with Bodhi. I think I've managed to install the Broadcom 43xx drivers it needs, but I'm not sure how to confirm that really worked. The laptop has a set of buttons across the top for media player control and wireless on/off. These are touch-switch controls, not keys or physical buttons. The media control (at least vol up/down) work properly, but the wireless control is glowing red (which indicates wireless is disabled) and doesn't respond when touched. I've done some searching on how to enable wireless from the command line, but haven't succeeded with that either.

So, I'm looking for help on how to make sure I've got the right keymap in Xwin, and with getting my wireless up an running.

Thanks,

DaveL
0

#2 User is offline   Elw3 

  • Group: Moderators
  • Posts: 1451
  • Joined: 06-June 11

Posted 17 July 2011 - 04:41 PM

about network, if you thing it is something to do with the on/off button try
rfkill list
at terminal, if everything is set to 'no' the card is switched on , if not try
rfkill unblock 'yourcardnumber'
hope that helps.
Bad Wolf
0

#3 User is offline   hippytaff 

  • Member
  • Group: Members
  • Posts: 1191
  • Joined: 15-April 11
  • LocationWales, UK

Posted 17 July 2011 - 06:22 PM

Also
sudo rfkill unblock all


I think rfkill needs to be installed in bodhi.
sudo apt-get install rfkill
Also if this doesn't work it might be worth trying the wireless script. You will need to install wireless-tools to run the wireless script (will fix that in the script one day)

Cheers
Hippytaff
0

#4 User is offline   DaveL60 

  • Member
  • Group: Members
  • Posts: 93
  • Joined: 17-July 11
  • LocationEastern USA

Posted 21 July 2011 - 11:29 PM

If I run rfkill, I get the following:

dave@firelizard:~$ /sbin/rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hp-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no

Based on Elw3's post, that would seem to indicate that there's no problem. But the touch button above the keyboard is still glowing red, which I think indicates that WiFi is off. If I right-click the Network Manager icon on the bar ("shelf") at the top of the screen, it shows the Enable Wireless box checked, but if I left-click on it, Wireless Networks is grayed out and shows "device not ready".

I downloaded the wireless script and it complained about not finding rfkill, so I OK'd installing it. The script then presented me the set of adapters to choose from, I picked the wireless, and then the script seemed to just exit apparently without doing anything further.

Heavy sigh.

DaveL
0

#5 User is offline   hippytaff 

  • Member
  • Group: Members
  • Posts: 1191
  • Joined: 15-April 11
  • LocationWales, UK

Posted 22 July 2011 - 08:12 AM

You have drivers installed? Check the wireless-results.txt for info
0

#6 User is offline   DaveL60 

  • Member
  • Group: Members
  • Posts: 93
  • Joined: 17-July 11
  • LocationEastern USA

Posted 23 July 2011 - 11:36 AM

View Posthippytaff, on 22 July 2011 - 08:12 AM, said:

You have drivers installed? Check the wireless-results.txt for info

Hmm, OK can do. Might I suggest you add mention of that to the README file?

Results file attached, but a couple of key things probably worth highlighting:

I appear to have a network driver for the wireless:

Quote

******************************************************************************************
lshw List of network devices
******************************************************************************************

*-network
description: Network controller
product: BCM4322 802.11a/b/g/n Wireless LAN Controller
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:03:00.0
version: 01
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=b43-pci-bridge latency=0
resources: irq:18 memory:99700000-99703fff


And it appears to be disabled:

Quote

*-network DISABLED
description: Wireless interface
physical id: 2
logical name: wlan0
serial: 00:21:00:5e:86:5f
capabilities: ethernet physical wireless
configuration: broadcast=yes driver=b43 driverversion=2.6.39-2-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg


And the network manager apparently agrees:

Quote

******************************************************************************************
NetworkManager.state
******************************************************************************************

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true



And the script apparently didn't finish:

Quote

******************************************************************************************
NetworkManager.state
******************************************************************************************

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true


And I continue to have funky, variable results with the keyboard, so I'm going to break that out as a separate question.

Thanks for the on-going assistance. Hope we can lick this problem sooner or later. :-)

DaveL

Attached File(s)


0

#7 User is offline   hippytaff 

  • Member
  • Group: Members
  • Posts: 1191
  • Joined: 15-April 11
  • LocationWales, UK

Posted 24 July 2011 - 07:42 PM

Good point, I didn't realise the readme ommitted this. Originally this is all the script actually did, until a certain Matt Symes spruced it up.

Anyway, seems you found a bug in the script, hence it not completing. Always welcome those findings. Can you try in a terminal
ifconfig wlan0 up
, and post any errors. Looks like the driver is installed, but it might be worth uninsalling and reinstalling it, trying a different driver etc etc

May I suggest having a read of this from the debian wiki

which goes over in detail what I have briefly suggested

btw - broadcom are notoriously annoying :)
0

#8 User is offline   DaveL60 

  • Member
  • Group: Members
  • Posts: 93
  • Joined: 17-July 11
  • LocationEastern USA

Posted 28 July 2011 - 02:55 AM

View Posthippytaff, on 24 July 2011 - 07:42 PM, said:

Good point, I didn't realise the readme ommitted this. Originally this is all the script actually did, until a certain Matt Symes spruced it up.

Anyway, seems you found a bug in the script, hence it not completing. Always welcome those findings. Can you try in a terminal
ifconfig wlan0 up
, and post any errors. Looks like the driver is installed, but it might be worth uninsalling and reinstalling it, trying a different driver etc etc.

Not getting much love from that command:
dave@firelizard:~$ ifconfig wlan0 up
SIOCSIFFLAGS: Permission denied
dave@firelizard:~$ sudo ifconfig wlan0 up
[sudo] password for dave: 
SIOCSIFFLAGS: No such file or directory
dave@firelizard:~$ 


I'll look up the Debian link when I've got some time.

DaveL
0

#9 User is offline   jschall 

  • Gold Member
  • Group: Members
  • Posts: 908
  • Joined: 24-January 11
  • LocationMont Saint Hilaire, QC

Posted 28 July 2011 - 11:38 AM

If I turn off the wifi (Fn+F2 on my eeePC), that command gives this:


jeff@eeepc:~$ sudo ifconfig wlan0 up
wlan0: ERROR while getting interface flags: No such device
jeff@eeepc:~$


@DaveL60:

What do you get when you enter simply "ifconfig"?
the other Jeff
----------------------------
eeePC 701 4G Bodhi Forum Members Map
0

#10 User is offline   Tara 

  • Moderately Bemused
  • Group: Moderators
  • Posts: 898
  • Joined: 02-July 11
  • LocationOttawa, ON

Posted 28 July 2011 - 11:54 AM

View PostJeff Schallenberg, on 28 July 2011 - 11:38 AM, said:

If I turn off the wifi (Fn+F2 on my eeePC), that command gives this:


jeff@eeepc:~$ sudo ifconfig wlan0 up
wlan0: ERROR while getting interface flags: No such device
jeff@eeepc:~$


@DaveL60:

What do you get when you enter simply "ifconfig"?


"iwconfig" would skip the wall of text that comes out with ifconfig, and tell you exactly which card is the wireless... :) On my current laptop, it's wlan0, but on my Dell Mini 9 it was "eth1".

tara@MarchHare:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"veritas2"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:13:10:53:D2:44   
          Bit Rate=54 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=62/70  Signal level=-48 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

tara@MarchHare:~$ 

0

#11 User is offline   hippytaff 

  • Member
  • Group: Members
  • Posts: 1191
  • Joined: 15-April 11
  • LocationWales, UK

Posted 28 July 2011 - 12:07 PM

@DaveL60
This error normally appears when your firmware can't be found (or so I belive) I would normally suggest installing the b43-fwcutter package to remedy this, but it seems that your chipset [4322] doesn't appear to be supported. So it might be a case of having to try installing the proprietry driver.
sudo apt-get update

sudo apt-get install bcmwl-kernel-source


I have never tried this myself, but it appears to work in most cases. Let me know how it goes.

Edit -> Failing this it looks like a ndiswrapper job using ndisgtk and the xp driver for your wireless device, but this is a last resort. :)

@Tara - true, but we have the details needed in the wireless script results.txt and what DaveL60 posted. it's wlan0, though like on one of your machines mine is also eth1 (on all my machines) always a source of confusion for me to begin with :)
0

#12 User is offline   DaveL60 

  • Member
  • Group: Members
  • Posts: 93
  • Joined: 17-July 11
  • LocationEastern USA

Posted 30 July 2011 - 12:15 PM

View Posthippytaff, on 28 July 2011 - 12:07 PM, said:

@DaveL60
This error normally appears when your firmware can't be found (or so I belive) I would normally suggest installing the b43-fwcutter package to remedy this, but it seems that your chipset [4322] doesn't appear to be supported. So it might be a case of having to try installing the proprietry driver.
sudo apt-get update

sudo apt-get install bcmwl-kernel-source


I have never tried this myself, but it appears to work in most cases. Let me know how it goes.

Edit -> Failing this it looks like a ndiswrapper job using ndisgtk and the xp driver for your wireless device, but this is a last resort. :)

I tried this, with the following results
DKMS: install Completed.
update-initramfs: deferring update (trigger activated)

Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.39-2-generic
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8105e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-1.fw for module r8169
dave@firelizard:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          
dave@firelizard:~$ sudo ifconfig wlan0 up
SIOCSIFFLAGS: No such file or directory

The output of the last command doesn't look much different from what I had before. I'm a little puzzled: I thought the only drivers for the bcm stuff were proprietary drivers, and so I'd thought that was what I had installed. Looking at my output vs. what Tara posted, I'm wondering if the Power Management setting reported is significant?

I need to go read that debian item, as I'm guessing it's what I used before under another distro to get this working. And I've never before needed the ndiswrapper for wireless on this laptop, so that really is a last resort, IMO.

I appreciate the persistence of folks trying to help out here.

DaveL
0

#13 User is offline   DaveL60 

  • Member
  • Group: Members
  • Posts: 93
  • Joined: 17-July 11
  • LocationEastern USA

Posted 31 July 2011 - 02:41 AM

I went off and read the Debian pages that were linked. When you follow through to the link on the Linux Wireless page, my chipset (BCM 4322 Rev 01) is described as being supported "partially in 2.6.39+", so I'm probably better off installing the proprietary driver. I can find Debian installation instructions for that here but I don't know whether to follow the instructions for Squeeze, Lenny, or Wheezy with Bodhi. Or is there a page somewhere specifically about installing the proprietary Broadcom drivers in Bodhi?

DaveL
0

#14 User is offline   hippytaff 

  • Member
  • Group: Members
  • Posts: 1191
  • Joined: 15-April 11
  • LocationWales, UK

Posted 31 July 2011 - 08:14 AM

I dont think the bodhi wiki has this info. You would better off following instructions for ubunru 10.04, from the ubuntu wiki. I originally linked to the debian wiki because it seemef more complete, information wise. Sorry forthe lack of links in this post. Posting from my phone. Google ubuntu broadcom. Should return the relevant link to thier wiki.
0

#15 User is offline   Hendra 

  • Member
  • Group: Members
  • Posts: 648
  • Joined: 17-April 11
  • LocationBalikpapan City, East Borneo, Indonesia

Posted 31 July 2011 - 09:19 AM

Btw, for your keyboard problem with Ctrl + Shift + Left / Right,
it is not working because it's assign to key binding to move between multiple monitor
you can delete the binding if you want (just like I do)
just call everything and type 'keys' and press enter to open Key Binding Setting window

Perhaps your problem with 'End' key also comes from global shortcut? Try to check it
0

#16 User is offline   DaveL60 

  • Member
  • Group: Members
  • Posts: 93
  • Joined: 17-July 11
  • LocationEastern USA

Posted 31 July 2011 - 11:24 AM

View PostHendra, on 31 July 2011 - 09:19 AM, said:

Btw, for your keyboard problem with Ctrl + Shift + Left / Right,
it is not working because it's assign to key binding to move between multiple monitor
you can delete the binding if you want (just like I do)
just call everything and type 'keys' and press enter to open Key Binding Setting window

Perhaps your problem with 'End' key also comes from global shortcut? Try to check it

Thanks. Since forum etiquette seems to favor one question per thread, I've actually broken that discussion out to its own thread, where that exact fix was suggested and has worked. I hadn't found a way to change the title of this one, though, so I've left residual confusion anyway. :)

I was a little puzzled by "just call everything and type 'keys'", but a little poking showed the "Run Everything" in the Bodhi menu, which I hadn't played with but will probably come to love so thanks for that too.

DaveL
0

#17 User is offline   DaveL60 

  • Member
  • Group: Members
  • Posts: 93
  • Joined: 17-July 11
  • LocationEastern USA

Posted 31 July 2011 - 11:48 AM

View Posthippytaff, on 31 July 2011 - 08:14 AM, said:

I dont think the bodhi wiki has this info. You would better off following instructions for ubunru 10.04, from the ubuntu wiki. I originally linked to the debian wiki because it seemef more complete, information wise. Sorry for the lack of links in this post. Posting from my phone. Google ubuntu broadcom. Should return the relevant link to thier wiki.

No problem about the lack of links. I found the Unbuntu Broadcom page, and the instructions for installing the STA drivers match what you'd previously suggested, and which I have done. The instructions on the Ubuntu page then say

Quote

Step 2.

Under the desktop menu System > Administration > Hardware/Additional Drivers, the STA drivers can be activated for use.

Note: A computer restart may be required before using the wifi card.

<snip>

Step 3.

Instead of a computer restart, in a terminal issue the following commands:

~$ sudo modprobe -r b43 ssb wl
~$ sudo modprobe wl

I haven't puzzled out what the Bodhi equivalent would be of Ubuntu's System > Administration > Hardware/Additional Drivers, and if I enter the commands from Step 3, I get:
dave@firelizard:/etc/apt$ sudo modprobe -r b43 ssb wl
FATAL: Error removing wl (/lib/modules/2.6.39-2-generic/updates/dkms/wl.ko): Device or resource busy
dave@firelizard:/etc/apt$ sudo modprobe  wl

which seems to indicate that the drivers are, in fact, loaded. But network manager still reports (left click) "wireless is disabled" and (right click) "Enabled wireless" is grayed out.

Seems like I'm missing one crucial step. I'm considering re-installing Bodhi, since I haven't done much with this system yet, and trying the STA driver procedure on a clean install.

Also, I've got a separate /home partition that's been preserved across installs of various distros. It seems contra-linux, but might there be something hanging around in there causing me a problem?

DaveL
0

#18 User is offline   Charles@Bodhi 

  • Old Faithful
  • Group: Moderators
  • Posts: 3339
  • Joined: 23-February 11
  • LocationZeist, The Netherlands

Posted 31 July 2011 - 11:57 AM

View PostDaveL60, on 31 July 2011 - 11:48 AM, said:


Also, I've got a separate /home partition that's been preserved across installs of various distros. It seems contra-linux, but might there be something hanging around in there causing me a problem?



Could be, if you use the same username for all your installs. That's because a lot of config files are stored in your home/username folder as hidden files.

Charles.
Medion S4216 Ultrabook, 4GB RAM, 1TB HDD, WIN 8.1, Bodhi 2.4.0-64
EEE Box202, 1GB RAM, 80 GB HDD, WIN-XP SP3, Bodhi 2.3.0-32_non-pae
EEE PC 901, 1GB RAM, 12 GB SSD, Tripleboot Bodhi 2.4.0-32 non-pae: E17-stable, E17-testing, E18-testing

How to mark a thread as [SOLVED]
The Bodhi Guide to Enlightenment
0

#19 User is offline   Hendra 

  • Member
  • Group: Members
  • Posts: 648
  • Joined: 17-April 11
  • LocationBalikpapan City, East Borneo, Indonesia

Posted 31 July 2011 - 01:48 PM

View PostDaveL60, on 31 July 2011 - 11:24 AM, said:

Thanks. Since forum etiquette seems to favor one question per thread, I've actually broken that discussion out to its own thread, where that exact fix was suggested and has worked. I hadn't found a way to change the title of this one, though, so I've left residual confusion anyway. :)

I was a little puzzled by "just call everything and type 'keys'", but a little poking showed the "Run Everything" in the Bodhi menu, which I hadn't played with but will probably come to love so thanks for that too.

DaveL


Good for you then :D

You can call Run Everything with shortcut Window + Space
It's very convenient to use. I practically use Run Everything and Ibar all the time. I hardly ever use Main Menu

About changing your title, see here.
It's wiki on how to mark your thread as solved, but in this forum we do it by editing the title :)
0

#20 User is offline   DaveL60 

  • Member
  • Group: Members
  • Posts: 93
  • Joined: 17-July 11
  • LocationEastern USA

Posted 04 September 2011 - 03:12 PM

I fixed the title, as explained. Thanks for the pointer.

I've been on vacation and then catching up for most of the last month, so am only now returning to this topic. I haven't made and changes yet and so, unsurprisingly, I still don't have wireless. Hopefully will get some time to play soon.

DaveL
0

Share this topic:


  • 2 Pages +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users