Jump to content

Photo

No Audio on Macbook Pro


  • Please log in to reply
14 replies to this topic

#1 Joe

Joe

    Member

  • Members
  • 6 posts

Posted 12 September 2011 - 03:31 AM

Does anyone use Bodhi on Apple hardware, specifically the macbook pro?

I have installed many Linux distros on my macbook pro and audio never works out of the box. The one distro that I have finally gotten to work is Ubuntu. I thought that Bodhi audio might work the same since it is based on Ubuntu but it doesn't.

Bodhi Linux 1.2.0
Apple Macbook Pro (mid 2007)
lspci shows: 00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
alsamixer shows: Card: HDA Intel | Chip: Realtek ALC889A
dmidecode -s system-product-name shows: MacBookPro3,1

Thanks for any help and thanks for Bodhi Linux.

Joe



A big thank you to everyone who contributes to Bodhi Linux


#2 Machster28

Machster28

    Member

  • Members
  • 5 posts

Posted 12 September 2011 - 02:30 PM

Does anyone use Bodhi on Apple hardware, specifically the macbook pro?

I have installed many Linux distros on my macbook pro and audio never works out of the box. The one distro that I have finally gotten to work is Ubuntu. I thought that Bodhi audio might work the same since it is based on Ubuntu but it doesn't.

Bodhi Linux 1.2.0
Apple Macbook Pro (mid 2007)
lspci shows: 00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
alsamixer shows: Card: HDA Intel | Chip: Realtek ALC889A
dmidecode -s system-product-name shows: MacBookPro3,1

Thanks for any help and thanks for Bodhi Linux.

Joe



I have tried using Bodhi on a 2009 MBP using VMWare, Parallels, and VirtualBox. It has an intel sound card. Only Parallels would not install. Both the other two vm apps had no sound with the liveCD or with a Bodhi install. Tried every thing I could think of to get it to work. Otherwise I think Bodhi is a gem.

The only sound problem I've had in the past that I can recall is with another Ubuntu based distro that also used e17.

#3 airbrushwerx

airbrushwerx

    Member

  • Members
  • 64 posts

Posted 12 September 2011 - 05:48 PM

Are you installing 1.2.0? Linux 3.0.0 kernel is not supported under VMWare tools. Also, the new kernel has some issues with various hardware -- I have a DEL 6400 that it can't see various hardware configs, but can with 2.6.35.

(go back to 2.6.x) Install 1.1.0. and then VMWare tools (if it is in a VM).

see if the audio works for that distribution. You might have to open the alsamixer from the command line. making sure that looks right.

If you can get audio then,

and the sudo apt-get update & sudo apt-get upgrade.

This is what I had to do to get it working correctly.

Cheers,
DJ

#4 Machster28

Machster28

    Member

  • Members
  • 5 posts

Posted 12 September 2011 - 09:10 PM

Are you installing 1.2.0? Linux 3.0.0 kernel is not supported under VMWare tools. Also, the new kernel has some issues with various hardware -- I have a DEL 6400 that it can't see various hardware configs, but can with 2.6.35.

(go back to 2.6.x) Install 1.1.0. and then VMWare tools (if it is in a VM).

see if the audio works for that distribution. You might have to open the alsamixer from the command line. making sure that looks right.

If you can get audio then,

and the sudo apt-get update & sudo apt-get upgrade.

This is what I had to do to get it working correctly.

Cheers,
DJ


Hi DJ.

The boot screen states 2.6.x kernel with both 1.2 and 1.1. But anyway I grabbed the v1.1 iso and installed. No change , still without sound with the LiveCD and the HD install.

Thanks.

edit: Must have been comparing two open instances of 1.1 above. 1.2 does indeed have kernel 3.0.

#5 STRUPPI

STRUPPI

    Member

  • Members
  • 738 posts

Posted 12 September 2011 - 09:41 PM

Hi Machster28,
is this your first Linux on Mac??

Have you controlled the "alsamixer" settings in Terminal?
Have you tryed via Terminal to play a short *.wav sound file with alsa?
Have you controlled this too with Earspeaker?

And too: Have you loadet the needet packages for alsa?

Bodhi is a little bit different to ather Linux in time of first installing.
Bodhi is minimalistic and the User can after the first installation loading, what is needet.

You can "manipulation" the alsa via Terminal-Single-Comando, I tryed this and this was very fine.
With the ANSI-alsamixer are not all settings possible. (ANSI was the GUI in simple DOS, I do not know the word for Linux).

#6 Machster28

Machster28

    Member

  • Members
  • 5 posts

Posted 12 September 2011 - 10:33 PM

Hi Machster28,
is this your first Linux on Mac??

Have you controlled the "alsamixer" settings in Terminal?
Have you tryed via Terminal to play a short *.wav sound file with alsa?
Have you controlled this too with Earspeaker?

And too: Have you loadet the needet packages for alsa?

Bodhi is a little bit different to ather Linux in time of first installing.
Bodhi is minimalistic and the User can after the first installation loading, what is needet.

You can "manipulation" the alsa via Terminal-Single-Comando, I tryed this and this was very fine.
With the ANSI-alsamixer are not all settings possible. (ANSI was the GUI in simple DOS, I do not know the word for Linux).



I've Installed many linux.
alsamixer settings are ok in terminal.

asla-utils installed, but I'm not an expert on sound, which I still don't have.

Thanks.

#7 airbrushwerx

airbrushwerx

    Member

  • Members
  • 64 posts

Posted 13 September 2011 - 12:57 AM

Although, this is old, it might help:
http://forums.opensu...1-2-64-bit.html

#8 Jeff

Jeff

    Lead Developer

  • Developer
  • 12493 posts
  • LocationBloomington, IL

Posted 13 September 2011 - 03:06 AM

Might be worth trying to install pulseaudio and the gnome mixer (after disabling the E mixer of course)

~Jeff

#9 Machster28

Machster28

    Member

  • Members
  • 5 posts

Posted 13 September 2011 - 03:44 AM

Might be worth trying to install pulseaudio and the gnome mixer (after disabling the E mixer of course)

~Jeff


Hi Jeff.

I'll give it a try and report back. I am confused about the E mixer though. I assume you mean the mixer @ settings->Extensions->Mixer. Right now it says Card: Intel 82801AA-ICH but I don't see any way of disabling it.

edit: Nevermind, I think I found it in the module settings menu. There I can unload it.

#10 Jeff

Jeff

    Lead Developer

  • Developer
  • 12493 posts
  • LocationBloomington, IL

Posted 13 September 2011 - 04:15 AM

Just right click on the mixer gadget and hit remove.

~Jeff

#11 Joe

Joe

    Member

  • Members
  • 6 posts

Posted 13 September 2011 - 05:00 AM

Hi DJ.

The boot screen states 2.6.x kernel with both 1.2 and 1.1. But anyway I grabbed the v1.1 iso and installed. No change , still without sound with the LiveCD and the HD install.

Thanks.


I've installed Bodhi 1.2.0 directly onto a separate partition on this macbook pro 3.1 and I'm using rEFIt to multi-boot. If it helps any of the more advanced users reading this thread, I've also got Ubuntu 11.04 installed and it only took one small tweak to get the audio working. All I had to do was edit the /etc/modprobe.d/alsa-base.conf file and add this line to the options section:

options snd-hda-intel power_save=10 power_save_controller=N model=mbp3

I rebooted and sound has worked great ever since. This is the only distro and the only time I've ever had audio working in Linux on this Macbook Pro.

I'll do any tests or provide more data if anyone needs me to but please be specific.

Thanks,
Joe

#12 Joe

Joe

    Member

  • Members
  • 6 posts

Posted 13 September 2011 - 06:14 AM

Okay, I've got sound working in Bodhi Linux 1.2.0 running on a Macbook Pro 3,1. I used the modified alsa-base.conf file from Ubuntu 11.04 installed on this computer. You can copy the actual file or like me, copy the contents into a text file at /etc/modprobe.d/alsa-base.conf. Then I rebooted and sound was working. You probably don't even need to reboot but I don't know how to restart alsa in Bodhi.

Here is the contents of my /etc/modprobe.d/alsa-base.conf file:

-------------------------------------------------

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-hda-intel power_save=10 power_save_controller=N model=mbp3

# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

-------------------------------------------------

I believe the key line is the last line of the options section but there may be more to it than that. Maybe someone here can figure out what's important for Bodhi and what's not necessary.

I hope this helps other Macbook Pro users because it is really fun to have sound working while using Bodhi on my Mac laptop.

Good luck,
Joe

#13 real

real

    Member

  • Members
  • 56 posts
  • LocationBodh Gaya.

Posted 13 September 2011 - 08:32 AM

Okay, I've got sound working in Bodhi Linux 1.2.0 running on a Macbook Pro 3,1. I used the modified alsa-base.conf file from Ubuntu 11.04 installed on this computer. You can copy the actual file or like me, copy the contents into a text file at /etc/modprobe.d/alsa-base.conf. Then I rebooted and sound was working.




Hi joe,
You have done , well.
for your information, i would like to say that,
Although , Bodhi is ubuntu-based.
but, for the speciality of Bodhi-minimalism, Many of the neccessary files & configurations of ubuntu
have been removed from Bodhi linux-setup.

#14 Machster28

Machster28

    Member

  • Members
  • 5 posts

Posted 15 September 2011 - 03:35 AM

Thanks Joe. Glad you got it working.

Unfortunately, your config file didn't work for me. But that gave me an idea that I could try a config file from another Ubuntu based vm I had already installed that had audio working. Sorry to say that this did not work either. Tried it with both Bodhi versions 1.1 and 1.2 on VMware and VirtualBox. Oh well, back to the old drawing board...




9-19-11 Update for those following in my path. I have gotten audio to work in VirtualBox setup by changing the audio controller in the VB audio setting from the standard ICH AC97 to Intel HD, which is name of the MBP audio device. VMware, of which I am more familiar, has no such setting and I have not been able to get sound working in it.

Edited by Machster28, 20 September 2011 - 12:18 AM.


#15 aeonius

aeonius

    Lord of the Website

  • Administrators
  • 2644 posts
  • LocationThe Netherlands

Posted 12 December 2011 - 06:33 PM

Have to thank you Joe,

your fix works great for me! Massive kudos! =)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users