Bodhi Linux Forums: [SOLVED] Left Handed Mouse - Bodhi Linux Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

[SOLVED] Left Handed Mouse Is there any way to use a mouse with the left hand?

#1 User is offline   ted_uk 

  • Member
  • Group: Members
  • Posts: 14
  • Joined: 06-October 11

Posted 09 November 2011 - 09:39 PM

Dear All,
I am a newbie to Bodhi and Enlightenment. The setting for the mouse hand in 1.2.1 is broken, and does not do anything. Is there any way to configure Enlightenment manually to use the mouse with the left hand?
Best wishes,
Ted
0

#2 User is offline   KlingKlangMan 

  • Member
  • Group: Members
  • Posts: 186
  • Joined: 25-March 11
  • LocationHertfordshire, UK.

Posted 09 November 2011 - 09:59 PM

I use my left hand for the mouse, but I've always kept the buttons as standard (primary click=left, secondary=right). I've been told that I'm weird, though ;)
This is a Signature. It is here to give you something to read after the end of the post.
0

#3 User is offline   ted_uk 

  • Member
  • Group: Members
  • Posts: 14
  • Joined: 06-October 11

Posted 09 November 2011 - 10:02 PM

View PostKlingKlangMan, on 09 November 2011 - 09:59 PM, said:

I use my left hand for the mouse, but I've always kept the buttons as standard (primary click=left, secondary=right). I've been told that I'm weird, though ;)


Dear KlingKlangMan,
I think that I may be forced to do what your doing, but it's going to take a long time to reverse the habits of twenty years!
Best wishes,
Ted
0

#4 User is offline   KlingKlangMan 

  • Member
  • Group: Members
  • Posts: 186
  • Joined: 25-March 11
  • LocationHertfordshire, UK.

Posted 09 November 2011 - 10:26 PM

I hope someone else on here can be more help, Ted.
This is a Signature. It is here to give you something to read after the end of the post.
0

#5 User is offline   hippytaff 

  • Member
  • Group: Members
  • Posts: 1191
  • Joined: 15-April 11
  • LocationWales, UK

Posted 09 November 2011 - 10:36 PM

Hi Ted-UK

Have you tried going to Settings -> Settings Panel -> input -> mouse, and changing the hand (to left handed)

Cheers
Hippytaff
0

#6 User is offline   ted_uk 

  • Member
  • Group: Members
  • Posts: 14
  • Joined: 06-October 11

Posted 09 November 2011 - 11:16 PM

View Posthippytaff, on 09 November 2011 - 10:36 PM, said:

Hi Ted-UK

Have you tried going to Settings -> Settings Panel -> input -> mouse, and changing the hand (to left handed)

Cheers
Hippytaff


Dear Hippytaff,
many thanks for your reply. Yes, I have tried that, and it does nothing. Have you got it to work?
Best wishes,
Ted
0

#7 User is offline   Duma 

  • Artist
  • Group: Members
  • Posts: 2133
  • Joined: 20-February 11
  • LocationRivalta (TO) - Italia

Posted 09 November 2011 - 11:26 PM

mine don't change nothing. maybe could be notified by E developer?
Se sei italiano e interessato a Linux, clicca qui!
0

#8 User is offline   hippytaff 

  • Member
  • Group: Members
  • Posts: 1191
  • Joined: 15-April 11
  • LocationWales, UK

Posted 09 November 2011 - 11:55 PM

No i havent tried it. Will when i get back to my machine. If someone else can confirm in tje mean time that it doesnt work...cool
0

#9 User is offline   Hendra 

  • Member
  • Group: Members
  • Posts: 648
  • Joined: 17-April 11
  • LocationBalikpapan City, East Borneo, Indonesia

Posted 10 November 2011 - 07:00 AM

Give it a try. Nope, not working.

I found a way using script.

open leafpad, paste following lines
#!/bin/bash
xmodmap -e "pointer = 3 2 1";


save it in your home folder as left_handed_mouse.sh

now open terminal, run followind command
chmod +x ./left_handed_mouse.sh


test it by running in terminal
./left_handed_mouse.sh


if it swap your mouse, you're good

if you want it, you can add this script at startup.
If you want to return it to right handed, change
#!/bin/bash
xmodmap -e "pointer = 3 2 1";

to
#!/bin/bash
xmodmap -e "pointer = 1 2 3";


good luck
0

#10 User is offline   hippytaff 

  • Member
  • Group: Members
  • Posts: 1191
  • Joined: 15-April 11
  • LocationWales, UK

Posted 10 November 2011 - 08:34 AM

Nice script hendre. Tou could add the line to the exec part of a deskrop file and have that run at startup
0

#11 User is offline   Hendra 

  • Member
  • Group: Members
  • Posts: 648
  • Joined: 17-April 11
  • LocationBalikpapan City, East Borneo, Indonesia

Posted 10 November 2011 - 08:52 AM

Now that's my problem hippytaff. I don't have firm linux basic.
That script is something I found when googling. I thought I would need it later.

If I'm running Ubuntu, I would copy this script to /etc/init.d
by running
sudo cp ./left_handed_mouse.sh /etc/init.d

and it will be called on startup

I wonder if this method works with Bodhi,
since when someone asked about startup, no one answer it this way
0

#12 User is offline   hippytaff 

  • Member
  • Group: Members
  • Posts: 1191
  • Joined: 15-April 11
  • LocationWales, UK

Posted 10 November 2011 - 09:38 AM

Duma

This is how I would do it. You can either get exec in the desktop file to point at your sctipt, or just add the commands to the exec: bit.

Cheers
Hippytaff
0

#13 User is offline   Duma 

  • Artist
  • Group: Members
  • Posts: 2133
  • Joined: 20-February 11
  • LocationRivalta (TO) - Italia

Posted 10 November 2011 - 09:45 AM

View Posthippytaff, on 10 November 2011 - 09:38 AM, said:

Duma

This is how I would do it. You can either get exec in the desktop file to point at your sctipt, or just add the commands to the exec: bit.

Cheers
Hippytaff

Yes is possible, but why you tell me? :D
Se sei italiano e interessato a Linux, clicca qui!
0

#14 User is offline   hippytaff 

  • Member
  • Group: Members
  • Posts: 1191
  • Joined: 15-April 11
  • LocationWales, UK

Posted 10 November 2011 - 10:32 AM

View PostDuma, on 10 November 2011 - 09:45 AM, said:

Yes is possible, but why you tell me? :D

Sorry. Was meant for hendre >•<
0

#15 User is offline   Duma 

  • Artist
  • Group: Members
  • Posts: 2133
  • Joined: 20-February 11
  • LocationRivalta (TO) - Italia

Posted 10 November 2011 - 10:49 AM

no problem ;)
Se sei italiano e interessato a Linux, clicca qui!
0

#16 User is offline   Hendra 

  • Member
  • Group: Members
  • Posts: 648
  • Joined: 17-April 11
  • LocationBalikpapan City, East Borneo, Indonesia

Posted 10 November 2011 - 10:57 AM

:D BTW I have question

Do startup application entry run before we login?
because if it don't and we don't use auto-login,
that means mouse will be in right-hand-mode at login screen right?
0

#17 User is offline   Duma 

  • Artist
  • Group: Members
  • Posts: 2133
  • Joined: 20-February 11
  • LocationRivalta (TO) - Italia

Posted 10 November 2011 - 11:02 AM

I think could be more "level" of autologin.

If you use Settings -> Applications -> Startup applications to load it, of course yes: in fact E17 manage this apps, so if you don't load it(and you don't load it until you make a login), app doesn't start.
Maybe using init.d or similar stuff you could have an application launched before the login, but i don't know.
Se sei italiano e interessato a Linux, clicca qui!
0

#18 User is offline   ted_uk 

  • Member
  • Group: Members
  • Posts: 14
  • Joined: 06-October 11

Posted 17 November 2011 - 06:53 PM

Dear All,
many thanks for your helpful suggestions. I have been a bit tied-up for the last few days, and I have only just got round to posting.

The script that Hendra suggested works fine, and after execution, the mouse is now left handed.
It took me quite a while to find out how to add the script to the startup applications, but using the information provided by hippytaff at:-
"http://wiki.bodhilinux.com/doku.php?id=startup_commands&s[]=startup&s[]=script"
I created the file "~/left_handed_mouse.desktop" containing:-

"[Desktop Entry]
Name=left_handed_mouse
Comment=Sets the mouse as left handed
Exec=/home/ted/left_handed_mouse.sh
Icon=false
NoDisplay=false
Terminal=false
Type=Application
Categories=
StartupNotify=true"

copied it to /usr/share/applications

sudo cp left_handed_mouse.desktop /usr/share/applications

and changed the permissions

sudo chmod +x /usr/share/applications/left_handed_mouse.desktop

This works very well.
Thank you all for your kind help.
Ted
0

#19 User is offline   Duma 

  • Artist
  • Group: Members
  • Posts: 2133
  • Joined: 20-February 11
  • LocationRivalta (TO) - Italia

Posted 17 November 2011 - 07:00 PM

You're welcome and enjoy Bodhi!
Could you mark your topic solved if is solved?
Se sei italiano e interessato a Linux, clicca qui!
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users