Jump to content

Photo

DNS issues on Bodhi 2.0 [Solved]


  • Please log in to reply
1 reply to this topic

#1 Devlin7

Devlin7

    Member

  • Members
  • 119 posts

Posted 03 August 2012 - 08:32 AM

Hi,

I have been testing Bodhi 2.0 on a crappy old laptop and loving it!!! The other night, I ran sudo apt-get update/upgrade and noticed some "bind" changes coming down. I then shut the computer down. The next day I couldn't surf the web at all. DNS name resolution was broken. I noticed that /etc/resolv.conf was missing. I also noticed the error "resolvconf: Error /etc/resolv.conf isn't a symlink". I then googled this error and got a few webpages pointing several issues with the new dns resolution on Ubuntu.

TO cut a long story short.

sudo dpkg-reconfigure resolvconf recreated the resolv.conf symlink
I then had to edit /etc/resolvconf/resolv.conf.d/base and manually add my nameserver options [It seems that the dns options supplied by DHCP on my wireless link don't make it into the laptop. Even adding DNS options manually on the network connection made no difference.

My base file now contains
nameserver 208.67.220.220
nameserver 208.67.222.222

A reboot then fixed it for me.

To be honest, I am not sure why it broke. This is a vanilla install of Bodhi, I haven't added any additional repositories or anything out of the ordinary.

Just happy to see it working again :-)



A big thank you to everyone who contributes to Bodhi Linux


#2 irvine

irvine

    Member

  • Members
  • 31 posts
  • LocationBreda, Netherlands

Posted 12 August 2012 - 10:21 AM

sudo dpkg-reconfigure resolvconf recreated the resolv.conf symlink

Thanks Devlin!

Didn't need to edit any file here.
Running the following command and answering 'yes' to everything solved it:

sudo dpkg-reconfigure resolvconf





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users