Bodhi Linux Forums: Fix: Touchpad on Alpha Image - Bodhi Linux Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Fix: Touchpad on Alpha Image sens and tapping

#1 User is offline   and.rew 

  • Member
  • Group: Members
  • Posts: 23
  • Joined: 30-December 12

Posted 31 December 2012 - 12:13 AM

Managed to get it more sensitive with:
Blog Entry

Excerpt:

14. The touchpad requires an additional configuration file called 50-touchpad.conf placed into /etc/X11/xorg.conf.d/ Using your preferred text editor create the required file

So, run as a rootskript:
 
#!/bin/bash
cat << xXx > etc/X11/xorg.conf.d/50-touchpad.conf
Section "InputClass"
Identifier "touchpad"
MatchIsTouchpad "on"
Option "FingerHigh" "5"
Option "FingerLow" "5"
#Add the following for tap-to-click,doubletap-to-rightclick:
Option "TapButton1" "1"
Option "TapButton2" "2"
Option "TapButton3" "3"
EndSection
xXx

0

#2 User is offline   Jeff 

  • Project Advisor
  • Group: Developer
  • Posts: 9691
  • Joined: 23-November 10
  • LocationBloomington, IL

Posted 31 December 2012 - 02:06 AM

I'm going to try this ASAP! The current state of the track pad has been at the top of my "to fix" list as it is really bad in it's current state.

Thanks for sharing.

~Jeff
0

#3 User is offline   AntCer 

  • Has the Python Fu
  • Group: Moderators
  • Posts: 1174
  • Joined: 06-August 12
  • Location92324

Posted 31 December 2012 - 03:13 AM

Can you please write your instructions a bit more clearly. Can't understand what to put. Using the quote or code tags would be super helpful! Thank you for the touchpad adjustment, of course!
Bodhi QuickStart Index Page -- Updates are automatically viewable via link. Take a couple seconds to view. ;)
0

#4 User is offline   and.rew 

  • Member
  • Group: Members
  • Posts: 23
  • Joined: 30-December 12

Posted 31 December 2012 - 04:50 AM

View PostAntCer, on 31 December 2012 - 03:13 AM, said:

Can you please write your instructions a bit more clearly. Can't understand what to put. Using the quote or code tags would be super helpful! Thank you for the touchpad adjustment, of course!

I formatted as a skriptsnippet, now. Plz test and feedback!
0

#5 User is offline   Jeff 

  • Project Advisor
  • Group: Developer
  • Posts: 9691
  • Joined: 23-November 10
  • LocationBloomington, IL

Posted 31 December 2012 - 04:54 AM

Does the "double tap to right click" work for you?

Tap to click works here, but the double tap does not.

~Jeff
0

#6 User is offline   AntCer 

  • Has the Python Fu
  • Group: Moderators
  • Posts: 1174
  • Joined: 06-August 12
  • Location92324

Posted 31 December 2012 - 09:59 AM

View PostJeff, on 31 December 2012 - 04:54 AM, said:

Does the "double tap to right click" work for you?

Tap to click works here, but the double tap does not.

~Jeff

Double tap doesn't seem to work here, as well.
Bodhi QuickStart Index Page -- Updates are automatically viewable via link. Take a couple seconds to view. ;)
0

#7 User is offline   cxexa 

  • Member
  • Group: Members
  • Posts: 1
  • Joined: 01-January 13

Posted 01 January 2013 - 07:59 PM

For a two-finger tap to act as a right-click, I think you need to make the following change.

Option "TapButton2" "3"


You can also change the middle-click behavior if you choose, as shown below.

Option "TapButton3" "2" - three-finger tap as a middle-click
0

#8 User is offline   bob rashkin 

  • Member
  • Group: Members
  • Posts: 356
  • Joined: 30-January 12
  • Location26.13069N,97.63676W

Posted 02 January 2013 - 05:28 PM

Just to be clear for those of us who aren't "cat"-conversant, the instruction is to create a file: /etc/X11/xorg.conf.d/ 50-touchpad.conf that is exactly the following.
Section "InputClass"
Identifier "touchpad"
MatchIsTouchpad "on"
Option "FingerHigh" "5"
Option "FingerLow" "5"
#Add the following for tap-to-click,doubletap-to-rightclick:
Option "TapButton1" "1"
Option "TapButton2" "2"
Option "TapButton3" "3"
EndSection

Is that right?
Bob Rashkin
0

#9 User is offline   Jeff 

  • Project Advisor
  • Group: Developer
  • Posts: 9691
  • Joined: 23-November 10
  • LocationBloomington, IL

Posted 02 January 2013 - 06:47 PM

As a heads up I uploaded a new chromebook image last night - so if you use our automatic installer script this trackpad improvement is now implemented by default.

~Jeff
0

#10 User is offline   bob rashkin 

  • Member
  • Group: Members
  • Posts: 356
  • Joined: 30-January 12
  • Location26.13069N,97.63676W

Posted 02 January 2013 - 07:31 PM

Good to know. Thanks. Amazon claims my Chromebook will arrive tomorrow (1/3).
Bob Rashkin
0

#11 User is offline   theoctagon 

  • Member
  • Group: Members
  • Posts: 4
  • Joined: 08-March 13

Posted 08 March 2013 - 12:17 PM

Is there an easy way to disable and reenable touchpad input? I find the touchpad input in Bodhi awkward, so I'm using an external trackball. While typing, the bases of my thumbs often accidentally brush the touchpad, repositioning the caret in unwanted places. So while using an external input device, I would like to be able to disable the touchpad (but also be able to reenable it easily if I am on the move and don't have a trackball or mouse with me). I see some touchpad settings under Settings > All > Input > Touch, but no simple "Disable" option.
0

#12 User is offline   Jeff 

  • Project Advisor
  • Group: Developer
  • Posts: 9691
  • Joined: 23-November 10
  • LocationBloomington, IL

Posted 08 March 2013 - 02:23 PM

Alas ARM hardware being the nightmare that it is I haven't found a simple way to disable to touch pad through a toggle on the chromebook to date.

~Jeff
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users