Jump to content

Photo

How to change default screen resolution?


  • Please log in to reply
3 replies to this topic

#1 cyber2200

cyber2200

    Member

  • Members
  • 1 posts

Posted 04 May 2013 - 09:53 AM

When my system is booting normally and I run xrandr I'm getting the following output:
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 4096 x 4096
VGA1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
1024x768 60.0*
800x600 60.3 56.2
848x480 60.0
640x480 59.9

However, I want my resolution to be 1366x768, so I'm using the following commands:
cvt 1366x768
xrandr --newmode "1368x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync
xrandr --addmode VGA1 1368x768_60.00
xrandr --output VGA1 --mode 1368x768_60.00

How can I make it permanent?
I tried to add those commands to /etc/lxdm/LoginReady with no sake, it only added the option to xrandr list and Enlightenment ir still ignoring the option..

Thanks a lot in advance..



A big thank you to everyone who contributes to Bodhi Linux


#2 HakerDefo

HakerDefo

    Member

  • Members
  • 282 posts
  • LocationIndia

Posted 04 May 2013 - 10:42 AM

Hello cyber2200!

Open leafpad and copy-paste the following,

#!/bin/bash
xrandr --newmode "1368x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync
xrandr --addmode VGA1 1368x768_60.00
xrandr --output VGA1 --mode 1368x768_60.00

Save this script in '~/.local/share/applications' directory with the name 'resolution.sh'

Open terminal and run the following command to make the above script executable,

chmod a+x ~/.local/share/applications/resolution.sh

Now create a .desktop file to help run the above script at startup

In leafpad copy-paste the following

[Desktop Entry]
Version=1.0
Name=resolution changer
Comment=auto changes the resolution
Exec=~/.local/share/applications/resolution.sh
Icon=
Type=Application
Categories=Settings;
NoDisplay=false

Save this file in '~/.local/share/applications' and name it resolution.desktop

Go to Main Menu -> Settings -> Settings Panel -> Apps -> Startup Applications -> Applications and add 'resolution' to the list of startup apps. If you don't see 'resolution' there just restart enlightenment and it will appear there. If you don't want 'resolution' to appear in your main menu after this just change 'NoDisplay=false' in your 'resolution.desktop' file to 'NoDisplay=true'

That's it!!!

Cheers!!!

#3 Jeff

Jeff

    Lead Developer

  • Developer
  • 12582 posts
  • LocationBloomington, IL

Posted 06 May 2013 - 12:50 AM

Welcome to the boards. More information on startup commands can be found here -> http://wiki.bodhilin...tartup_commands

~Jeff

#4 moumin

moumin

    Member

  • Members
  • 6 posts

Posted 06 May 2013 - 08:22 PM

Hello cyber2200!

Open leafpad and copy-paste the following,

#!/bin/bash
xrandr --newmode "1368x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync
xrandr --addmode VGA1 1368x768_60.00
xrandr --output VGA1 --mode 1368x768_60.00

Save this script in '~/.local/share/applications' directory with the name 'resolution.sh'

there is no application folder, and no luck in making one or saving the file to anywhere else but desktop.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users