Jump to content

Photo

[SOLVED] Dell mini910 Wireless NOT working


  • Please log in to reply
11 replies to this topic

#1 theindianofthegroup

theindianofthegroup

    Member

  • Members
  • 11 posts
  • LocationBloomington, IN

Posted 31 August 2013 - 12:51 AM

Just today I made a live bodhi USB after being intrigued by the name, hooked by the description, and then toppling head over heels when running it from the USB for the first time!!! I have been runing ubuntu for about three years now, but it seems I was always getting warnings about having less than 250mb of memory...yet another reason I am excited about bodhi!

However, I cannot seem to get the wireless card working!?!? I have installed ubuntu several times, and after installation there is always a promt which gets my wireless up and running; so it seems I should be able to with bodhi as well, but I am still a noob when it comes to troubleshooting and doing things without a GUI. I do use terminal often, but I also often 'copy and paste' the solutions I find on the internet...I just cant seem to find any solutions for this issue!

Please HELP!!!!!

(I have already installed and ran 'rfkill list' and 'rfkill unblock all'...even though nothing showed blocked on the lists...)
Reality is only a Rorschach ink-blot, you know. -Alan Watts



A big thank you to everyone who contributes to Bodhi Linux


#2 Twilight_Genesis

Twilight_Genesis

    Member

  • Members
  • 344 posts
  • LocationMissouri, USA

Posted 31 August 2013 - 04:35 AM

Can you please post the output of
lspci | grep -i network
so we can know what kind of wireless card we're dealing with?
Please send all complaints to /dev/null

#3 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4560 posts
  • LocationZeist, The Netherlands

Posted 31 August 2013 - 10:01 AM

Maybe it is a matter of activating the network-manager.
On the live CD for some obscure reason the autostart function does not work properly, so you have to do it manually.

Hit WIN + Space key to open Everything and type network. The launcher will be highlighted, just hit ENTER and it will start.
You will have an icon in the systray where you can left-click to select an AP and connect. Or rightclick to edit settings for your connections.

Please let us know how you are progressing, one way or another.

Welcome to the forums btw.

Enjoy,
Charles.

#4 theindianofthegroup

theindianofthegroup

    Member

  • Members
  • 11 posts
  • LocationBloomington, IN

Posted 31 August 2013 - 07:12 PM

03:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)


This is what ' lspcplspci | grep -i network ' produced.

I also checked the network-manager and it runs at start up as it should.

Thanks again for the help!!
Reality is only a Rorschach ink-blot, you know. -Alan Watts

#5 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4560 posts
  • LocationZeist, The Netherlands

Posted 31 August 2013 - 08:26 PM

I don't have that chip myself but for some other users the following worked. I presume you are connected by wire now.

To get your wireless device BCM 4312_LP-PHY pci-id 14e4:4315 to work.

Needs firmware using a package from the repos
Needs driver using a package from the repos (bodhi-packed version)
The driver package needs the kernel headers installed.

Commands in terminal:
sudo apt-get update && sudo apt-get install linux-headers-$(uname -r)
sudo apt-get install firmware-b43-lpphy-installer
sudo apt-get --reinstall install bcmwl-kernel-source=5.100.82.112+bdcom-0ubuntu3

Now you have to remove all loaded broadcom related modules and insert the new one so you can test it.
sudo modprobe -r b43 ssb wl brcmfmac brcmsmac bcma
sudo modprobe wl

Now you can test if things work using the nm-applet. It may take a few seconds to scan for networks. So take some time before trying to connect to your AP.

To avoid conflicting drivers to load at boot you should have those blacklisted. Usually the bcmwl package takes care of that, otherwise you have to do it manually:
echo "blacklist drivername" | sudo tee -a /etc/modprobe.d/blacklist-broadcom-wireless.conf
Replace drivername with the actual name of the driver p.e. b43

After changing a blacklist file you should run
sudo update-initramfs -u
to take effect.

Finally to prevent the bcmwl-kernel-source package getting updated you should run
sudo apt-get install --no-upgrade bcmwl-kernel-source

The trick in this is that you need an older version of bcmwl as the newer one seems not to work for your wifi anymore.

Enjoy,
Charles.

#6 theindianofthegroup

theindianofthegroup

    Member

  • Members
  • 11 posts
  • LocationBloomington, IN

Posted 31 August 2013 - 09:51 PM

I ran the first 5 commands and the wireless is working now!!!!! However, after running ' sudo apt-get --reinstall install bcmwl-kernel-source=5.100.82.112+bdcom-0ubuntu3 ' I get this...

root@alpha-Inspiron-910:~# sudo apt-get --reinstall install bcmwl-kernel-source=5.100.82.112+bdcom-0ubuntu3
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be DOWNGRADED:
bcmwl-kernel-source
0 upgraded, 0 newly installed, 1 downgraded, 0 to remove and 0 not upgraded.
Need to get 0 B/1,150 kB of archives.
After this operation, 536 kB disk space will be freed.
Do you want to continue [Y/n]? y
dpkg: warning: downgrading bcmwl-kernel-source from 6.20.155.1+bdcom-0ubuntu0.0.1 to 5.100.82.112+bdcom-0ubuntu3.
(Reading database ... 94790 files and directories currently installed.)
Preparing to replace bcmwl-kernel-source 6.20.155.1+bdcom-0ubuntu0.0.1 (using .../bcmwl-kernel-source_5.100.82.112+bdcom-0ubuntu3_i386.deb) ...
Removing all DKMS Modules
Done.
Unpacking replacement bcmwl-kernel-source ...
Setting up bcmwl-kernel-source (5.100.82.112+bdcom-0ubuntu3) ...
Loading new bcmwl-5.100.82.112+bdcom DKMS files...
Building only for 3.8.0-12-generic
Building for architecture i686
Building initial module for 3.8.0-12-generic
Done.

wl:
Running module version sanity check.
- Original module
- No original module exists within this kernel
- Installation
- Installing to /lib/modules/3.8.0-12-generic/updates/dkms/

depmod....

DKMS: install completed.
ERROR: Module b43 does not exist in /proc/modules
ERROR: Module b43legacy does not exist in /proc/modules
ERROR: Module ssb does not exist in /proc/modules
ERROR: Module bcm43xx does not exist in /proc/modules
ERROR: Module brcm80211 does not exist in /proc/modules
ERROR: Module brcmfmac does not exist in /proc/modules
ERROR: Module brcmsmac does not exist in /proc/modules
ERROR: Module bcma does not exist in /proc/modules
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.8.0-12-generic
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169

Is everything ok?
Reality is only a Rorschach ink-blot, you know. -Alan Watts

#7 theindianofthegroup

theindianofthegroup

    Member

  • Members
  • 11 posts
  • LocationBloomington, IN

Posted 31 August 2013 - 09:56 PM

Also, I am a little confused about how to know if these steps are necessary, and where I would find the name of the conflicting drivers...if there are any:

To avoid conflicting drivers to load at boot you should have those blacklisted. Usually the bcmwl package takes care of that, otherwise you have to do it manually:
echo "blacklist drivername" | sudo tee -a /etc/modprobe.d/blacklist-broadcom-wireless.conf

Replace drivername with the actual name of the driver p.e. b43

After changing a blacklist file you should run
sudo update-initramfs -u


Reality is only a Rorschach ink-blot, you know. -Alan Watts

#8 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4560 posts
  • LocationZeist, The Netherlands

Posted 31 August 2013 - 09:57 PM

The errors refer to modules you blacklisted so that's perfect.
The W: stands for a warning, you can safely ignore them.

Congrats, great result, you can mark this as solved. :)

Enjoy,
Charles

#9 theindianofthegroup

theindianofthegroup

    Member

  • Members
  • 11 posts
  • LocationBloomington, IN

Posted 31 August 2013 - 10:16 PM

:D :rolleyes: :D Wow, THANK YOU SO MUCH!!!!!! You are a true Bodhisattva Charles! As stated before, I was wowed from the very beginning; and you have set the tone for my path to enlightenment with Bodhi Linux!!! :rolleyes: :lol: :rolleyes:
Reality is only a Rorschach ink-blot, you know. -Alan Watts

#10 Charles@Bodhi

Charles@Bodhi

    Old Faithful

  • Moderators
  • 4560 posts
  • LocationZeist, The Netherlands

Posted 31 August 2013 - 10:20 PM

The modulenames you want to blacklist are in your previous post where it says ERROR:

If after rebooting everything works hassle-free, there is no need to execute those last commands. Otherwise you need to repeat that line for every drivername that would cause conflicts. Most people want to prevent possible issues and prefer to do it anyway.

Enjoy,
Charles.

#11 theindianofthegroup

theindianofthegroup

    Member

  • Members
  • 11 posts
  • LocationBloomington, IN

Posted 31 August 2013 - 10:46 PM

After reboot everything seems perfect!! Thanks Again!!

Now comes the the fun part - PERSONALIZING BODHI!!!
Reality is only a Rorschach ink-blot, you know. -Alan Watts

#12 rebbi

rebbi

    Silver Member

  • Members
  • 78 posts

Posted 11 June 2014 - 02:56 AM

I don't have that chip myself but for some other users the following worked. I presume you are connected by wire now.

To get your wireless device BCM 4312_LP-PHY pci-id 14e4:4315 to work.

Needs firmware using a package from the repos
Needs driver using a package from the repos (bodhi-packed version)
The driver package needs the kernel headers installed.

Commands in terminal:

sudo apt-get update && sudo apt-get install linux-headers-$(uname -r)
sudo apt-get install firmware-b43-lpphy-installer
sudo apt-get --reinstall install bcmwl-kernel-source=5.100.82.112+bdcom-0ubuntu3

Now you have to remove all loaded broadcom related modules and insert the new one so you can test it.
sudo modprobe -r b43 ssb wl brcmfmac brcmsmac bcma
sudo modprobe wl

Now you can test if things work using the nm-applet. It may take a few seconds to scan for networks. So take some time before trying to connect to your AP.

To avoid conflicting drivers to load at boot you should have those blacklisted. Usually the bcmwl package takes care of that, otherwise you have to do it manually:
echo "blacklist drivername" | sudo tee -a /etc/modprobe.d/blacklist-broadcom-wireless.conf
Replace drivername with the actual name of the driver p.e. b43

After changing a blacklist file you should run
sudo update-initramfs -u
to take effect.

Finally to prevent the bcmwl-kernel-source package getting updated you should run
sudo apt-get install --no-upgrade bcmwl-kernel-source

The trick in this is that you need an older version of bcmwl as the newer one seems not to work for your wifi anymore.

Enjoy,
Charles.


Charles,

Thank you very much for this. It got my wireless working and I'd never have figured it out by myself!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users