Jump to content

Photo

Microphone support on Acer C720


  • Please log in to reply
10 replies to this topic

#1 jmd8800

jmd8800

    Member

  • Members
  • 11 posts

Posted 15 March 2014 - 02:46 AM

I'm trying to configure Skype on an Acer C720. Sound works fine in Skyp on a test call. The built in microphone does not. I have looked at Applications -> Preferences -> Sound. When I choose the Output tab I highlight Built-in Audio Analog Stereo. On the Input tab I have Input volume set to 100%. Connector is microphone . When I speak into the microphone on a Skype test call I get one or two bars in volume. When the test calls replays my voice I can barely hear it.

Speakers work fine on test calls and Youtube. I have tried Logitech Headphones with a microphone with a Y adapter for speakers and microphone. Headphones work in this setup but not microphone.

Any ideas?



A big thank you to everyone who contributes to Bodhi Linux


#2 Jeff

Jeff

    Lead Developer

  • Developer
  • 12547 posts
  • LocationBloomington, IL

Posted 15 March 2014 - 03:01 AM

In your mixer settings do you have your input volume turned all the way up?

~Jeff

#3 jmd8800

jmd8800

    Member

  • Members
  • 11 posts

Posted 15 March 2014 - 03:22 AM

In your mixer settings do you have your input volume turned all the way up?

~Jeff


Yes. As a side note the sliders appear to have little effect on volume output on speakers (using a youtube video to test)

#4 jmd8800

jmd8800

    Member

  • Members
  • 11 posts

Posted 22 March 2014 - 01:10 AM

SOLVED... partially.

It turns out my microphone on the headphones has a short. So when I used the headphones with the Y adapter I could hear sound but no voice in Skype test calls. What threw me off was that I could hear sound through the onboard speakers but the onboard microphone did not work.

Now, with new headphones I can hear sound and the microphone functions with the Y adapter.

:-( But still no onboard mic support. So I'm stuck with using headphones w/microphone for now with Skype.

dmesg shows 5.988625 input:Intel PCH mic as /devices/pci0000:00/0000:00:1b.0/sound/card1/input12... so the computer knows it is there.

I had tried changing the default card for sound to card 1 instead of card 0 (HDA Intel MID which is the HDMI card).

I removed pulseaudio by changing the autospawn setting and by removal. Alsa sound works fine except for the microphone. Now I have pulseaudio reinstalled and working.

At this point I'm guessing this is a faulty microphone.

#5 LogicalDave

LogicalDave

    Member

  • Members
  • 7 posts

Posted 26 September 2014 - 07:48 PM

I have exactly the same issue so I doubt it's a faulty microphone.

SOLVED... partially.

It turns out my microphone on the headphones has a short. So when I used the headphones with the Y adapter I could hear sound but no voice in Skype test calls. What threw me off was that I could hear sound through the onboard speakers but the onboard microphone did not work.

Now, with new headphones I can hear sound and the microphone functions with the Y adapter.

:-( But still no onboard mic support. So I'm stuck with using headphones w/microphone for now with Skype.

dmesg shows 5.988625 input:Intel PCH mic as /devices/pci0000:00/0000:00:1b.0/sound/card1/input12... so the computer knows it is there.

I had tried changing the default card for sound to card 1 instead of card 0 (HDA Intel MID which is the HDMI card).

I removed pulseaudio by changing the autospawn setting and by removal. Alsa sound works fine except for the microphone. Now I have pulseaudio reinstalled and working.

At this point I'm guessing this is a faulty microphone.



#6 Sitting Fox

Sitting Fox

    Member

  • Team
  • 551 posts

Posted 06 October 2014 - 03:00 AM

Hey jmd8800,

I use Bodhi 3 on my C720s and, after a recent update, the microphone stopped working.

I figured out how to get it to work by using pavucontrol. I wonder if that or something similar will work for your case?

However, I seem to have gotten the mic back by installing pavucontrol and going into Input Devices and choosing "Microphone (unplugged)" instead of "Internal Microphone". For some reason, that's the one that works. :lol:



#7 bymbie

bymbie

    Member

  • Members
  • 17 posts

Posted 09 November 2014 - 10:34 PM

Hey jmd8800,

I use Bodhi 3 on my C720s and, after a recent update, the microphone stopped working.

I figured out how to get it to work by using pavucontrol. I wonder if that or something similar will work for your case?


Hi. Could you describe how to get the mic to work? I have the same problem and would like to fix my microphone for Skype. Cheers. ~bymbie

#8 Sitting Fox

Sitting Fox

    Member

  • Team
  • 551 posts

Posted 10 November 2014 - 06:13 PM

Hey bymbie,

I shared what I did in my above post, more details within the quote. If there's a particular part that you're having trouble with, let me know.

It works in 3, but I'm hoping it'll work in 2 too.

#9 bymbie

bymbie

    Member

  • Members
  • 17 posts

Posted 13 November 2014 - 01:43 PM

Hi. I installed pavucontrol, but I only have two option in input devices: internal microphone and microphone. None of those appear to be working.

#10 Deepspeed

Deepspeed

    Sir Creeps-a-lot

  • Developer
  • 543 posts

Posted 13 November 2014 - 06:09 PM

do
sudo alsamixer
in terminal and make sure nothing is muted.

#11 bymbie

bymbie

    Member

  • Members
  • 17 posts

Posted 13 November 2014 - 07:29 PM

Thanks for the support. I will try this. Although I have to re-map my F keys so can't do it right away. I will report back.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users