Jump to content

spankmon

Members
  • Content count

    14
  • Joined

  • Last visited

  • Days Won

    2

spankmon last won the day on December 14 2017

spankmon had the most liked content!

Community Reputation

3 Neutral

About spankmon

  • Rank
    Member

Profile Information

  • Gender
    Not Telling
  • Location
    On a cactus
  1. Every Login, CapsLock Light is On

    birdmun, I agree. Editing one text file would have been my first choice of a fix. That or one small command in a terminal. After taking a closer look in the /etc folder, there are like seven different places where I might edit something... and I don't have a clue. So now that I know why the light is on at login, I kinda like it. Each of you guys should get the best answer acknowledgement, but it was the Waiter's post that put my mind at ease. Thanks all.
  2. Every Login, CapsLock Light is On

    If I am understanding correctly... it looks like the caps lock key is set to the "compose" function, and two clicks returns it to default behavior. This is fine with me. Someday I might learn to compose something beyond my normal line of BS. Thanks for that, theWaiter. Oblio, yeah I miss riding too. Old age takes its toll. My last desert race was in 1987 on a Maico 250. The old Butterfield Trail passed through the desert here, and I used to explore a lot. Found pieces of covered wagons, old bottles, arrowheads, stuff like that.
  3. Every Login, CapsLock Light is On

    Maybe I should have been more precise in my first post. When I login to the Moksha desktop, the capslock light is on. But I'm still typing lower case letters. Two clicks turns off the caps lock light... and after that everything works as expected. I can turn on caps lock again, the light comes on, and I'm now typing upper case letters. It functions normally. So it's really not even a problem. I thought the developers of Bodhi might want to know about it. This has never happened to me during ten years of distro-hopping. I've now learned to use setleds, but they don't work for the graphical desktop... they only work in the console. And that's not any solution because the caps lock light issue only shows up when I log in to Moksha desktop. I can log out, then login to the alternate openbox session and the caps lock light is off, as expected. So this is an issue only with the Moksha desktop... and not really an issue at all. I do appreciate very much the help you guys have offered.
  4. Every Login, CapsLock Light is On

    It looks like the -L doesn't stick through reboots. I'll get back on this thang tomorrow. Thanks for the help Oblio. EDIT: setleds -L -caps just turns off the led for the tty I'm currently in, regardless of whether caps lock is on or off. I'm using the wrong command. EDIT2: these settings only work for the console. I can't figure how to make them work for the graphical desktop.
  5. Every Login, CapsLock Light is On

    I go into tty1 and enter "setleds -L -caps" and the command is accepted. Then I reboot, login back to my desktop and nothing has changed. That command was supposed to return the caps lock back to its default state (I think). The article DOOMguy linked says I can make an entry in the /etc/rc file... I don't have a /etc/rc file. There is, however, an /etc/rc.local file that is executable. When I open the file in a text editor, the file has a warning that the script does absolutely nothing.
  6. Every Login, CapsLock Light is On

    ok, DOOMguy. I think I understand what setleds does. I'll give it a try. Surely I couldn't mess anything up. If I do, I'll get bitchslapped by my wife. EDIT: I don't know how to apply this to the desktop.
  7. Each time I log in to Bodhi the caps lock light on the keyboard is activated. But caps lock is not really activated... I'm still typing in lower case fonts. Also, I need to click twice to turn off the caps lock light. I tried switching to the Bodhi green theme and it still happens. So I guess it's not theme related. Just a minor annoyance, but I'm curious as to why it happens. It does not happen when I log in to an openbox session.
  8. Auto Start Works for Some Apps, Not Others

    I don't know if this is related, but every time I log in to Bodhi the caps lock light on the keyboard is activated... even though caps lock is not really activated... and I have to click it twice to turn it off. I switched to the Bodhi green theme and it still happens.
  9. Auto Start Works for Some Apps, Not Others

    This is the working code from .e/e/applications/startup/startupapplications. Both lines were added with a text editor. sh -c 'compton -b &' | \ xscreensaver The other applications which I have on startup were added with the "startup applications" tab of Swami. They are cairo-dock, redshift and conky. Conky was picked up by the gui search (normally it wouldn't be) because, somehow, I added a launcher to the Main Menu apps "Other" section. I don't remember how I added the launcher to the menu, something about a custom personal menu. So I didn't need to add conky as a command. And these are the entries that were added with Swami that didn't work. This is how it showed up in the file, but the "and" symbol had been typed correctly in the Swami text box. This was before I had read the thread that solved my problem. I had also previously tried just adding "compton" in the Swami command and it didn't work either. It showed up in the file without the pipe slash. xscreensaver | \ compton -b &
  10. Auto Start Works for Some Apps, Not Others

    Thanks, The waiter. That thread was the solution for me. I needed to add... sh -c 'compton -b &' ...to the .e/e/applications/startup/startupcommands file as the FIRST entry of the file. If I add the command through the Swami gui, it modifies the command and won't work. So it needs to be added to the file directly. I love frying my brain attempting to fix things that are way above my level of expertise. Thanks again.
  11. Auto Start Works for Some Apps, Not Others

    Thanks for the reply Jeff. I've tried several different ways to get compton to auto start using the Swami settings mgr. If I use the "applications search" it can't find Compton. When I use the command it will add the command ok, but still won't auto start Compton. I've tried the command compton -b and it still won't auto start. I've noticed that after adding the command, the file ".e/e/applications/startup/startupcommands" doesn't have the "| \" at the end which the other commands do have... so I tried adding that bit and Compton still won't auto start. I've also tried adding the command with the full path to /usr/bin/compton and still no luck. Also tried with the -b and the pipe slash. I have no problem starting compton after I log in... both with a terminal and a launcher using only the "compton" command. I've also tried removing all the other startup apps and using only compton, in case there was some sort of conflict. Still didn't work. The Swami gui works with all the other startup apps that are added.
  12. The apps that I want to autostart on login are xscreensaver, conky, cairo-dock, redshift and compton. I've found three different autostart methods here on the forum and within the settings menu... and managed to get conky, cairo-dock, and xscreensaver to autostart. But nothing works for redshift or compton. Now, I'm not even sure which startup method was the one that did work because I have left all three methods activated (two different startup gui's in the Moksha menu, and editing the file in .e/e/applications folder). For now I have created launchers so I can start them after logging in, but would really prefer them to auto-start. This is on a desktop PC with nvidia gtx 760 graphics card and the 375 proprietary drivers. I have also installed the compton-conf so I can actually adjust transparency etc., but it doesn't offer any option for autostart. Thanks. EDIT: I finally got redshift to work on startup, but not compton.
  13. Change Menu Opening from L-click to R-click

    That was quick and easy. Thanks Jeff. I'm really loving this latest release of Bodhi.
  14. I've been using Openbox for years and am accustomed to right clicking the mouse for the apps menu to open. I've just installed Bodhi and love it, but would like to change the menu access from left-click to right-click. How can I do this? Thanks.
×