Jump to content
Sign in to follow this  
Jeff

Name ideas for a PDF Viewer

Recommended Posts

Fair warning the gitcha branch may come with some stability issues, ect. ect.

 

There is a reason packages are there and not in main :)

 

I'll say...wha it has broken my system... what is the command to uninstall them? eeVee will not launch nor will exterminator or synaptic etc... lol

Share this post


Link to post
Share on other sites

You will need to manually download older versions of whatever packages you updated.

 

For reference I have gitcha running on my daily laptop without issues and both my test VMs also work as expected with it.

Share this post


Link to post
Share on other sites

You will need to manually download older versions of whatever packages you updated.

 

For reference I have gitcha running on my daily laptop without issues and both my test VMs also work as expected with it.

 

Its all good. I was wanting to do a clean install anyways. :-) Backing up my data now.

Share this post


Link to post
Share on other sites

The py-elm-application developer Kuuko has baked a pdf viewer!

Here's the announce on E-devel Mailing List:

Yes, it's another Python app. Try it.

(sudo) pip install Lekha
or download:

https://pypi.python.org/packages/source/L/Lekha/Lekha-0.2.0.tar.gz

and untar, cd Lekha-0.2.0, (sudo) python setup.py install

 

Dependencies:

  • Python 2
  • PyPDF2
  • pyxdg
  • python-efl >=1.14
Features:
  • PDF rendering (with evas images, so no editable form fields or anything fancy)
  • PDF bookmarks (outlines)
  • opens files in multiple tabs, and from command line
  • remembers scroll position for every document
No pants were ruined in the making of this software.

 

  • Like 2

Share this post


Link to post
Share on other sites

Yes - Kuuko and I had gone back and forth on ideas and he ended up cooking up a custom thing for displaying PDFs as images.

 

Some day in a far off land when the E team finally fixes all the crashes we have with new versions of EFL - we will get it into the stable Bodhi repo along with this app that needs EFL 1.14 or better.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×