Jump to content
  • 0
Sign in to follow this  
jjbenitez

edje_cc error

Question

Hello

I use edje_decc to decc a e17 theme, and work perfect, but if i run in terminal

edje_cc Radiance/default.edc -o myRac.edj, example, i have the next error:

fireball/fireball.edc:15 unhandled keyword spectrum

Can anybody help me ?

 

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

Thanks for your answer.

My real problem is a black space in windows borders, using Radiance theme, but when i try to fix that using : http://forums.bodhilinux.com/index.php?/topic/11952-e17-radiance-theme/&do=findComment&comment=89592, i get the next error:

Radiance/edc/comp.edc:17 float -1.000 out of range of 0.000 to 1.000 inclusive

 

How i fix that problem ?

Sorry for my very bad english,

Share this post


Link to post
Share on other sites
  • 0

Looks like "-1.000" is interpreted as a negative number that is not allowed. Possibly the syntax in that lines needs some attention. Is that dash "-" needed?

 

Enjoy,

Charles

Share this post


Link to post
Share on other sites
  • 0

Yes

Have you considered to use a compositor? This should fix the problem.

Are you sure that you are using E17 version of Radiance and not the e19 one? Where do you have take the theme?

 

Last chanche.

Copy the rad_conf.edc file from Radiance theme, decompile MokshaRadiance and replace its rad_conf.edc file with the Radiance one.

 

With this you should have sqaured border with Radiance colors and not MokshaRadiance's ones.

Share this post


Link to post
Share on other sites
  • 0
Personally, I do not like compositors.
The header of file default.edc of the theme is:
 *              <RADIANCE THEME>                      *
 *                                                                       *
 * The E17 Port of the GTK Radiance theme.   *
if the theme had square edges I was happy.
How hard is this?

Share this post


Link to post
Share on other sites
  • 0

Well, when i try to build MokshaRadiance: Surprise !!

My friend the error:

edc/comp.edc:17 float -1.000 out of range of 0.000 to 1.000 inclusive
edje_cc: Error. PARSE STACK:
collections.group.parts.part.description.text.ellipsis
edje_cc: Error. PARAMS:
edje_cc: Error.   -1

HELP !!

Share this post


Link to post
Share on other sites
  • 0

How did you install said EFL version? If you are using an E version that old I'm betting your EFL version is old as well and that is why it is not working with these up to date themes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×